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Copyright Notice
© Copyright 2020 by Melco
ALL RIGHTS RESERVED No part of this publication may be reproduced, stored in a retrieval system, or
transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise)
without prior written approval of Melco. Melco reserves the right to revise this publication and to make
changes in it at any time without obligation of Melco to notify any person or organization of such revisions or changes.
All precautions have been taken to avoid errors or misrepresentations of facts, equipment, or products. However, Melco does not assume any liability to any party for loss or damage caused by errors or
omissions.
Melco Technology is protected by - but not limited to - the following patents:
• Pat. US 6,445,970 B1
• Pat. US 6,823,807
• Pat. CH 693569 A5
• Pat. US 6,736,077 B2
• Pat. US 6,732,668 B2
• Pat. US 6,871,605
• Pat. US 6,983,192 B2
• Pat. US 7,308,333 B2
• Pat. US 7,513,202
• Pat. US 8,851,001 B2
• Pat. US 9,702,070
• Other patents pending
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Introduction
DesignShop is a embroidery digitizing software. Through the use of this software, an image can be
transformed from a simple graphic into a series of machine movements and commands that will create a
beautiful embroidered product.
The digitizing software will have many embroidery specific tools and features, but many of the conventions and tools may feel familiar from other non-embroidery softwares.
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What’s New in DesignShop Version 10
v.10.05.XXX
• Added compatibility for OFM files created with DesignShop versions newer than v10.

v.10.04.XXX
• Color icons are now an option. Go to Tools>Options>Preferences to change the setting.
• Trims inside alphabet letters no longer cause indeterminate property values.
• Updated Gunold thread charts.
• True Type Modified alphabets are now functional.
• Advanced tab functionality has been added to Lite and standard levels.
• Default Property Changes - These defaults will not overwrite previously installed defaults.
• Ties in and off are defaulted to ON and use style 1.
• Tie-in width is set to 7 points with a number of stitches at 3.
• Changed satin stitch density to AUTO with a modified auto table.
• Auto Underlay is defaulted to ON with modified underlay tables.
• Changed travel stitch length to 20 points.
• "Allow Interior Entry Exit" is now OFF by default.
• Snap to Grid can be now be a default setting.
• Step and Repeat now allows negative numbers.
• EPS file handling has been improved.
• Dragging a file into DesignShop to open now works in a Windows 10 environment.
• Alphabet descenders can be included or excluded from Envelope or Perspective line types.
• Added Alphabets:
• OESCO Block
• Services Block
• Addition of the following hoops
• Mighty Hoop 6”x 4”/ 15.2cm x 10.2cm
• Mighty Hoop 3”x 9”/ 7.6cm x 22.9cm
• Melco Fast Clamp
• Hoop database will overwrite previous database upon software installation.
• Various performance improvements
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v10.03.XXX
• Check For Updates - If updates are available, the software will automatically display an update
notification. Internet connection is required for this feature.
• Update process improvements.
• Continuous underlay is now off by default.
• Keyboard shortcuts for change element type were added to the DesignShop Level.
• Various performance improvements

v10.02.XXX
• Check For Updates - Now the update link provides the option to download and view "What's
New" in the new version before choosing to update.
• Security activation instructions have been revised and simplified.
• Thread Charts Updated - R-A Super Brite Poly, R-A Super Strength Rayon, Madeira Frosted Matt,
Madeira Poly Neon
• Thread Chart Added - Iris Ultra Brite Poly
• Various performance improvements

v10.01.XXX
• Added Fanci Monogram (3 Letter)
• Added EPS handling warning dialog
• Added language support for: French, German, Italian, Portuguese, Spanish, and Dutch.
• Various performance improvements
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v10.00.XXX
• 25 New Alphabets
• New Alphabet Categories - Sorted alphabets makes it easier to find that perfect typeface. This
includes a Recent Projects category for that alphabet that you just used in the last project.
• New Alphabet Search Function - If you know the name or partially know it, type it in the alphabet
field. DesignShop will now filter by what you type!
• New Alphabet Previews - Alphabet previews now appear on screen with a full preview of the alphabet, a live preview of the selected lettering, and guidelines for embroidery alphabets.
• New Alphabet Print Function - If you would prefer to print a preview of the current alphabet or all
the embroidery alphabets in your software, you now have that option.
• New Main Screen Look & Feel - Updated icons and toolbars.
• New Digitizing & Editing Cursors - The digitizing and editing cursors have been improved, enlarged, and are now easier to see.
• New File Support - Open ART and EMB files.
• Virtual Security Keys - No more physical security keys (dongles)!
• New Open Dialog - View all supported embroidery AND graphic files at the same time.
• Updated Thread Charts - New colors and new thread color names.
• Element Naming - You can name elements and color blocks in the Project View.
• Improved Vector File Support - Rendering of vector files has been improved.
• Raster Preview of Vector Files - A raster preview of the opened vector graphic is generated and
displayed in the background of the view window.
• Mighty Hoop Support - Mighty Hoops have been added to the hoop list.
• New Hoop Tech Clamp and Frame Support - New Hoop Tech clamps and frames have been added
to the hoop list.
• Improved Help - The manual has been rewritten and newly formatted to be able to be easily printed or transfered to most tablets and some e-readers.
• Improved Icon Preview Generation
• Fully Compatible with Windows 7, Windows 8, and Window 8.1
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DesignShop Product Levels
The following DesignShop product levels are available. This table also provides a brief overview of some
of basic features available in each level. The feature availability is described in more detail throughout the
manual.
Feature
Lettering
Scaling, Mirroring, & Rotating Designs
Editing of Basic Properties (Density, Underlays)
Editing Wireframe Shapes
Editing Expanded Points
Digitizing Wireframe Shapes
Alignment Tools
Raster Graphic File Support
Vector Graphic File Support
Raster Graphic to Embroidery Conversion
Vector Graphic to Embroidery Conversion
Stock Pattern & Decorative Fills
User Created Pattern & Decorative Fills
Distortion Fill Effects
Random Stitch Lengths
Photo Fill
Cross Stitch

DesignShop DesignShop DesignShop DesignShop
Lite
(Standard)
Pro
Pro+
160+
160+
160+
160+
alphabets
alphabets
alphabets
alphabets
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
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DesignShop Screen Overview
This section will introduce you to all of the different areas of the DesignShop user interface,
and will help you become familiar with the layout of DesignShop before you begin learning
about its tools and features. When DesignShop is open, you will see a window similar to the
one below. Some icons, windows, and tabs may not be visible depending on the level of
software you are running.

Screen Overview
Video

Title Bar
The title bar is displayed at the top of the window. Displayed in this bar will be the level of software as
well as the name of the current file.
On the far right side of this bar, you have the option of minimizing the window, restoring the window, or
closing the program.
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Menu Bar
The menu bar lists drop-downs from which you can select any number of commands for the machine.
Many of these commands will also be accessible from a keyboard shortcut or an icon on the toolbars.

Toolbars
Many of the file, view, and operations are found on these bars. These bars can be moved by
clicking and dragging on the small vertical line to the left or top of each set of icons. Each
icon will display a tool tip when hovered over with a mouse. This will allow you to quickly
see what each icon does.
If these toolbars are closed, they may be reopened by going to View>Toolbars> and placing
a check mark by any that are missing.

Toolbars & Preferences
Video

Main Bar
The main bar contains mostly file options like new, open, and save. It also contains edit options like cut,
copy, and paste, undo and redo.
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View Bar
The view bar contains the zoom tools as well as view settings and editing modes.

Object Bar
The object bar contains various tools for centering a design, updated trims and ties, as well as graphic to
embroidery assistance tools.

Property Bar

The property bar shows the most common properties of any tool or element that is selected. If multiple elements are selected, only those properties that are shared between the selected elements will be
displayed.

Input Toolbar
The input toolbar contains the majority of the tools used for digitizing, editing, selecting, and sequencing
a design.
The tools on this bar will change depending on what tool or element is selected.
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Mini-Palette Toolbar
The mini palette toolbar contains much of the color information from the design file. It controls the
background color and the current color as well as stores every color used in the design. Below the design
color information is a pool of color swatches for a quick color preview.

Zoom Bar
The zoom bar shows the zoom level as well as the X/Y location of the cursor. It will also display the length
and angle between input points as an element is digitized.

Scale Bar
The scale bar contains information on the size and stitch count of the design or currently selected element(s). It can be used to scale, rotate, or mirror a design or element.
This bar will be replaced with a status update when a digitizing tool is used.

Slow Redraw Bar
The slow redraw bar allows the user to "play" the design on screen as if it were sewing out. The speed is
controlled by the number beside the play button.

Right-click on the step buttons to access and adjust the step increments.
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View Window
The View Window acts as the main workspace for digitizing and editing. A preview of the project is
displayed.

When a project is open, right-clicking in a blank area of the view window will bring up a selection context menu. This menu mostly contains input tools.
If multiple projects are open, each project will have a view window. Typically these are layered, but they
can be tiled or rearranged. The Window menu provides the option for tiling or cascading these windows.

Changing the Workspace Size
The size of the workspace in the view window can be altered by the
following steps:
1. Select the project in the project view.
2. Right-click on the selected project and choose "Project" from
the context menu.
3. Change the workspace area dimensions.
4. Click OK.
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Project View
Typically found on the right side of the screen, the project view contains non-visual information about the
design. The sew sequence, color information, and element types are all visible here.

•

If the project view is closed, go to View>Project Views and select "Project View 1" to retrieve it.

The size of the elements in the project view may be adjusted by right-clicking and selecting Tree Image
Size from the context menu.
The background color of the project view may be altered by right-clicking and selecting Tree Background
Color from the context menu.
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Working With Files
This section describes how to open, save, close, and create new projects or embroidery files.

Opening Files
An embroidery file is opened using the Open command. This command is accessible in the following
ways:
• Click on File>Open
• Click on the Open button on the main toolbar.

• Use the keyboard shortcut of CTRL + O.
Using any of the above methods will bring up an open dialog box.

The open dialog box allows you to browse your computer to find your desired file.
The right side of the dialog box displays a preview, if available, of the selected design file. If the selected
file has an OFM extension, below the preview will display information about the file included the date
created, the OFM version, the stitch count, and the dimensions.

Files of Type
The Files of Type drop-down menu allows you to choose what type of files are visible within
the open dialog box. The choices consist of the following:
• All Embroidery Files
Embroidery Files
Video

• All Graphics
• Specific Single File Types
• All Files (including unsupported file types)
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Supported Embroidery File Types for Open
The following are supported embroidery file types for Open and their extensions.
Extension File Types
.ofm
Melco Project
.cnd
Melco Condensed (v7 and earlier)
Melco Condensed (v9 and later)
.exp
Melco Expanded
.dst
Tajima
.fdr
Barudan FDR
.fmc
Barudan FMC
.zsk
ZSK
.pes
Baby Lock / Bernina / Brother
.pec
Baby Lock / Bernina / Brother
.sew
Elna / Janome
.jef
Janome
.jef+
Janome +
.pcs
Pfaff
.pcm
Pfaff Macintosh
.csd
Poem / Singer Embroidery Unlimited
.xxx
Singer
.hus
Viking
.oef
OESD
.pat
Saurer SHC
.gnc
Great Notions Condensed
.emd
Elna
.shv
Viking D1
.vip
Husqvarna / Viking
.dsz
ZSK DSZ
.psf
Pulse PSF
.emb
Wilcom
.art
Bernina Artista
.art 50 Bernina Artista
.art60
Bernina Artista
.art70
Bernina Artista
.art42
OESD Explorations
.jan
Janome Designer

Opens as data type
Wireframe
Wireframe (simple fills)
Wireframe (manual stitches)
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded

21 of 218
Table of Contents

Saving a File
You can save the active (the file that is open and has focus) file in the following ways:
• Click on File>Save
• Click on the Save button on the main toolbar.

• Use the keyboard shortcut of CTRL + S.
Saving a file in this way will save the active file with its current file name, location, and format. If this is
the first time saving, the Save As dialog box will appear.

Save As...
You can save the active file with new properties or name by selecting to "Save As..." To save a file using
the Save As dialog box, click on File>Save As...
Doing this will bring up the Save As dialog box.

Using this dialog, you'll need to:
5. Specify the file location by navigating to the desired folder or drive.
6. Specify the file name by typing it into the file name field.
7. Specify the file type by selecting it from the Save as Type drop-down menu.
• .ofm file type will be the default.
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Supported Embroidery File Types for Save As...
The following are supported embroidery file types for Save As... and their extensions.
Extension File Types
.ofm
Melco Universal OFM
.cnd
Melco Condensed (v7 and earlier)
Melco Condensed (v9 and later)
.exp
Melco Expanded
.dst
Tajima
.fdr
Barudan FDR
.fmc
Barudan FMC
.zsk
ZSK
.pes
Baby Lock / Bernina / Brother
.pec
Baby Lock / Bernina / Brother
.sew
Elna / Janome
.emd
Elna
.jef
Janome
.pcs
Pfaff
.pcm
Pfaff Macintosh
.csd
Poem / Singer Embroidery Unlimited
.xxx
Singer
.hus
Viking
.shv
Viking D1
.gnc
Great Notions Condensed
.vip
Husqvarna / Viking
.dsz
ZSK DSZ

Opens as data type
Wireframe
Wireframe (simple fills)
Wireframe (manual stitches)
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded
Expanded

When saving in the Tajima format, the file's internal file name can be entered in the Sav As dialog (in the
Tajima Internal Filename field. If this field is left blank, the internal file name will be changed to match the
Windows file name.
Universal OFM
The Universal OFM file format allows the file to be read by all versions of DesignShop. DesignShop versions that are older than the version of DesignShop the file was saved with will usually read the data as
expanded. Versions of DesignShop that are the same or newer than the version the file was saved with
will usually read the file as wireframe data.

23 of 218
Table of Contents

Auto Save
When working with computer files, it is usually a good idea to save your work often. You may wish to
turn on the Auto Save feature in the software. This feature is not the same as clicking the save button
every three minutes.
The Auto Save feature creates an automatically saved temporary backup version of the file. It does not
save over the file with the original file name. Should the software encounter an error and be forced to
close, an recover window will come up when the software is launched again.
Because the file is a temporary backup, if used for recovery, the file should be saved under a new name
in a more permanent location.
To use the auto save feature, go to Tools>Options>File Options Tab. The Auto Save is under the File
Options tab.

In this tab, you can check the box to enable the auto save as well as specify how often you would like the
auto save to occur.

Creating a New File
A new embroidery file is created using the New command. This command is accessible in the following
ways:
• Click on File>New
• Click on the New button on the main toolbar.

• Use the keyboard shortcut of CTRL + N.
Creating a new project creates a blank project based on the default settings in which to work.

Inserting a File
The Insert command places a complete project from an embroidery file or graphic file into the existing
open file. To insert a file into the active project, use one of the following:
• Click on File>Insert
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• Click on the Insert button on the main toolbar.

• Use the keyboard shortcut of CTRL + Insert.
The inserted file will appear in the Project Tab as its own design.

•

The supported file types for Insert are the same as for Open.

Loading a File to a Machine
A file may be sent to an embroidery machine that is enabled to receive files directly from DesignShop.
The support of this feature is machine specific.
To load a file to a machine:
1. Go to File>Machine>Load Design.
2. This will send the design to the machine operating software and load the design.
Sending a Design to a Machine Queue
To send a design to a machine queue:
1. Go to File>Machine
2. Selecting from the following:
• Queue Current Design - This will add the current design to the design queue for the machine.
• Queue All Open Designs - This will add all the designs open in the software to the queue for
the machine.
• Queue Selection - This will add the currently selected element(s) to the machine queue as a
design.

Closing a File
An embroidery file is closed using the Close command. This command is accessible in the following ways:
• Click on File>Close
• Click on the Close button on the menu bar.

If changes have been made since the last save, a prompt to save will appear when the close command is
used.
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Graphics File Support
The types of graphic files that can be opened, inserted, or saved as depend on the level of
software.
Art File Types
Video

Extension
.bmp
.jpg / .jpeg
.tif / .tiff
.png
.pcx
.eps
.emf
.svg
.svgz

File Types
Windows Bitmap
Joint Photographic Experts Group
Tagged Image File Format
Portable Network Graphics
Personal Computer eXchange
Encapsulated PostScript
Enhanced Meta File
Scalable Vector Graphics
Scalable Vector Graphics (Compressed)

Data Type
Raster
Raster
Raster
Raster
Raster
Compound
Vector
Vector
Vector

DS Lite

DS
•
•
•
•
•

DS Pro
•
•
•
•
•

DS Pro+
•
•
•
•
•
•
•
•
•

To open or insert any of these graphic file formats, change your files of type to "All Graphics" to better
see the files. If files of type is set to "All Embroidery Files", none of the graphic files will be visible.

Vector Import/Export Options
In both the open dialog box and the file options tab under Tools>Options, you will find the Vector
Options button. Clicking on this button will bring up the Vector Import/Export Options.
Import Options
For importing, there are two options.
• Convert to Vector Objects
This option, when checked, brings in the vector data as
essentially wireframe elements without stitch information. All of the outlines and layering are brought into
the project, but the elements lack the stitch properties
to be full embroidery.
Unchecked, this option brings the graphic information
into the project as a flat rasterized image.
• Auto-Sequence
When this option is checked, the order of the elements within the file will be rearrange in an attempt to create a more efficient embroidery project.
When checked, an Options button appears for this feature. Clicking on the options button will
bring up the Auto-Sequence properties and options.
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Export Options
Export options affect both the saving of vector files and the copying from DesignShop and pasting into a
vector illustration program. When referencing the clipboard, this is where data is placed when the copy
or cut function is used in software.
• Place AICB(eps) on clipboard
This option, when checked, indicates the AICB (Adobe Illustrator ClipBoard)data should be placed
on the clipboard. Since many vector illustration programs use this type of data, it is often best
when used in conjunction with those types of programs.
• Place EMF on clipboard
This option places EMF data on the clipboard. Most programs support EMF data.
• Color Space
This option indicates whether the color data is stored as RBG or CMYK upon saving as an EPS file.
RGB data is saved as Red, Green, and Blue. The spectrum for this color space is much larger than CMYK.
CMYK data is saved as Cyan, Yellow, Magenta, and the Key (or Black). This color space is more
limited in gamut than RGB, but is more accurate for printing on printers.
• Add Embroidery Data (EPS Only)
If checked, this option adds special tag objects that are copied to the clipboard or saved into and
EPS. This allows for a limited amount of stitch information to be maintained when copied back to
the project.

•

When using lettering features in vector illustration programs, it is best to convert the lettering
objects to outlines before saving or copying. If the lettering objects are not converted to outlines, the lettering will be reinterpreted by DesignShop using the fonts available to the software.

Raster Graphic Options
When opening raster files, you have the option of opening them at the resolution stored in the files. This option appears as a check box in the open dialog or
under the files options tab from Tools>Options.
Additionally under the file options tab, you can select the resolution you would
prefer raster graphics to be opened at and saved at. The same number affects
both open and save.
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Scanning and Image into DesignShop
If desired, an image may be scanned directly into DesignShop. This function works with any scanner tha
complies with the TWAIN scanning industry standard communications format. To enable the scanning
function in DesignShop, you must have the appropriate level of software an a TWAIN compatible scanner
connected to the computer.

•

TWAIN 32 compatible scanners are not the same as TWAIN compatible scanner and cannot be
utilized with DesignShop.

•

Melco cannot provide technical support for any scanner. Technical assistance for scanners must
be obtained through the manufacturer or dealer.

If the scanner that is attached to the computer is not compatible with DesignShop, it is still possible to
use it with another program and save the image as a file that DesignShop can utilize. See the supported
graphics table for more information.

Select Scanner
Located under the file menu, the Select Scanner function only needs to be performed prior to your initial
scan. You will not need to return to this function unless you add a scanner or wish to change scanners.
To select a scanner for use with DesignShop:
1. With a new project open, go to File>Select Scanner.
2. Select the scanner from the select source dialog box.
• If the scanner does not appear in the sources list, use the following list to help diagnose the
issue.
• For the Select Scanner function to identify the available TWAIN compatible scanners attached to the computer system, the TWAIN software that came with your scanner must
first be properly installed and configured for your system.
• Melco has found that a common mistake is the failure to add the path for your scanner to
the autoexec.bat file.
• Refer to your scanner manual and the Microsoft Windows User's Guide for information on
modifying the autoexec.bat file.
3. Click on the Select button to choose the scanner and return to the current DesignShop window.
4. From this point forward, this will be the source used for the Scan function. This can be altered byt
going to Select Scanner again.
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Scan
DesignShop does not directly interface with any scanner. When the Scan function is selected, DesignShop
launches the scanner's software to perform the scan and return the image to DesignShop. Since this interface depends on the software used with the scanner, please refer to that documentation for scanning
operation.
To scan and image into DesignShop:
1. Go to the file menu and select Scan.
2. Use the software for the scanner to initialize the scan.
3. When the scan is complete, close the scanning software and the image will be returned to
DesignShop and displayed in the view window and project view.

•

Higher resolution images will consume good amounts of computer memory and may slow lesser equipped systems.

Adding Notes to a File
Notes can be added to a file and stored electronically. This can be a convenient way to store information
about how the design was digitized, what types of backing, material, needles, and thread were intended
for use with the design, or whatever other information might be important.
To create notes, do one of the following:
• Click on View>Design Notes
• Click on the Notes button on the main toolbar.

This will launch a simple text editor in which your notes may be typed.
Click OK to close the editor and keep the notes. Remember to save the file as well, or else the notes will be lost.

Send Files Via E-mail
To send the active project to another person via e-mail,
1. Save the embroidery file.
2. Go to File>Send.
This will launch your default e-mail client on your computer (if applicable) and create a new e-mail with
the current project file as an attachment.
Alternatively, you could,
1. Save the embroidery file.
2. Create a new e-mail message.
3. Attach the file as an e-mail attachment.
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Printing Files (Run Sheets & Previews)
Printing a version of the embroidery project on paper may be
helpful in keeping orders organized.
The print command is accessible in the following ways:
• Click on File>Print
• Click on the New button on the main toolbar.

• Use the keyboard shortcut of CTRL + P.
Using the print command will bring up a print dialog box.
From here you will need to choose the printer from the drop-down
menu as well as your printing preferences. What of the design would you prefer to print? Choose by adding
checks to the elements you wish to print.
• Print Design
This prints the design. If a three dimensional rendered is preferred, press the "Show Stitches in
3D" button prior to starting the print process.
You will also need to choose how you want the design to fit on the paper. From the drop-down
beside the option, you can choose fill the page or print at actual size.
• Print Background
If you desire the design to be on a colored background, set the background color prior to starting
the print process and then check this box.
• Print Origin & Print Grid
Both options will be greyed out unless the grid or origin is visible in the view window. If you want
to print them, be sure to turn on the features before printing.
• Print Status/Notes
This will print status information such as trim count, color sequence, and any notes stored in the file.
• Print Logo
Should you like to personalize your print-outs, you may include an image file to print. To include
the image, click on the browse button to locate the image file you'd like to use. The image will be
centered at the top of the page and is alloted 7.2" x 1.2" of space. All scaling must be done prior
to browsing for the file.
Print Preview
To preview what the print-out would look like, go to File>Print Preview. A Preview of the print-out will
appear in the view window.
Print Setup
Going to File>Print Setup allows you access to all of the print options without actually printing.
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Embroidery File Types
There are two main types of embroidery files. Almost all of the extensions and file types fall
into one of the following two categories.

Wireframe Files

Embroidery Files
Video

Wireframe files keep the projects in outlined elements with stitch properties. This makes
them easier to manipulate, scale, and edit. When working with wireframe projects, you will be dealing
mainly with either an OFM or a CND file extension. Not all features of wireframe work the same between
the file types. Below is a list of the features.
Feature
Elements are outlined shapes that contain element properties like density, stitch
length, and stitch directions.
Element properties can be edited.
Element shapes can be edited.
Can contain intact lettering. You can change the spelling, typeface, size, and
other properties.
Can contain design notes.
Color information can be stored.
Some machine settings may be stored.

•

CND
*

OFM
•

*
*

•
•
•
•
•
•

* CND files saved in DesignShop V7 and earlier will contain wireframe shapes but may not
contain the exact fill properties and stitch locations. CND files save in DesignShop V9 and later
will match the original stitches exactly, but that is accomplished with the use of a manual stitch.
This renders the embroidery file closer to that of a stitch file.

Scaling a Wireframe File
Scaling a wireframe file is usually more successful than scaling a stitch file. The outline is scaled and the
stitches will then be recalculated. Try to keep the scaling within 25% of the original wireframe design for
the best results.

•

If design elements are pushing the limits of what is possible with stitches, scaling a design
down will result in thread breaks. If stitches are already the length of the diameter of the needle they are being sewn with, scaling the stitches down will make them smaller than the needle
and create problems.

Project Tab
Wireframe information in the project tab will typically show up as a list of elements. You will see elements like "Column 2" or "Complex Fill".
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Stitch Files
Stitch files do not contain properties. They are purely plotted-out needle penetrations. The colors that
show up in DesignShop are generated from the default colors.
Expanded data can be held inside an OFM, but it remains plotted stitches. Editing stitch information is
done by either stitch editing each needle penetration or using the Expanded Stitch Processor or using the
Convert to Wireframe function.

Scaling a Stitch File
Stitch files can usually be scaled close to 10% up or down in size. Using the Expanded Stitch Processor,
you can occasionally push that percentage closer to 20%.

Expanded Stitch Processor
The Expanded Stitch Processor essentially converts expanded data to wireframe in order to maintain densities while scaling. This may change the pattern in some fills.
The Expanded Stitch Processor is located under the right-click scale menu. If you select and element or
elements, right-click and the select "Scale", you will see the Scale tab. Under the main top section for
scaling the size of the design, there is the check box for Expanded Stitch Processing. Check this box to
enable the processing when scaling expanded designs.

Project Tab
Stitch information for stitch files will show as "Expanded Data" in the project tab of DesignShop.

File Extensions
The table in the Opening Files section lists how different extensions are brought into DesignShop.
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Project View
Typically found on the right side of the screen, the project view contains non-visual information about the design. Within the project view are three tabs: the project tab, the stitches tab, and the navigator tab. These tabs are accessed from the bottom of the project view.
Project View
Video

The project view can be detached from the side of the screen and moved to another monitor or elsewhere on screen. To do this click and drag the title bar of the window (no words exist in the project view
title bar). Once detached, the project view can be moved to the desired area. Double-clicking on the title
bar will return the project view to the original docked position.

•

If the project view is closed, go to View>Project Views and select "Project View 1" to retrieve it.

Project Tab
The project tab contains a list of elements found in the design. The order in which these elements are
displayed determine the order in which they sew.
Elements and range of elements may also be selected from the project tab. By selecting elements in the
project view, you can make adjustments to the properties of large or small sections of a project.
The project tab functions in tier levels. If you select at a level, you can affect all subsequent levels and
elements. These levels may be collapsed or expanded by clicking the expand or collapse button to the left
of the individual levels.
Expand All and Collapse All buttons are available at the top of the project tab.

•

To navigate through the element list of the project tab, you can use the scroll wheel of a
mouse, or the arrow keys, the Home, End, Page Up, and Page Down buttons on the keyboard.
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Project Tab Levels
1. Project Level
Selecting at the project level will select everything within the project.
Doing so will allow you to affect every element within that project.
2. Design Level
The next level down is the design level. Though uncommon, more than
one design can be in a project file. This allows you to select an entire
design by leave any other designs within the project untouched.
3. Color Level
The next level is the color. By clicking on a color block in the project view, you can select the entire
contents of that color block. This would allow you to make changes to every element within that
color block without affecting any other elements.
This works with color blocks. If the same color of red is used three times in a project, selecting a
red color block will only affect one of the three red color blocks. It will not affect every red element in a design.
4. Element Level
Individual elements may also be selected. By expanding a color level, you will have access to the
individual elements. These elements will be labeled by element type (Column 2, Complex Fill, Walk
Normal, etc.). Projects typically contain a variety of element types.

Show/Hide
Sections of a project may be hidden from view if desired. This does not delete the elements and if loaded to a machine, the stitches would sew. Hiding
element is useful when digitizing over artwork that already has stitching over
it. You can hide the stitches to easily view the artwork again. Hiding stitches
is also useful when editing stitches that are later covered up. Hiding the covering stitches allows for easy editing access to the stitches underneath.
To the left of each level and element, two small squares exist. The left
square is the show/hide box. To show or hide elements, click in the
show/hide box to the left of the level that you wish to show or hide. If
an eye is in the box, the level/element will be visible. If the box is empty, the level/element will be hidden.
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Lock Elements
Sections of a project may be locked to prevent accidental selecting or moving. Locked elements will not move or be selected from the view window.
They can still be selected and properties altered from the project view.
To the left of each level and element, two small squares exist. The right
square is the lock box. To lock or unlock elements, click in the lock box
to the left of the level or element that you wish to lock. If an padlock
is in the box, the level/element will be locked. If the box is empty, the
level/element will be unlocked.
Elements can also be locked or unlocked by selecting elements and choosing Object>(Un)Lock Element.
If you mouse over a selected locked element in the view window, a locked cursor will appear. This is just
to indicate that the selected element is locked and cannot be moved.
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Project Tab Functions
Along the top of the project tab you will find a series of buttons that change what is visible in the project
tab as well as how colors and groups behave.
Expand/Collapse All Colors
The first button at the top of the project tab expands all the levels in
the project tab to display everything at the element level.
The second button at the top of the project tab collapses the projects
elements to display everything at the color level.
Auto Merge Color Blocks
The first button at the top of the project tab is the auto merge color
blocks button. The auto merge color blocks button will automatically
combine any back-to-back identical color blocks. Often this is view as
more efficient . This button will remain pressed until it is clicked again.
Group & Ungroup
The fourth button at the top of the project tab is the group button.
This button allows you to group multiple selected elements into a single group. If one element within a group is selected, all elements within
that group also become selected.
The arrow to the right of the group button provides a drop-down
menu from which any group in the design may be selected.

Grouping Video

When a group is selected, it may be ungrouped by clicking on the fifth
button at the top of the project tab.
Grouping and ungrouping elements only changes how those elements behave when being selected. It
does not change the sew order of the project.
Toggle Stitches Tab
The sixth button at the top of the project tab is the Toggle Stitches Tab
button. This button allows the stitches tab to share space with the project tab and have both the element list and the stitch list visible at the
same time. As this tends to take up a good deal of screen real estate, it
may be best to have the project view on a separate monitor when using this feature.
Toggle Point List
The seventh button at the top of the project tab is the Toggle Point List
button. This button grants access to the input (wireframe) point list for
elements. Usually the element level is the finest level of detail in the
list. Using the point list expands the element list with one more level
of detail. The point list details the X/Y location and point type for every input point in an element. The
individual points can then be selected and altered from the project view.
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Right-Click Context Menu
Right-clicking within the project tab will bring up a context menu in which you can access several functions. Most of these functions are also available from menus and toolbars as well.

Merge Color Blocks
To the right of each color block is the merge icon. Clicking on this will
merge the color block into the one above it. This will eliminate the color change command sent to the machine and make the elements from
both original blocks the same color.
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Stitches Tab
The second tab in the project view is the stitches tab. This
lists out every stitch in a design. It is listed in table form.
Explanations of the columns are below.
#, X,Y - Stitch Number and Position
This column lists first the stitch number, then the X or horizontal position in relation to the origin, followed by the Y or
vertical position in relation to the origin.
At the beginning of an element, it will list the element type.
rX - Change in X
This column lists the Delta or change/difference in X or horizontal position from the previous needle penetration.
rY - Change in Y
This column lists the Delta or change/difference in Y or vertical
position from the previous needle penetration.
L - Length
This column lists the Length of the stitch or the distance between the needle penetrations.
S - Stitch Type or Status
The last column lists the stitch type or status. In it, you will
find the following:
• (RO) - Read Only - These stitches are unable to be
manipulated. If you switch to expanded stitch editing
mode, the (RO) goes away and you will be able to edit
the individual stitch penetration locations.
• Jmp - Jump stitches - These are locations that the machine will move to without stitching.
• TI - Tie In Stitches - These are ties stitches at the beginning of elements created using the properties dialog box.
• TO - Tie Off Stitches - These are ties stitches at the end of elements created using the properties
dialog box.

•

To navigate through the element list of the project tab, you can use the scroll wheel of a
mouse, or the arrow keys, the Home, End, Page Up, and Page Down buttons on the keyboard.
Using the arrow keys will move one stitch at a time. The arrow keys while holding ALT will
move ten stitches, and the arrow keys while holding CTRL will move one hundred stitches.
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Navigator Tab
The third tab of the project view displays the design and view window in
relation to the workspace. The red box represents the view window borders.
Moving the View Window
By clicking and dragging the red box, you can change the position of the
view window in relation to the design.
Zoom Within the Navigator
To change the zoom level while in the navigator tab, hold CTRL and click
and drag a box withing the navigator tab. When you release the mouse
button, a new size of box will be displayed, and the view window will match
the contents of that box.
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Navigating the Workspace
There are many ways to customize your workspace and view your designs the way that you prefer.
Showing or hiding guides, hoop outlines, or certain types of stitches can be helpful when editing or preparing a design for embroidery. The View Toolbar will be the toolbar most used in adjust what appears in
the view window of the softwares. If it is not visible, go to View>Toolbars> and ensure there is a checkmark by "view".

Measurement Units
You have the option of changing the measurement units in the software for multiple properties.
To access this, go to Tools>Options and select the Measurement Units Tab.

From the measurement units tab, you can select different measurement units for different properties. It is
common for embroiderers and digitizers to have some properties as inches and others in points.

1 Point =
1 mm =
1 cm =
1 Inch =
1 Pouce =

Point

mm

cm

Inch

1
10
100
254
270.7

0.1
1
10
25.4
27.07

0.01
0.1
1
2.54
2.707

0.003937
0.03937
0.3937
1
1.066

Table for Measurement Conversion

Ruler
The ruler tool can be used to measure anything
in the view window and read the actual length.
To use the ruler tool:
1. Select it from the toolbar.
2. Click and drag across the object to be measured in the view window.
3. The length will be displayed beside the ruler.
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French Inch
(Pouce)
0.0036941
0.0369412
0.3694126
0.9380863
1

Display Hoop (Limits)
Displaying the hoop limits of the hoop you intend on using is a great way to avoid surprises when moving to the machine to start embroidering. It allows you to make sure that everything you think will fit
within the hoop actually will.
Select the Hoop Size
To select the hoop you plan on using:
1. Right-click on the display hoop icon.
2. This will bring up the hoop manager window.
3. The defaults are set to support Melco machines. Make
sure that the Machine Manufacturer and Machine
Name are set appropriately.

•

Note: The XTS and XT are listed as associated machines under the EMT 16 hoops. The hoops used on
the XT and XTS are listed under the EMT.

4. Select the hoop name/size from the Hoop Name drop-down menu.
5. Click OK.
Display Currently Selected Hoop
Display the currently selected hoop by one of the following:
• Click the display hoop icon on the view toolbar.
• Go to View>Display Hoop
To hide the hoop, do either of the above a second time.

This will display the currently selected hoop on screen. The
solid line(s) represent the physical hoop. The dotted line represents the hoop limit. This is as close as the machine can sew
to the hoop wall without risk of striking the hoop.
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Display Origin
The origin is typically displayed as the center of the workspace. The coordinates by default are (0,0) and
the lines displayed show horizontal and vertical center.
Display the origin by doing one of the following:
• Click the display origin icon on the view toolbar.
• Go to View>Display Origin
• Check the Show Origin box in Grid Properties Tab
To hide the origin, do either of the above a second time.

Origin Properties
To access properties and defaults for this tool, rightclick on the icon. This will bring up the Grid tab and
the origin properties.
• Show Origin - The Show Origin check box
shows or hides the origin.
• Origin Type - The Origin Type displays the origin
as either a solid or dotted line with dots falling
along the grid subdivisions.
• Origin Color - The Origin Color allows you to
select the color in which the origin is displayed.
Click on the color swatch to change.
• Place Origin At - This drop-down menu allows you to choose where the origin is to be
displayed.
• Center - displays the origin at the coordinates (0,0).
• First Stitch - displays the origin at the coordinates of the first stitch.
• Display Above Elements - This check box affects both the origin and the grid. Checking it will display both the grid and origin (if visible) as an overlay to the embroidery design elements.
• Save As Default - Saves the current settings to the defaults for the software.
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Display Grid
A grid can be used to help align or space elements in a design. Since zoom levels can minimize any sense
of scale, displaying a grid may help keep the relationship of the size of the elements to the actual size of
the needle and threads they will be sewn with.
Display the grid by doing one of the following:
• Click the display grid icon on the view toolbar.
• Go to View>Display Grid
• Check the Show Grid box in Grid Properties Tab
To hide the grid, do either of the above a second time.

Grid Properties
To access properties and defaults for this tool, rightclick on the icon. This will bring up the Grid tab and
the origin properties.
• Show Origin - The Show Origin check box
shows or hides the origin.
• Method - The method offers the choice of what
lines are displayed in the grid.
• Horizontal only
• Vertical only
• Both (Horizontal and Vertical lines)
• Grid Spacing - The grid spacing can be adjusted
here. Enter your desired spacing for the main
grid lines in these fields. Horizontal and vertical spacing can be adjusted independently.
Measurement units can be changed by going
to Tools>Options>Measurement Units tab.
• Grid Subdivisions - set the number of subdivisions you would prefer between the main grid lines.
• Grid Color - The Grid Color allows you to select the color in which the grid is displayed. Click on
the color swatch to change.
• Grid Type - The Grid Type displays the grid as either a solid or dotted line with dots falling along
the grid subdivisions.
• Display Above Elements - This check box affects both the origin and the grid. Checking it will display both the grid and origin (if visible) as an overlay to the embroidery design elements.
• Save As Default - Saves the current settings to the defaults for the software.

43 of 218
Table of Contents

Snap to Grid Mode
Snap to Grid can be useful when digitizing. The grid needs only to be spaced the way you would prefer
it. It does not need to be visible to utilize Snap to Grid.
When Snap to Grid is enabled, the input points created while digitizing will "snap" to the closest grid
intersection point.
• To enable Snap to Grid, go to View>Snap to Grid. A check mark will be displayed if it is enabled.
Repeating the process will disable the feature.
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Show Stitches in 3D
Viewing the stitches in the view window in 3D is an easy way to quickly see the thread layering and stitch
types. Satin and fill stitches tend to look the same in the view window until 3D is enabled.
Show Stitches in 3D renders the stitches as if they were dimensional instead of thin flat lines. It can be
used to give you and approximation of what the embroidery might look like.
Enable 3D by clicking the Show Stitches in 3D icon on the view toolbar. To show the stitches as thin flat
lines again, click the icon a second time.

3D Settings
To access settings and defaults for this tool, right-click
on the icon. This will bring up the 3D Settings window.
• Enable Hardware Acceleration - This option
allows the processing unit on the graphics card
in your computer to greatly assist in the rendering of the graphics as opposed to asking the
software emulation to do the majority of the
rendering work.
• Slow Draw On Toggle - When enabled, this
option draws the embroidery design slowly as
if being stitched when the 3D button is clicked.
The speed of the slow draw is altered by changing the number in the field to the right.
• Enable Textures - This options gives the thread
a bit of texture when rendered in 3D. Without
this option enabled, the thread appears completely smooth and rounded.
• Enable Twists - This options gives the thread a twisted appearance, meant to mimic the physical
twist of real thread. This option is only visible at the "High Quality Zoom Level"
• High Quality Zoom Level - This sets the level at which the twists, if enabled, get applied.
• Thread Width - This setting determines the width that the thread is depicted with in 3D.
• Reset - This resets the 3D settings to the factory defaults.

•

If the stitches are being shown in 3D, they will print rendered the same way. If the 3D rendering
is turned off, they will print as thin lines.
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Show/Hide Graphic
If a graphic is used in an embroidery project, it is typically used as a starting point for digitizing. It is often
useful to hide the graphic to just see the stitches and then show it again to continue digitizing or editing.
If no graphic file exists in the project, this icon will be greyed out.
To show or hide the graphic, do one of the following:
• Click the show/hide graphic icon on the view toolbar.

• Use the show/hide box to the left of the graphic file in the project view.

Show/Hide Stitches
It is occasionally useful to hide and show stitches or groups of stitches within an embroidery project. This
allows you to more easily see what stitches may fall underneath top stitches or layers.
To show or hide the stitches, do one of the following:
• Click the show/hide stitches icon on the view toolbar.

• Use the show/hide box to the left of the design, color, or element(s) in the project view.
• Go to View>Show Selected, Hide Selected, Hide Non-Selected, or Show All for more show/hide
flexibility.

Toggle Connectors
The toggle connectors feature better shows trimmed and untrimmed threads. When enabled, leftover
threads between elements (connectors) will be show. When disabled, only threads contained within elements will be shown.
To show or hide the connectors, click the toggle connectors icon on the view toolbar.

Toggle Expanded Points
Only available when stitch elements are selected, this option displays each needle penetration as a tiny
plus (+) sign. It is meant to show, not edit, where the needle penetrations are.
To show or hide the connectors, click the toggle expanded points icon on the view toolbar with embroidery element(s) selected.
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Zoom Functions
Changing the zoom level on a design helps you better see what you are doing when editing or digitizing. There are several zoom functions built into your software.

Zoom Tools

Zoom Video

On the view toolbar, there is a series of zoom tools. These tools are also available in the view menu.
• Graphical Zoom - The graphical zoom tool allows you to click and drag a box. When the mouse
button is released, the zoom level will change to fill the view window with the contents of that
drawn box.
To use graphical zoom, click on the tool in the view toolbar. Then using the tool, click and drag a
box within the view window.

• Zoom In - The zoom in button increases the zoom level to approximately 150% of the current
zoom level with every click.

• Zoom Out - The zoom out button decreases the zoom level to approximately 67% of the current
zoom level with every click.

• Actual Size - The actual size button sets the zoom level to 100%.

• Fit Window - The fit window button sets the zoom level to fit/fill the project within the view window at the highest zoom level possible.

• Fit Selection - The fit selection button sets the zoom level to fit/fill the currently selected element(s)
within the view window at the highest zoom level possible. This button is greyed out if nothing is
selected.

• Center Selection - The center selection button does not alter the zoom level. It shifts the view
window to center upon the currently selected element(s). This button is greyed out if nothing is
selected.

• Zoom Previous - The zoom previous button sets the zoom level to the last zoom level used in the
current project.
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Zoom Bar
The zoom bar shows the zoom level as well as the X/Y location of the cursor. It will also display the length
and angle between input points as an element is digitized.

• Zoom Level - The zoom level can be changed by selecting a new level from the drop-down menu
or typing a desired level within the box and press the Enter key.

• X/Y Position - In this field, the X/Y position of the cursor is displayed. As the cursor is moved
around the view window, these values will change.

• Length & Angle - As an element is being digitized, this field will display the Length and Angle
from the previous input point.

Mouse Zoom/Pan/Scroll Functions
Often it may be more convenient to use the mouse and scroll wheel rather than toolbars to scroll and
zoom. Using the scroll wheel of the mouse and the keyboard, a variety of functions may be utilized.
Function
Scroll Vertically
Scroll Horizontally (Pan)
Zoom to/from Screen Center
Zoom to/from Cursor

Action
Roll mouse scroll wheel
Roll mouse scroll wheel
Roll mouse scroll wheel
Roll mouse scroll wheel
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Key Command
None
+ CTRL
+ ALT
+ Shift

Manipulating Elements
When working in a project, it is common to select an element or elements and need to rotate, scale or
move them to a new position or sew order within the project. This section will detail how to accomplish
all of these things.

Selecting Wireframe Elements
Elements can be selected either in the view window or in the project view.
Selected elements are displayed with more intense color and slightly bolder line in the view
window. They are highlighted in the project view.

Selecting a Wireframe Element in the View Window

Selection Tools
Video

To select an element in the project view, left click on the desired element. When
an element is selected, it will be displayed with the resize/edit box around it.
This box has an opaque box in each corner and on the center of each side. The
edges of the box rest just at the outer edges of the element stitches.
When a single element is selected in wireframe editing mode (default), the
input, entry, and exit points of the element will also be displayed. The last
stitch of the previous element is displayed as well.

•

Keep in mind that only the top-most layer of stitches will be able to be selected when clicking
on an element in the project view. To select lower layers of stitches, other tools such as the element lock, hide, or select previous element will need to be used. In many ways it is like placing
a finger on the physical embroidery. You can only select what you can touch.

Selecting Multiple Wireframe Elements in the View Window
You can select multiple elements in the view window by either of the following methods.
• Click & Drag a Box - With the left mouse button, click and drag a box around the elements you
want to select. This method is exempt from the layer limitations listed above.
• Custom Point Selection Tool - The custom point selection tool is located on the input toolbar. When selected, the cursor changes to match the icon. Use the tool to click and drag
a line around the elements that you want to select. The shape created can be any shape.
When the line is almost fully enclosing the desired elements, left go of the mouse button
and press the Enter key. This will complete the shape and select the enclosed elements. It
will also deselect the custom point selection tool.
• CTRL + Click - Holding the CTRL button while left-clicking on elements will select multiple
elements. This method of selection is subject to the same layer limitations listed above.
When multiple elements are selected in wireframe editing mode, the resize edit box is displayed
around all the selected elements. The individual element boxes are shown as dashed lines and no
input points are displayed.
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Selecting Wireframe Elements in the Project View
Single elements in the project view by clicking on the element (preview, number, or name). The selected element will then be highlighted in the project view and displayed with a resize/edit box in the view
window.

Selecting Multiple Wireframe Elements in the Project View
Multiple elements may be selected in the project view by the following
methods.
• CTRL + Click - Select Non-Consecutive Elements - Click on a single
element. Hold CTRL and click on any other elements that you would
like to select. This will select only those elements clicked.
• Shift + Click - Select Consecutive Elements - Click on a single element. Hold CTRL and click on another element. This will select these
two elements and all elements in between.
• Select Same Type - Right-click on a selected element and choose Select>Select Same Type from
the context menu. This will select all of that type of element within a project. This is also available
under the Edit menu.
• Select Entire Design - Right-click on a selected element and choose Select>Select Entire Design
from the context menu. This will select the entire design of which that element is a part. This is
also available under the Edit menu.
• Select All - Right-click on a selected element and choose Select>Select All from the context menu.
This will select the entire project. This is also available under the Edit menu.

Other Selection Methods
The following selection methods fall outside the view window and project view.
• Select Entire Project - Click on the Select Entire Project button on the input toolbar to select
the entire project.
• Select Color - Right-click on an active color and choose Select Color to select every instance
of that color in a project.
• Deselect All - Right-click on a selected element and choose Select>Deselect All from the context
menu. This will deselect any selected elements. This is also available under the Edit menu.

Selecting Expanded Elements
Expanded elements may be selected using all of the same methods as the wireframe elements. The major
difference is that expanded elements are usually only separated by a trim or color block. This means that
you typically will be selecting larger sections of stitches.
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Sew Sequence
The order in which elements appear in the project view is the order in which they sew. This is helpful to
keep in mind when determining the way that stitches will layer on top of one another.
To change the sequence of the elements, use one of the following methods.
• Select and Drag
1. Select the desired elements
2. Drag them up or down in the element list to the desired location.
When dragging, watch for the insert line to indicate where the
elements will be reinserted into the list.
• Cut & Paste (see Basic Functions Section)
1. Select the desired elements.
2. Cut them.
3. Select the element after which you would like the cut elements to appear.
4. Paste the elements in the list.

•

Be careful! Changing the order of a design will alter how the stitches layer. This may reveal previously hidden travel stitches or create unsecured trims.

Basic Functions
Common functions to many programs are the ability to cut, copy, and paste. These functions often save
the user time and effort. Several of these basic functions are explained below.

Cut
The Cut command removes the selected element(s) from the project and places them on the computer
clipboard. From the clipboard, these element(s) may be pasted back into the project later.

•

If another element is placed on the clipboard, the new element will replace the original and the
original element will be lost.

To use the cut command, use one of the following methods:
• Go to Edit>Cut.
• Click on the Cut icon on the main toolbar.

• Right-click on the selected element(s) and select Cut from the context menu.
• Use the keyboard shortcut of CTRL + X.
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Copy
The Copy command will place a copy of the selected element(s) on the clipboard. Unlike the cut command, it will not remove the elements from the project.
From the clipboard, these element(s) may be pasted back into the project later.

•

If another element is placed on the clipboard, the new element will replace the original copy.

To use the copy command, use one of the following methods:
• Go to Edit>Copy.
• Click on the Copy icon on the main toolbar.

• Right-click on the selected element(s) and select Copy from the context menu.
• Use the keyboard shortcut of CTRL + C.

Paste
The Paste command will place a copy of the element(s) from the clipboard into the project. Unlike some
graphics programs, the new element(s) will not be slightly shifted from the original. The exact positions
of the input points or needle penetrations are maintained.

•

When pasting from the clipboard, the X/Y position is set, but you will need to consider where/
when in the sew sequence you would prefer the new element(s) to appear. The pasted element(s) will be inserted into the project after whatever element is selected. If no element is
selected, the pasted element will appear at the end of the project. This is most easily observed
in the project tab.

To use the paste command, use one of the following methods:
• Go to Edit>Paste.
• Click on the Paste icon on the main toolbar.

• Right-click on a selected element and select Paste from the context menu.
• Use the keyboard shortcut of CTRL + V.

Cut, Copy, & Paste Between Programs
The cut, copy, and paste commands can occasionally be used between DesignShop and other programs
with varying degrees of success. Some illustration programs can utilize the wireframe data as vector
shapes while maintaining some stitch information in the background. This enables you to edit the shapes
in one program and paste them back into DesignShop while keeping some stitch information.
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With some artwork files, opening all the graphic information may prove overwhelming, but copying the
artwork from the native program and pasting it into a DesignShop project may work well.
If attempting to copy text from an illustration program and maintain the exact look of the letterforms,
it is best to convert the text to outlines in the illustration program before copying them to the clipboard
and pasting them into DesignShop.
For more information and control on how elements are utilized between programs, see the Vector
Import/Export Options.

Duplicate
The Duplicate command will essentially copy and paste the selected element(s) in a single command. The
new element(s) will be inserted directly after the selected element(s).
To use the duplicate command, use one of the following methods:
• Go to Edit>Duplicate.
• Right-click on the selected element(s) and select Duplicate from the context menu.
• Use the keyboard shortcut of CTRL + D.

Delete
The Delete function removes the selected element(s) from the project.
To use the delete command, use one of the following methods:
• Go to Edit>Delete.
• Right-click on the selected element(s) and select Delete from the context menu.
• Use the Delete (not Backspace) key on the keyboard.

Undo
The Undo command is used to undo certain actions. For example, if you accidentally deleted an element
and want it back, use the undo command.
Next to the Undo command on the main toolbar is a drop-down menu. This menu presents a history of
actions. Using this history, you can select the action that you wish to go back to.
Actions may only be undone in the reverse order of which they occurred.
To use the undo command, use one of the following methods:
• Go to Edit>Undo.
• Click on the Undo icon on the main toolbar or select from the drop-down next to it.

• Use the keyboard shortcut of CTRL + Z.
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Redo
The Redo command is used to redo recent actions that were reversed using the undo command. For example, if you accidentally used the undo command and you want to reverse the command, use the redo
command.
Next to the Redo command on the main toolbar is a drop-down menu. This menu presents a history of
recently undone actions. Using this history, you can select the action that you wish to go back to.
Actions may only be redone in the reverse order of which they were undone.
To use the redo command, use one of the following methods:
• Go to Edit>Redo.
• Click on the Redo icon on the main toolbar or select from the drop-down next to it.

• Use the keyboard shortcut of CTRL + Y.

Find
The Find command allows you to move through a design selecting the next, previous, or specific occurrence of a particular element type. It will highlight the selected element in both the view window and
project view.
To use the find command, use one of the following methods:
• Go to Edit>Find...
• Use the keyboard shortcut of CTRL + F.
To find an element, select the desired type of element from
the list on the left. Then do one of the following:
• Click the Next button to find the next element of the
specified type in the sew sequence.
• Click the Previous button to find the previous element of the specified type in the sew sequence.
• Enter a number in the field and click the Go To button. If you specified walk elements and entered
the number 3, this would take you to the third walk element in the project.

Center the Design
To center the project over (0,0) or the origin, click on the center design button on the
object bar. This will horizontally and vertically center the entire project. It is often a good
idea to do this before sewing a project on a machine.
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Moving Elements of a Design
The software allows you to move selected elements in several ways. It is common to move these elements to better align with other elements within a project.

Moving Elements by Dragging
One of the easiest ways to move a selected element is to click on the element and drag it where you
would like it to be. Clicking and dragging is a common function in many programs and it works well with
embroidery designs too.
Horizontal or Vertical Movement
If you would like to drag an element and lock it to a horizontal or vertical axis, hold the ALT key as you
drag it. This will allow it to move only horizontally or vertically, but not both.

Moving Elements with the Arrow Keys (Nudging)
If you would prefer a bit more precision in your design movements, you can use the arrow keys on the
keyboard to move design elements. To use the arrow keys,
1. Select the desired element(s).
2. Move the cursor into the view window to make that window have focus.
3. Use the following commands to move the element(s).
Key Commands
Shift + Arrow Keys
Shift + ALT + Arrow Keys
Shift + CTRL + Arrow Keys

Movement
1 point
10 points or 1 mm
100 points or 1 cm

Moving Through the Context Menu
You can also move elements by very specific increment using the right-click context menu. Just right-click
on the selected element(s) and select "Scale". This will bring up a scale tab. Select the position tab to
access the move functions.
Enter the amount in the X and Y fields that you would like to move. Positive numbers will move the element up or right. Negative numbers will move down or left. Click Apply to affect the change.

Scaling Elements
The ability to resize elements is one of the basic functions in DesignShop. You as the designer have relatively unlimited ability to scale elements in the software. However, you will
want to consider the physical limitations of embroidery when doing so. Make sure that as
you scale design elements you keep the size of the needle and thread in mind.
To scale elements, you must first select them. Once selected, a resize/edit box will appear
around the elements.

Scale, Slant, & Rotate
Video
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Scaling Graphically
An element can be scaled by clicking and dragging on any of the opaque handles in the corners or sides
of the resize edit box. Adding a key command as you drag can alter how the element(s) are scaled.
Mouse and Key Commands
Click and Drag Corner Handle
Click and Drag Top or Bottom Handle
Click and Drag Side Handle
Click and Drag Handle + ALT
Click and Drag Handle + Shift
Click and Drag Handle + ALT + Shift

Scaling Behavior
Scales X and Y (unproportionally)
Scales Vertically (Y) Only
Scales Horizontally (X) Only
Scales from the Center
Scales Proportionally
Scales Proportionally from Center

Scale to Specific Size (Scale Bar)
A selected element can be scaled to a specific size by typing the desired size in the scale bar with the
element is selected.
When and element is selected, the size of that element is displayed in the scale bar. You can resize the
elements by doing one of the following:
• Type a new value in either the Height or Width field and press Enter to apply.
• Use the arrow buttons to the side of either field to change the size.
• Click in either field and scroll on the mouse scroll wheel to change the size.

Scale by Percentage
If you would rather scale by percentage, select your desired element(s) and click on either the H or W in the scale bar. This will bring
up a scale pop-up window from which you can scale by percentage.
Type your desired percentage in the field and press the Enter key to
apply the change.

Scaling Proportionally
Along with the key commands listed above for graphically scaling proportionally, you can keep things
proportional when using the specific size or percentage.
Between the Width and Height on the scale bar is the Maintain Aspect Ratio button. Make sure that
this button is pressed in to keep your scaling proportional. This same function is represented by the lock
check box in the percentage pop-up window.
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Scaling Through the Context Menu
You can also scale elements using the right-click context menu. Just right-click on the selected element(s)
and select "Scale". This will bring up a scale tab in which many of the same scaling techniques listed
above are available.
Scale Factors and global Pull Compensation are also available in this tab. These deal with object properties. See those sections for more information.

Rotating Elements
Elements can be rotated graphically or by specific degrees. Use the method that best suits
your needs.
Scale, Slant, & Rotate
Video

Rotate Graphically
To rotate an element graphically, follow these steps.
1. Select an element or elements to be rotated.
2. Change the resize/edit box to rotate by either:
• clicking inside the box
• right-click and chose "Rotate" from the context menu

Rotate mode is displayed by hollow handles as opposed to the opaque handles or resize/edit mode.
3. Click and drag one of the corner handles to rotate the element.
4. Release the mouse button to complete the rotation process.

•

As you rotate the element, watch the status bar (where the scale bar was). I will display the
rotation in degrees.

Change the Pivot Point
When a selected element is in rotate mode, a circled X appears in the center of the element. This is the
pivot point. You can click and drag this point anywhere inside or outside of the selection. When you rotate, this is the point around which your selection will pivot.

Rotate by Degrees
If you would rather rotate by degrees, select your desired element(s)
and click on either the H or W in the scale bar. This will bring up a
scale pop-up window from which you can also rotate by degree.
Type your desired rotation in the field and press the Enter key to apply the change.
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Rotating Through the Context Menu
You can also scale elements using the right-click context menu. Just right-click on the selected element(s)
and select "Scale". This will bring up a scale tab. Select the position tab to access the rotation.
You can rotate by entering the desired degree in the rotate field. Click Apply to affect the change.
The orientation button can be used to quickly rotate in 90° increments. If you click to 360°, it will begin
to mirror the design and continue rotating. Click Apply to affect the change.

Skew or Slant Elements
Elements can be slanted or skewed graphically.
To slant or skew an element graphically, follow these steps.
1. Select an element or elements to be rotated.
2. Change the resize/edit box to rotate by either:

Scale, Slant, & Rotate
Video

• clicking inside the box
• right-click and chose "Rotate" from the context menu
Rotate mode is displayed by hollow handles as opposed to the opaque handles or resize/edit mode.
3. Click and drag one of the side handles to slant or skew the element.
4. Release the mouse button to complete the process.

Mirror Elements
Mirroring of flipping a design along either the X or Y axis is a simple command in your software.
To mirror an element, follow these steps.
1. Select an element or elements to be mirrored.
2. Click on either the horizontal or vertical mirror button located on the scale bar.
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Align / Evenly Space Elements
Elements or grouped elements may be aligned with one another in the software. They may also be distributed evenly between the two farthest elements.
To align or space elements, use one of the following:
• Go to Object>Align>[Desired Action]
• Use the icons on the Align toolbar.
• Align Top - aligns the tops of the selected elements to the top-most edge of the top-most
element.

• Align Bottom - aligns the bottom edge of the selected elements to the bottom-most edge of
the bottom-most element.

• Align Left - aligns the left edge of the selected elements to the left-most edge of the left-most
element.

• Align Right - aligns the bottom edge of the selected elements to the bottom-most edge of the
bottom-most element.

• Vertically Center - aligns the center of the selected elements to the center horizontal axis of
the resize/edit box.

• Horizontally Center - aligns the center of the selected elements to the center vertical axis of
the resize/edit box.

• Space Evenly Vertically - distributes the heights of the selected elements evenly between the
top edge of the top-most element and the bottom edge of the bottom-most element.

• Space Evenly Horizontally - distributes the widths of the selected elements evenly between the
left edge of the left-most element and the right edge of the right-most element.

•

Align commands will only be available with two or more elements selected. Space evenly commands will only be available when three or more elements are selected.
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The Color System
Color information is stored in OFM files. It is displayed by the software in a couple of places. The
majority of the color information is displayed on the mini palette toolbar and in the project tab.
Color Video

Mini-Palette Toolbar

The Mini-Palette toolbar displays the current color, view window background color, active
colors, and a small color palette of possible color options. Hovering over a swatch will display the
color.
Should this toolbar get closed, it can be reopened by selecting View>Toolbars>Mini-Palette Toolbar.
Current Color
The current color displays the color of the currently selected element(s). If multiple colors of
elements are selected, it will display an indeterminate color as diagonal lines.
If digitizing, this swatch will display the color with which the current or next element will be digitized.
To change the current color, use one of the following methods:
• Click on the desired active color or color from the color palette below.
• Click on the current color swatch to bring up the color properties window. From here a new color
chart or thread color may be selected. See the color properties section for more information.
Background Color
The background color swatch displays the color of view window background. Often changing the
background can help better mimic the color of the garment onto which the embroidery is to be placed.
To change the background color, click on the background color swatch to bring up the color properties window. From here a new color chart, thread color, RGB value, or graphic file may be selected. See
the color properties section for more information.
Active Colors
These colors are the colors used in the current project. The active colors differ from the color sequence in that these color swatches show only unique colors. If a design had the color sequence
of red, white, red, the active colors would only show two swatches.
It may be helpful to think of these swatches as the cones of thread on your machine. If you
change the color of an active color swatch, it will change every occurrence of that color in the
color sequence of the embroidery project.
To change an active color, use one of the following methods:
• Right-click on an active color swatch and select "Edit Color..." This will bring up the color properties window. From here a new color chart or thread color may be selected. See the color properties section for more information.
• Drag a color swatch from the palette colors over an active color.
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•

The numbers in the active color swatches do not correlate to the color sequence.

Right-Click Context Menu
Right-clicking on an active color swatch will bring up a context menu. From here, you may select any of
the following.
• Edit Color... - This option will bring up the color properties box and allow you to change the active color.
• Locked - This will lock the active color. A locked active color swatch will remain in the active color
swatches even if no instance of that color appears in the color sequence. A locked swatch with no
instances in the color sequence appears with a fine cross-hatch across the swatch.
The empty locked color swatch at the end of the active colors may be right-clicked on and populated with a color that you plan to use at a later time. Some digitizers will load their active colors
with the threads that they are planning on using in the design.
Locking a color essentially keeps the swatch for future use even when no elements currently use that color.
• Hide Color - This will hide every instance of the color in the color sequence. A hidden active color
swatch appears with a bold "X" across the swatch.
• Show Color - This will show every (hidden) instance of a color in the color sequence.
• Select Color - This will select every instance of that specific color in the color sequence.
• Hide Other Colors - This will hide any color block in the color sequence that is not using that active color.
• Show All Colors - This effectively shows all embroidery elements and colors within an embroidery project.
Color Palette
Found directly below the active colors is the color palette. These swatches are merely color suggestions that may be quickly pulled from to get a quick impression of a color. They can be dragged
onto an active color swatch to change the color quickly. They can also be populated by colors that
you are planning on using.
To change a color swatch in the color palette, right-click on the swatch. This will bring up the color
properties window.

Color Sequence (Project Tab)
The project tab contains color information as well. Since the order that elements appear in the project list reflects the order in which those elements
show, the color information in the project view dictates the color sequence.
To change the color of a color block or element(s) in the project tab,
use on of the following methods:
• Right-click on the selected color block(s) or element(s) and select
"Color..." This will bring up the color properties window. From here
a new color chart or thread color may be selected. See the color properties section for more information.
• Select the desired color block(s) or element(s) and click on a color swatch from the palette.
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•

Color blocks can be renamed by right-clicking and selecting "rename" from the context menu.

Color Properties Window (Color Tab)
The color properties window is typically access from
right-clicking on selected elements and selecting "Color..."
or right-clicking on a color swatch in the mini-palette toolbar.
If accessed from the mini-palette toolbar, this window can
be used to change the current thread color, and active color,
a palette color swatch, or the background color of the view
window. If access from the project tab or view window, it can
be used to change to color properties of the currently selected
element(s).
Color Chart
From the color chart drop down menu, you can select the
thread catalog (Brand or line) that you are using for this project. Not all threads in the project have to exist in the same
catalog.
To the right of the drop-down is a scrolling display of all the
thread colors in that catalog. Scroll through the list and click
on the desired new color to populate the lower have of the comparison preview. Click Apply to affect the
change. Click OK to close the window.
To the right of the scrolling display is a color scrubber. Click on the small triangle to the right and drag to
quickly scroll to the desired color area.
Mix Your Own Color
At the bottom of the color chart list is the System RGB color. This changes the thread catalog into sliders
and swatches for basic computer colors. This can be useful when changing the background color. You
can use the sliders to mix just the right color to mimic your garment.
Locked (Active Colors Only)
The locked check box appears for active colors only. This indicates whether the active color is locked or
not. For more information on this, see the Active Colors section above.
Color (#)
The color number field indicates which color in the list is being displayed. If this window was access for
the active color swatch, it will display the active colors. If accessed from the palette, it will display palette
colors. Color zero displays the background color.
If accessed from the project tab, current color, or view window, the color number field will not be shown.
Color Comparison/Preview
The color comparison/preview window is shown just below the color number field. This shows the original color on top and a newly selected color on the bottom for comparison.
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Match Chart
If a different color chart is selected from the one being used, the match chart button will find the closest
RGB match for the new chart and change the thread color to match. While this works well for a quick
search, it is recommend that for color accuracy, physical thread charts, cones, or swatches be compared
in natural light for the best results.
Save As Default
Save as Default will save the current palette and thread chart as the defaults for the software.
Find Name:
Only available if the thread chart has named colors, this tool allows you to search for the thread colors by
name. Press the Go button to initiate the search. Pressing it again will move the next thread name including that word or group of letters.
Find Number:
This field allows you to search the currently selected thread chart for a specific thread by the thread number. This will search as you type.

Creating Custom Palettes or Color Charts
Custom palettes and color charts can be created to better suit your needs. The custom palettes can be loaded to
replace the palette on the mini-palette toolbar. The custom color charts will appear in the color chart drop-down.
Custom palettes must be loaded to the mini-palette toolbar. Custom color charts are populated in the
color chart drop-down as soon as they're created.
To create a custom palette or color chart, use the following steps:
1. Right-click on the upper left swatch of the color palette (see section above) to bring up the color
tab on color 1.
2. Select the color chart and color that you would like to occupy that swatch.
3. Click Apply.
4. Click the up arrow to the right of the color number to increment the color number and move to
the next swatch.
5. Repeat steps 2-4 until you populated the desired amount of colors. The palette will display a maximum of 42 color swatches.
6. Click the Save As Custom... button.
7. Type a label in the Name field
8. Specify the number of colors.
9. Specify whether this is a palette or a color chart by clicking on the button beside the appropriate type.
10. Click OK.

•

Custom palettes and color charts can contain thread colors from multiple brands.
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Loading a Custom Palette
To load a custom palette, use the following steps:
1. Right-click on a swatch in the palette.
2. Click the Load Custom Palette... button.
3. Select the desired palette from the list.
4. Click OK.
5. Click Apply to affect the change and OK to close the window.

•

The palette and color chart files are located in the "Color Data" folder inside the main
DesignShop folder on your hard drive. Color charts use the extension ".clr" and palettes use
the extension ".pal".

Changing Element Colors
To change the color of selected elements, use one of the following:
• Right-click on the selected elements and select "Color..." to access the color tab.
• Click on a new color in the palette.

Changing Colors as You Digitize
To change colors as you are digitizing, have your digitizing tool selected and use one of the following:
• Click on a new color from the color palette.
• Click on the current color swatch to access the color tab and select a specific color.

Changing Colors of Letters
If you want to change the color of letters in a lettering element, select the individual letters you wish to
alter the color of by clicking on the handle (X) of the letter. If multiple letters are desired, hold the CTRL
key while clicking to select multiple letters. With the letter(s) selected, use one of the following methods
to change the color:
• Right-click on the selected elements and select "Color..." to access the color tab.
• Click on a new color in the palette.

Displaying a Graphic Background
An image may be displayed in the background of the view window. The purpose is to give a better idea
of the embroidery on a patterned background. To do this, click on the background swatch in the mini
palette toolbar. Access the Graphic background tab. Uncheck the no graphic background box. Browse to
the graphic file. Click OK to see the change.
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Lettering
Creating lettering is a basic tool for any embroiderer or digitizer. DesignShop has a variety of features and
tools for creating lettering to fit your needs.

Creating a Lettering element
The first step of working with lettering is to actually get the letters on the screen and in the
embroidery project.
To create a lettering element, use one of the following methods:
Create Lettering
Video

• On Screen Lettering
1. Select the lettering tool by clicking on the [A] icon on the input toolbar.

2. Choose your properties (alphabet and size) on the property bar, just below the main
toolbars.
3. Click in the view window where you would like the lettering element to appear. A blinking cursor should appear on screen.
4. Type the desired text with the keyboard.
5. Press the Enter key to complete the lettering element or use CTRL + Enter to create a second
line of text.
OR
• Through Properties
1. Select the lettering tool by clicking on the
[A] icon on the input toolbar.
2. Click in the view window where you would
like the lettering element to appear. A blinking cursor should appear on screen.
3. Press Enter to go directly into the lettering
properties window.
4. Choose your alphabet and size.
5. Click within the lettering box.
6. Type your desired text in the box.
7. Click Apply to see the text appear on screen.
8. Click OK to close the window.
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Lettering Properties
Lettering Properties consist of a myriad of attributes from the
alphabet choice, size, and justification to the order in which
the letters are sewn and many more.
The object properties of the lettering element may be accessed by right-clicking on a selected lettering element and
selecting properties. You may also simply double-click on the
lettering element.

Alphabet
The alphabet selection drop-down menu provides access to
all of the embroidery alphabets loaded with your software.
If the level of software permits, it will also provide access to
the TrueType fonts and TrueType-style OpenType fonts in the
system fonts folder on your computer.
Searching for the Alphabet Name
Clicking within this box will also enable you to type the name
of your desired alphabet. Results will begin to display and filter down as more letters are typed. If, for
example, you knew that your preferred alphabet had the word "times" in it, you could type that in the
alphabet field and see all alphabet names containing that word.

Alphabet Types
As new technology has evolved, new types of alphabets have been made available for the
software. There are a couple of embroidery alphabet types that your software uses.
Embroidery Alphabets (Newer)
The new embroidery alphabets have been developed in recent years using more versatile
digitizing tools. These alphabets will usually scale and sew with fewer property adjustments
than older alphabets. These alphabets a indicated by a star to the left of the name.

•

Alphabet Types
Video

These alphabet files have been digitized for embroidery while keeping the limitations of the
needle and thread in mind. They are the most versatile of the alphabet choices and require the
least amount of property adjustments.

Embroidery Alphabets (Older)
The older of the embroidery alphabet types uses older digitizing methods and is a bit less dynamic in the ways
that it can be used. These alphabets are marked by a caution mark to the left of the name. This indicates that
these alphabets may require significant adjustments to their properties to sew well for your application.
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TrueType Fonts or OpenType (TrueType Style) Fonts - Software Level Dependent
TrueType fonts and TrueType-style OpenType fonts loaded into the system fonts folder on your computer can be used by your software. These fonts utilize vector shapes in the creation of the letterforms and
those vector shapes are converted into wireframe stitch elements by your software.
These fonts are found in the TrueType alphabet category. The location of the actual font files is in the
system fonts folder of your computer.

•

As these fonts were never meant to be made into embroidery, they may take some adjusting of
properties or editing of the wireframe shapes to sew well.

Alphabet Categories
The alphabets in the dropdown menu are separated into categories. These categories are usually based
on the shapes of the letterforms. Some alphabets may appear in more than one category.
• Block - Typically these alphabets will contain slab serifs or have no serifs at all.
• Script - These alphabets mimic the flow of handwritten letterforms.
• Serif - These alphabets contain small flares at the ends of the strokes.
• Sans Serif - These alphabets contain little or no flares at the ends of the strokes.
• Slab Serif - The flares on the ends of these alphabets tend to be squared off.
• Micro - Small embroidery is a challenge. These alphabets were designed to sew well at smaller sizes. Because they were digitized and optimized for micro lettering, they may look good when sewn
small but a bit odd when sewn at larger sizes.
• Monogram - These alphabets were designed to be used as monograms. With the exception of
Classic Monogram, these alphabets are limited to three letters and a border or graphic element.
• Specialty - These alphabets can be a bit unique, funny, or used to add elements to type.
• Pictographs - These alphabets contain or are mostly images.
• Custom - This category is reserved for user-created alphabets.
• TrueType - This category lists all the TrueType and TrueType-style OpenType fonts loaded to the
system fonts folder of your computer. Remember that these fonts were not originally intended for
embroidery. They may require editing to sew well.
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Alphabet Previews/Guidelines
As you browse alphabets from the alphabet drop-down menu, hover over the alphabet name to see a
preview of the alphabet beside the alphabet name. Usually, this preview will display all available characters within an embroidery alphabet.
Guidelines
If guideline information is available for the alphabet, information such as a suggested minimum and maximum size is displayed below the alphabet name. If this information is not available, only the alphabet
name will be displayed above the preview image.

Special Characters
Many of the alphabets will include characters that do not exist
on a standard keyboard. If they are specific to that alphabet
and exist for embroidery only, they will display a character beside them to indicate which key to press to utilize that character. Many of the monogram and picture alphabets display this
information in their previews.
In the example for 3 Letter Seal, adding the keystroke "1" in
the text edit box will add a circular border appropriate for a
three-letter monogram in the view window.
For alphabets with standard Euro characters, use the character map utility on your computer to access the appropriate
keystrokes.
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Special Characters
Video

Height
The height field allows you to set the height of the letters within the lettering element. This will scale the lettering element proportionally.
Letter height can be changed in the following ways:
Letter Scaling
Video

• Double-click in the height field and type the desired letter height.
• Double-click in the height field and scroll on the scroll wheel of your mouse to
change the value.
• Click on either the up or down arrows attached to the height field to change
the value.

•

Either press the Enter key or click the Apply button to affect the change.

•

The height field can also be found on the property bar when a lettering element is selected.

How Letters Are Measured
The letter height may differ from the element height. If looking at the letter height field and comparing it
to the height field (H:) on the scale bar, you will most likely notice the difference.
Letter height is measured from the baseline of the lettering element to the indicated cap height when the
alphabet was created. Not all letterforms will fit perfectly within these two indicated lines. The baseline
and cap height are imaginary lines determined by the digitizer/designer during the creation of the alphabet file.
The element dimensions are measured from the wireframe edges of the shapes.
Cap Height
Ascender
Letter
Height
Baseline
Descender

Element
Height

Example shown in Shell Script

•

The letter height can be altered graphically as well. See the scaling section on proportionally
changing the size of selected elements.
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Letter Width
The letter width property allows you to alter the width of the letter based on the
original digitized letterform. The height of the letter will remain as specified in the
height field, but the width will change using the percentage in the width field.
To change the letter width, use one of the following methods:

Letter Scaling
Video

• Double-click in the width field and type the desired letter height.
• Double-click in the width field and scroll on the scroll wheel of your mouse to
change the value.
• Click on either the up or down arrows attached to the height field to change
the value.

•

Either press the Enter key or click the Apply button to affect the change.

•

As with many manipulations in this software, the software will not limit you. Make sure that
you do not push the manipulation beyond the physical limitations of embroidery. Basically,
make sure that your stitches are at least a millimeter long and they are not bunching and causing thread breaks.

Because different alphabets and fonts can handle varying amounts of manipulation, a wide range of manipulation is allowed. To stay in a safer range when using the width field to alter lettering, stay between
70% and 130%. Going beyond that range may still work, but it also may require some editing.

50%

•

60%

70%

80%

90%

100%

110%

120%

130%

140%

150%

The letter width can be altered graphically as well. See the scaling section on changing the
width of selected elements.
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Slant
The slant field allows you to alter the slant angle of the letter based on the original
digitized letterform. The height of the letter will remain as specified in the height
field, but the angle will change using the degree specified in the slant field.
To change the slant, use one of the following methods:

Letter Scaling
Video

• Double-click in the slant field and type the desired slant degree.
• Double-click in the slant field and scroll on the scroll wheel of your mouse to
change the value.
• Click on either the up or down arrows attached to the slant field to change
the value.

•

Either press the Enter key or click the Apply button to affect the change.

•

As with many manipulations in this software, the software will not limit you. Make sure that
you do not push the manipulation beyond the physical limitations of embroidery. Basically,
make sure that your stitches are at least a millimeter long and they are not bunching and causing thread breaks.

Because different alphabets and fonts can handle varying amounts of manipulation, a wide range of manipulation is allowed. To stay in a safer range when using the slant field to alter lettering, stay between
-15° and 15°. Going beyond that range may still work, but it also may require some editing.

-30°

•

-25°

-20°

-15°

-10°

-5°

0°

5°

10°

15°

20°

25°

30°

The slant angle can be altered graphically as well. See the slanting and skewing elements section on changing the slant angle of selected elements.

71 of 218
Table of Contents

Text Editing Box
The text editing box works well for any basic editing that is required for the lettering
element. Clicking within this box inserts a blinking cursor. From this point, the box
works very similarly to most simple text editing programs. Letters and words may be
cut, copied, or pasted using the keyboard shortcuts.
Click the Apply button to see your changes appear on screen.

•

Copying text such as a name from a customer e-mail is a great way to prevent embarrassing
spelling errors on embroidered goods.

Kerning Lettering
Any designer working with text needs to address kerning in their lettering elements. Kerning is the process of adjusting the space between individual letterforms. This will need to be done with any typeface
containing characters of varying widths. The purpose behind kerning to give the appearance that the
white space between the letters has approximately the same optical weight.
Certain letters are more prone to needing kerning adjustments. Letters that are wider on one end than
the other (A F J L P T V W Y) typically require more work.
Manual Kerning
Using the kerning marks to the right of the text edit box will allow you to adjust the
kerning between letters. To manually adjust kerning, use the following steps.
1. Click within the text edit box and insert the cursor where you need to make
an adjustment.
2. Click on one of the kerning buttons to adjust the space. These buttons will remove or add space
between the letters. The adjustment amount is equal to 1/16 of the letter height.
• [A] - this button removes space between the letters. It is displayed in the text edit box as "«"
• [A] - this button adds space between the letters. It is displayed in the text edit box as "»".
• If one of these kerning marks isn't enough, you may add more. For example, it the text edit
box, you may have a lettering element that looks like "T««o«y"

No Kerning
Displayed as "Toy" in text edit box

Manual Kerning
Displayed as "T««o«y" in text edit box
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Auto Kern
While the control of manually or on-screen (below) kerning is
great, sometimes to speed production you need an automatic
option. Auto Kern is a feature in the software that will examine the lettering for you and adjust the space to appear as a
percentage of the height.
To use the auto kern feature:
1. Access the properties of the selected lettering element.
2. Select the "Spacing" sub menu below "Letters"
3. Check the Auto Kern check box to enable.
4. Adjust the percentage.
5. Click Apply to see the changes.

•

Auto Kern works well for a variety of typefaces, but
not all. Be careful when working with connected
scripts or any monogram alphabets. Auto kern adds
typically undesired space to connected or precisely
spaced alphabets.

Times New Roman - No Auto Kern

Times New Roman - Auto Kern at 10%

Shell Script - No Auto Kern

Shell Script - Auto Kern at 10%
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Word Spacing
Automatic word spacing is located in the same window as
Auto Kern (above). This will ignore the programmed space
assigned to the space bar key and utilize a percentage of the
letter height. To use word spacing:
1. Access the properties of the selected lettering element.
2. Select the "Spacing" sub menu below "Letters"
3. Uncheck the "Use Default Spacing" check box to enable the use of the percentage.
4. Adjust the percentage.
5. Click Apply to see the changes in the view window.
Micro Block - Default Word Spacing

Micro Block - Word Spacing at 40%

On-Screen Kerning
If on-screen manipulation is more to your liking, you can kern lettering in the view window
To graphically kern lettering, use the following steps:
1. Select the lettering element in the view window by clicking on it.
2. Click and drag on the handle (X in the middle of the letter) of the letter you wish to move. The
letter will move along the baseline.
• If more than one letter is to be moved together, click on the handle of one letter, then hold
CTRL and click on the handle of the other desired letters. This will select multiple letters.
Release the CTRL key.
• To move them, click within the resize/edit box (this time avoiding the handles) and drag. If
you click on the handle of a single letter, the resize/edit box will reduce to the single letter and
deselect all other currently selected letters.
3. Release the handle and examine your work.

On-screen Kerning
Berfore

•

On-screen Kerning
During

On-screen Kerning
After

Hold the CTRL key while dragging a single letter to move it off of the baseline.
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On-Screen Manipulation
Lettering height, width, slant angle, and kerning can all be altered in the view window. This can provide
easier visualization for the designer/digitizer.
Lettering Element (Whole)
To select the entire lettering element, click on it in either the view window or the project view. This will
surround the selected element with the resize/edit box. This works just like normal embroidery elements.
See the scaling, rotating, slanting and skewing elements section on making this alterations to the selected elements.

Individual Letters
After selecting a lettering element, an individual element may be selected by clicking on the handle (X
in the middle) of the letter. If more than one letter is desired, click on the handle of one letter, then hold
CTRL and click on the handle of the other desired letters. This will select multiple letters. Release the
CTRL key. With the individual letters selected, any of the manipulations above may be used. You may also
alter the color of those letters by selecting a new swatch or changing the color in properties.

Clarendon

Clarendon with the first letter scaled up, changed to Olde English, and altered color.
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Trimming Between Letters
If you would prefer to have the machine trim between the letters, you may need to
insert a trim command between the letters in the text edit box. To do this:
1. Click within the text edit box and insert the cursor where you need to add the
trim command.
2. Click on the trim command button to the right of the text edit box. This will insert a trim
command.
• A trim command is displayed in the text edit box as "¤".

•

The Auto Trim feature may be used to automatically insert trims between elements greater than
a specified distance apart. If the auto trim feature is creating the trim commands, they will not
appear in the text edit box.

Connection Type:
The connector stitches between letters may not always need trimmed. Often when
working with smaller lettering, the embroidery sews more cleanly and looks nicer if
the letters are not trimmed.
Changing the connection type of lettering will alter how the letter sews. It can
change where the connection thread is placed. The options follow.

Connection Types
Video

• As Digitized - This keeps the intersections and overlaps exactly the same as
the digitizer intended. The entry and exit points of the individual letters are
independent of the adjacent letters.
• As Digitized is usually used when trimming between letters. It maintains the
integrity of the alphabet.
• Bottom Connect - This option resequences the individual letter elements to place the entry and
exit points along the bottom of the individual letters. This can change overlaps and intersections.
• Closest Point - This option resequences the individual letter elements to place the entry and exit
points wherever the letterform is closest to the next letter. This can change overlaps and intersections.
• Closest Point connections are often used when working with smaller lettering that will not be trimmed.

Connections Highlighted in Red
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Justification
Below the text edit box in the letters properties, you will find the justification buttons. These icons alter how the text is aligned. The options follow.
• Flush Left - This aligns the left side of the lines of text to the left side of the
lettering element box. The right sides of the text lines are ragged.

Justification
Video

• Centered - This horizontally centers each line of text within the lettering element box. Both sides of the text lines are evenly ragged.
• Flush Right - This aligns the right side of the lines of text to the right side of
the lettering element box. The left sides of the text lines are ragged.
This is an aesthetic decision and has little or no impact on the sew quality of the project.

Horizontal Stitch Order
The horizontal stitch order determines the order in which the letters within a single
lettering element will sew. The options follow:
• Left to Right - This sews the left-most letter of a text line first and continues sewing to
the right.

Sew Order
Video

• Right to Left - This sews the right-most letter of a text line first and continues sewing
to the left.
• From the Center - This divides the lettering line in half. It sews from the center to the
right, and then finishes by sewing the other half of the line from the center to the left.

•

Avoid ripples! When selected a direction for your embroidery elements to sew, it is important to
sew away from previously sewn elements. These elements attach the material to the backing.
Sewing toward these anchored elements can push a ripple of material.

Vertical Stitch Order
The vertical stitch order determines the order in which the lines of text within a single lettering element will sew. The options follow:
• From the Top - This sews the top-most text line first and continues sewing to
the bottom.
• From the Bottom - This sews the bottom-most text line first and continues sewing to the top.
• Wrap - This overrides horizontal stitch order. This sews from the top. Each successive line alters the
horizontal stitch direction. This minimizes machine movements and for machines without trimmers,
makes the connectors between lines fall on the outside edges where they are easier to trim by hand.

•

Avoid ripples! Use the same material push considerations as with horizontal stitch order.
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Line Types
The line types feature allows you to change the line along which your text flows.
With some of the line types, additional line manipulation will be require to see the
full effect and potential of the line type.
To select a line type, click on the drop-down menu and choose your desired type. The
options follow.

Line Types
Video

Straight
This is probably the most common of the line types. The letters fall along a horizontal line with the digitized baseline as the horizontal line.

Vertical
This line type aligns the horizontal center of the letterforms along a vertical line.
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Arc (How to Arc Lettering)
The arc line type curves the line along which the letters fall. The baseline of the letters aligns with the arc
line. When selecting this line type, you have the option to change a few properties associated with this
line type. These properties appear when "Arc" is selected.
• Radius: - The radius of the arc measures the distance from the center of the circle to the edge.
Both the center and the edge points are indicated in the view window by a blue diamond. This
setting can be altered by changing the number in the radius field in the properties window or by
dragging either handle in the view window.
• Angle: The angle determines where along the arc the lettering will fall. The angle is applied to
the horizontal center of the text. 0° indicates the top of the circle. 180° indicates the bottom of
the circle. This setting can be altered by changing the number in the radius field in the properties
window or by dragging either handle in the view window.
• Clockwise & Counter Clockwise - This option changes the direction the lettering flows around the arc.
Clockwise

Counter Clockwise

0°

180°

To achieve the common look of lettering both at the top of a circle and at the bottom with both lettering
pieces reading from left to right, two lettering segments need to be created. The top would be set to
clockwise at 0°. The bottom lettering would be set to counter clockwise at 180°.

•

When using an arc line type, and especially when running counter clockwise, the horizontal
spacing (see the spacing section) and auto kern may need to be adjusted. If multiple lines of
type are used within a single element, line spacing may also need to be adjusted.

79 of 218
Table of Contents

Custom
The custom line type allows you to wireframe-edit the line along which the letters flow.
When custom line type is first selected, the line will have wireframe input points on each end. If you
hover over the line or points, your cursor will change and you can alter the line. For more information on
wireframe editing the line, see the wireframe editing section.

•

Because the baseline of the letters attempts to follow the wireframe line as closely as possible,
this feature works best with a more gentle path.

Perspective
The perspective line type can create the illusion of depth. By manipulating the wireframe lines, the lettering appears to come forward or go back in space. To achieve this, the perspective line type keeps the
width of the letters in relatively close proportion to the height.
When perceptive line type is first selected, a wireframe line will appear on the top of the lettering element as well as along the bottom. If you hover over one of these lines or the points at either end of
them, your cursor will change and you can alter the line. For more information on wireframe editing the
lines, see the wireframe editing section.

•

The software will not limit you with your distortions and manipulation of the text. Be careful that what you create will still have stitches larger than your needle. Try to keep stitch line
lengths above 1mm.

The perspective baseline adds "Envelope properties" to the properties window. See the following sections on how to use those properties and "Scale to Fit".
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Envelope
The perspective line type can create the illusion of depth. By manipulating the wireframe lines, the lettering adheres to the upper and lower lines without changing the width of the letters.
When envelope line type is first selected, a wireframe line will appear on the top of the lettering element
as well as along the bottom. If you hover over one of these lines or the points at either end of them, your
cursor will change and you can alter the line. For more information on wireframe editing the lines, see
the wireframe editing section.

•

The software will not limit you with your distortions and manipulation of the text. Be careful that what you create will still have stitches larger than your needle. Try to keep stitch line
lengths above 1mm.
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Scale to Fit (Envelope & Perspective Line Types)
The scale to fit feature allows you to use either the envelope or perspective line type to create a shaped
lettering template.
• If scale to fit is enabled, any lettering that is edited in the text edit box will stretch or shrink the
letter width to fit or fill the envelope shape.
• If scale to fit is disabled, any lettering that is longer than the original and is edited into the text
edit box will shrink the letter width to fit the envelope shape. If the lettering is shorter than the
original text, it will not expand to fill the envelope shape.

Creating a Template with Scale to Fit
The easiest way to use this feature for templates is to do the following:
1. Select a word/name that fits your application as easily as possible. Usually this will be one with
around six letters.
2. Create a lettering element with a straight line type using that word. Set the majority of your lettering properties (height, width, slant, auto kern, etc.).
3. Change the line type to envelope or perspective and create the desired shape. Click apply.
4. Change the lettering in the text edit box to a new word and click apply to see the changes.
Scale to Fit (Enabled)
Justin
(Template
Starter)

Christopher
(Longer)

Sue
(Shorter)
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Scale to Fit (Disabled)

Include Descenders (Envelope & Perspective Line Types)
The Include Descenders feature allows you to alter how words with descenders fit within the top and
bottom distortion lines used by envelope and perspective line types.
• If Include Descenders is disabled, any lettering that contains descenders will use the baseline of
the character to rest on the bottom distortion line.
• If Include Descenders is enabled, any lettering that contains descenders shrink the letter height to
fit the entire lettering element within the envelope shape.
Please use the following table to see what combination of Scale to Fit and Include Descenders fits your needs.
Scale to Fit (Enabled)

Scale to Fit (Disabled)

Travis
(Template
Starter)

Becky
(Slightly
Shorter)
Include
Descenders
OFF
Becky
(Slightly
Shorter)
Include
Descenders
ON
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(Lettering) Spacing
The adjustment of spacing for lettering elements is accessed through the Spacing sub
window. To access this, do the following:
1. Select a lettering element.

Letter Spacing
Video

2. Access the properties of the element by
right-clicking on the element and selecting properties
or double-click on the element.
3. If the Letters category is collapsed on the left, expand it.
4. Select the spacing sub-category.
The Spacing (sub) category controls the auto kerning, line,
horizontal, and vertical spacing of the lettering elements as
well as the spacing between words.
Auto kerning and word spacing are discussing in the earlier
kerning section.
The spacing section is devoted to the following:
• Line Spacing - Called "leading" in traditional typography, this value controls the spacing between lines of type. It adjusts the distance between the
baseline of the first line and the cap height of the subsequent line. See the height section to view
where these invisible lines fall.
• Horizontal Spacing - Called "tracking" in traditional typography, this value adjusts the spacing
between all of the letters. Small adjustments make a large visual impact.

•

Using a negative number in the horizontal spacing field can bring letters closer together without changing the size of the individual letterforms. This can help place a larger amount of text
in a smaller area without compromising the integrity of the embroidery. It can also help hide
connections if using closest point and leaving the connections between letters untrimmed.

• Vertical Spacing - This value adjusts the vertical space between letters. In essence, it can create a
tiered effect. It will offset the baseline of each successive letter by the specified amount.
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Auto Borders (Lettering)
The automatic addition of borders to lettering elements is accessed through the Auto Borders sub window. To enable this
feature, do the following:
1. Select a lettering element.
2. Access the properties of the element by right-clicking
on the element and selecting properties or double-click
on the element.
3. If the Letters category is collapsed on the left, expand
it.
4. Select the Auto Borders sub-category.
5. Check the Enable Auto Border Check Box
6. Adjust the properties below.
7. Click Apply to see the changes.

Auto Border Properties
Below the enable check box, there are several properties to
adjust. These will only be enabled if the feature has been enabled.
Stitch Type
From the stitch type drop-down, you can choose the follow types of stitches for your borders.
Satin - arguably the most common border type. Just make sure that your width is larger than the needle
that you are sewing with and gives you enough room for bit a of pull from the letter underneath. Too
thin, and the letter and border will not line up like they appear on screen.
• Walk Normal - Borders your lettering in a single line of stitches.
• Walk Bean - This choice will border your lettering in a line of triple stitches. Each stitch will go over
the same spot three times before continuing to the next stitch.
• Appliqué - A level dependent choice, this will switch your lettering from normal embroidery into
an appliqué element.
• Tackle - This will border your letters in a tackle-style stitch.
All properties for the stitch types are listed as sub-categories of the Auto-Borders.

•

Adjusting the pull offset of the lettering you intend to border by adding a couple of points will
increase the likelihood that your letters and borders will align as they appear on screen. Using
underlay under the lettering will also help. See both the Pull Comp and Underlay sections for
more information on those features.
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Width
This field will change the width of a satin border. Keep in mind that this needs to be wider than the
diameter of your needle. Also, the center of the satin stitch falls along the wireframe edge of the letter.
This means that only half the width is overlapping the letter edge.
Add Color Change
This enables the borders to be separate color blocks from the letters they surround. Unchecking this will
make the letters and the borders all the same color.
Stitch Borders Last
This feature will cause the entire lettering to sew first and then all of the borders. This feature is best used
on short words and stable materials.
Leaving this feature disabled will provide better registration of letters and borders on less stable materials
and longer lettering elements.
Stitch Letters
This feature will sew both the letters and the borders. Unchecking this will sew only the borders. This can
allow for much larger letters with far fewer stitches.

Example shown with auto borders enabled. Add color change, stitch borders last, and stitch letters are all disabled.

•

Using Auto Borders with an overlapping alphabet like a connected script will outline each
letterform causing the overlapping areas to be four layers of stitching thick. This is not recommended without extensive editing.
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Monograms
There are a couple of ways to create a monograms in the software. Use the method that best suites your needs.

Monogram Alphabets
The alphabets in the monogram alphabet category were designed to be used specifically for the embroidery of initials in
a monogram format. The majority of these were designed for
up to three-letter monograms.
Several of these alphabets will also have borders and flourishes to accompany the letterforms. This are typically accessed by
typing a number or symbol into the text edit box. The preview of the alphabets list the corresponding keystroke by the
accent element.
Some of these alphabets will utilize capital and lowercase
letters to distinguish which letterforms contain accents. This too is visible in the preview.

Monogram Mode (Lettering Sub-Category)
Nearly any alphabet may be utilized by the Monogram Sub-Category
to create a monogram looking design. This tool allows you to alter
the height of each letter separately. This works for three-letter lettering elements.

•

This feature is meant for use with standard alphabets and is
not mean to be used with monogram alphabets.

To use this mode, follow these steps:
1. Begin with a lettering element containing only three letters.
2. Access the object properties of the lettering element.
3. Select the Monogram sub-category of Letters on the left side
of the properties window.
4. Check "Enable Monogram Mode".
5. Change the height of the letters in the monogram. Typically the middle letter is the largest.
6. Click Apply to see the change in the view window.
7. The letters will shift along the line to be vertically centered
with each other and the letter heights of the individual letters
will change.
8. Click OK to close the object properties window.
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Monogram (Using Envelope Line Type)
Another way to create the look of a monogram without using an
alphabet specifically designed to be a monogram shape is to utilize
the envelope line type to mimic a monogram shape.
To do this, use the following method:
1. Begin with a lettering element typically containing at most
three letters, although this method can be used for less conventional monograms with varying numbers of initials.
2. Access the object properties of the lettering element.
3. Change the line type to envelope.
4. Click apply.
5. Edit the envelope shape to suite your needs. The letterforms will adjust to fit the shape. See the
Envelope Line Type section for more information on manipulating this line type.
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(Lettering) Styles
Lettering styles are named sets of lettering properties that can be
saved and then loaded at a later time. These provide a quick way to
utilize all of your favorite or most used settings for a given typeface.
For example, you can set up your lettering to sew at a quarter inch
tall with specified densities, pull offset, and underlay to help it sew at
such a small size. Sew the lettering out and make sure it is working
well for you. Then you can go into the file and save all the settings as
a lettering style named "[Typeface] quarter inch" or whatever name
makes sense to you. The next time you need that small lettering,
you can load the style and it will populate all the properties with the
settings that you've tested and know work well for you.

Saving a (Lettering) Style
To create a style, follow these steps:
1. Create a lettering element with all your desired properties.
2. Test sew your project on the intended material and backing.
3. Adjust your properties as needed and possibly test sew again.
4. Once all properties are to your liking, go to the Styles sub-category of Letters in the object properties of your lettering element.
5. Click Save Style.
6. A Create Style window will pop up and you need to populate it with the name of your new style.
7. Click OK.

Loading (Applying) a (Lettering) Style
After creating and saving a lettering style, it may be applied to other lettering elements in other projects.
To apply a lettering style and load all the properties associated with it, follow these steps:
1. Create or select a lettering element.
2. Access the properties of that element.
3. Go to the Styles sub-category of Letters.
4. Select the desired style from the drop-down menu.
5. Click Load Style.
6. Click Apply to see the changes to the lettering element.
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Group Names
The group names feature allows you to create an embroidery project
in which one of the lettering elements may be swapped out with
different letters (names, words, numbers, etc.). This means that you
can essentially create a template and have the software generate the
different files for you.
For example, you may choose to have a lettering element above or below a ball design. Then, populate the group names feature with all the
names from a sports team. The feature will allow you to copy those
names from an e-mail or text document and paste them into the software (eliminating embarrassing typos). Once populated, the feature
can be used to generate a name-stacked file or separate files depending on your needs. The output type will allow for these choices.

•

Envelope Line Type + Group Names = Template
Working with group names often requires some tests to ensure that the majority of the names
being used look good and fit within the hoop. Using the envelope line type can help reduce the
guesswork on names fitting. See the sections on envelope and scale to fit for more information.

The position and many of the properties cannot be altered from name to name. Using automatic features
such as auto-density, auto-underlay, and auto-kern (for unconnected typefaces only) can greatly reduce
the need to address issues with individual names.

Setting Up Group Names
To set up a project to use group names, use the following steps:
1. Create an embroidery project using a lettering element that
is emblematic of the words that will be replacing it. Try to use
a word that is of average length. It could just be a series of
a single letter (XXXXX). Remember that this text is merely a
placeholder and will be swapped for the text values from the
group names feature.
2. Set all the properties (alphabet, letter width, densities, underlays, etc.) of the elements in the design.
3. Sew a test sample to ensure the properties are what you really
need.
4. Access the properties of the lettering element to be changed.
5. Select the Group Names sub-category.
6. Check the Enable check box.
7. Populate the Available Names box.
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Available Names
Group Names has two lists of names associated with it. The first is the available names. For example, this
might be populated with a list of all the players on a sports team. The available names is the list from
which the selected names are pulled.
The second list is the selected names. This is a subset of the available names. It may be used to aid production. For example, you may choose to select all of the team members who where a medium sized
shirt. This would allow to you produce all of one size at a time and help prevent mix-ups.
To populate the Available Names list, use one of the following methods:
• Manually Add the names
1. Type the names in the field just below the Available Names list and click Add after every name
or separate the names with commas (John Smith, Rose, Jack Jones). Be careful to avoid typos.
• Copy and Paste the names from a text document.
1. Select the names in an e-mail or word processing document.
2. Copy the names to the clipboard of the computer (CTRL+C usually works with most software programs)
3. Click the Paste button below the available names list to paste the names from the clipboard
into the list.
• Import the names from a .TXT file.
1. If you have a .TXT file of the names, you can import the file using the import button below the
available names list.

Format of the Names
When populating the list, the format of the names matters.
• First Names: The first names listed will be considered the first name of the person when selecting
the names in the selected name list.
• Last Names: Any words after the first space will be considered the last name of the person.
• Dual Names: For first names that have two names, separate them with and underscore. The underscore will be turned to a space with the stitch files are generated, but it will keep the names
together. For example, Sarah_Jane, Mary_Jo, and Mary_Beth.
Available Name (as input)
John Smith
Smith, John (Manually Added)
Smith, John (Pasted or Imported)
Sarah Jane Smith
Sarah_Jane Smith
Smith

Selected Names (First)
John
Smith
John
Smith,
Sarah
Sarah_Jane
Smith

Selected Names (Last)
Smith

John
Jane Smith
Smith
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Selected Names
The selected names list is a subset of the available names list. These names are the names to be used
when generating the group name file(s).
It may be helpful to use this to keep track of garment sizes. For example, you could generate all of the
mediums at one time, then go back in and change to all the names for large garments.
Add Names to the Selected Names List
To add names to the selected names list, use the buttons between the two lists.
[>] - This button adds the highlighted (selected) name in the Available Names to the Selected Names list.
[<] - This button removes the highlight (selected) name from the Selected Names list.
[»] - This button adds all names from the Available Names list to the Selected Names list.
[«] - This button removes all names from the Selected Names list.
The buttons below the selected names list show which parts of the names will be added to the selected
names list.
• Both - This choice adds both first and last names (if available) to the selected names list.
• First - This choice adds the first name (first word listed) to the selected names list.
• Last - This choice adds the second name (all words after the first space) to the selected names list.
• Copy To Clipboard - This button copies the selected name to the clipboard of the computer.

Editing Individual Names
Once the selected names list is populated, you can view the names in the design by selecting a name
from the selected names list and clicking Apply. You may then proceed to edit the spacing, kerning, or
letter width of that individual name.

Generating the Group Name File(s)
Group Names file(s) are generated on saving. The file format will determine how the files are generated.
• OFM - Saves the setup file, but does not generate the group names.
• EXP or CND - Generates the group name file(s) based on output type selected.

92 of 218
Table of Contents

Output Type
The output type determines how the file(s) for the group names will generate.
• Design, Name, Repeat - This option will sew the design and name on the list. Then, after a color
change, it will sew the design again and the next name on the list. It will repeat until the list is
completed. This generates one file this is occasionally referred to as a name-stack. To sew this, set
your color sequence for the first set of the design and name, then place a pause/hold command
to make the machine wait. Repeat this sequence. This will allow the design to sew on a garment,
when the pause is reached, the machine will wait for you to swap the garments. You can then
sew the next design/name combo on the next garment.
• Design Once - This will sew the design elements once and then stack the names. This can work
well for traditional multi-head configurations. They can sew the design on all heads and then turn
off all but one head to sew a name. Then, turn that head off and the next one on to sew the next
name. Repeat until all the names have been sewn. Ideally with this configuration, you have no
more names than you have heads.
• Names Only - This will generate a file with just the names stacked.
• Design Only - This will generate a file with just the design elements.
• Separate Files - This will generate separate files. Each file will contain the design elements and
a unique name. The benefit of this method is that you can trace the design for every garment.
These files will be named with a number from the order of the list and the name. Example:
01TOMMY.exp

A Group Names file saved as separate files using .EXP

Saving and Opening Groups
Should you need to use multiple templates or designs with the same set of names, you can set up one
file first and save the group. For example, you may have a group that wants their names with a football
and another batch of garments with their same names with a mascot. Rather than inputing the names
twice, you can reuse the group.
• To save a group, click on the Save Group button. This will save both the available names list and
the selected names list in a .GRN file. Just remember where you saved it.
• To open/use a saved group, click on the Open Group button. Then, navigate to the .GRN file that
you would like to use. Click on Open to populate the available and selected names lists.
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Object Properties
Object Properties contains a variety of settings for the
elements within embroidery projects. These settings or
properties will change depending on the type of element or elements that are selected.
To access the object properties window:

Accessing Object
Properties Video

1. Select the desired element(s)
2. Access properties by one of these methods.
• Right-click on the selected element and select Properties
from the context menu,
• Double-click within the resize/edit box of a selected element.
• Go to View>Properties.
This will bring up the object properties window. The window is divided in two. The left side contains
categories and sub-categories while the right side of the window displays the properties contained in the
selected category.
Element/Stitch Type Selection Drop-Down
When multiple elements are selected, the object properties window will allow you to affect different subsets of those elements based on their element type and/or stitch type.
The Element/Stitch Type Selection Drop-Down will allow you to select to affect the following subsets of elements:
• All Elements - This will display properties that are common between all the selected elements.
• Lettering - This will display properties that will affect all the lettering within the selected elements.
• Single Line - This will display properties that will affect all the single line elements within the selected elements.
• Multi-Stitch Line Elements - So labeled because these elements contain multiple lines of stitching,
selecting this will display properties that will affect all the following stitch types.
• Satin - a subset of the Multi-Stitch Line Elements. This will affect all selected satin stitches.
• Fill - a subset of the Multi-Stitch Line Elements. This will affect all selected fill stitches.
• ZigZag - a subset of the Multi-Stitch Line Elements. This will affect all selected zigzag stitches.
• E-Stitch - a subset of the Multi-Stitch Line Elements. This will affect all selected e-stitches.
• Tackle - a subset of the Multi-Stitch Line Elements. This will affect all selected tackle stitches.
• Edge Fill - a subset of the Multi-Stitch Line Elements. This will affect all selected edge fill stitches.
• Decorative - a subset of the Multi-Stitch Line Elements. This will affect all selected decorative
stitches contained in either a column or complex fill element.
• Sequin - a subset of the Multi-Stitch Line Elements. This will affect all selected sequin fixing
stitches contained in either a column or complex fill element.
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• Walk - This selection will affect all walk types including the following stitch types.
• Normal - a subset of walk elements. This will affect all selected walk normal elements.
• Jump - a subset of walk elements. This will affect all selected walk jump elements.
• Bean - a subset of walk elements. This will affect all selected walk bean elements.
• Decorative - a subset of walk elements. This will affect all selected walk decorative elements.
• Sequin - a subset of walk elements. This will affect all selected walk sequin elements.
• Cross Stitch - This will display properties that will affect all the cross stitch elements within the
selected elements.
• Appliqué - This will display properties that will affect all the appliqué elements within the selected
elements.
• Expanded - This will display properties that will affect all the expanded elements within the selected elements.
• Manual - This will display properties that will affect all the manual stitch elements within the selected elements.
• Vector - This will display properties that will affect all the vector elements within the selected
elements.
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Saving Properties as Defaults
Your preferred object properties can be stored as the defaults for the current project or the software. To
set your own property defaults, use the following steps:
Open the object properties window.
1. Select your desired settings for the properties you use. This can be done by element or stitch type
by changing the selection in the drop-down menu.
2. Once satisfied, click on the Save As Defaults icon near the top of the left side of the properties window.

3. From the window that comes up, select whether you would prefer to save your defaults permanently or for the current project only.
4. Click OK.
Copy & Paste Properties
Object properties can copied from one element and pasted onto others. This is a great way to get your
settings just how you would prefer them. Adjust a small element and sew it out to check. Once satisfied,
those properties can be copied from that element and pasted onto others.
To Copy Properties of an Element:
1. Select the desired element.
2. Access the object properties window.
3. Click the Copy Properties button.

To Paste Properties of an Element:
1. Select the desired element.
2. Access the object properties window.
3. Click the Paste Properties button.

4. Click Apply to see the changes.
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Stitch Types
Stitch types have varying purposes and appearances. Many of the properties are specific to
either the stitch type or the element type. Some stitch types are software level dependent.
The common stitch types in the software follow. Examples are shown in flat on the left and
3D on the right. Not all stitch types are available for every type of element.
Walk Normal

Stitch Types
Video

Walk Normal stitches are single stitches that follow one after the other. Sometimes these stitches are referred
to as straight stitches or running stitches. They are typically used for traveling from one area of a design to
another without trimming, creating a manually digitized underlay, and creating small details or outlines.

Walk Bean
Walk Bean stitches are similar to the walk normal in that the stitches fall in a line and follow after each
other. The big difference is that walk bean stitches go over themselves multiple times before moving
forward. These stitches are often used for outlines, details, and decorative work. When the stitches are
shown flat in the software, these stitches appear a bit bolder than a walk normal. In 3D, these stitches
look the same in the software. When sewn, the extra layers of stitches build a bolder and slightly more
rounded stitch.

Walk Jump
This stitch type is actually a lack of stitches. Selecting this as a walk type will move the machine along the
indicated path without stitching. In the software, it shows as a dotted line. When viewed in 3D, these
elements are not visible. This is used for digitizing for older machines and is seldom used today.

Walk Decorative
Walk decorative allows a digitized or standard motif to follow along the specified path.

Walk Sequin
Identical to the walk decorative in many ways, this stitch type repeats a motif along a path. The motif for
this stitch type also contains a sequin eject command for machines that have sequin capabilities.
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Satin Stitch (Multi-Stitch Line Elements)
Satin stitches are probably the most commonly thought of stitch when thinking of machine embroidery. The
stitches only sink needle penetrations on either side of the form and the stitches typically run perpendicular
to the edges or across the form. This gives satin stitches a very rounded, shiny, and sculptural look.
Satin stitches are a bit limited in size range. To prevent stitches from snagging, keep stitch line lengths under
60 points or 6mm. If longer stitch lines are desired, consider a fill-style stitch to keep the stitches in the fabric.

Fill Stitches (Multi-Stitch Line Elements)
Fill stitches are often used for larger areas where stitches might otherwise snag. An element containing a fill
stitch will have needle penetrations throughout the form. These penetrations usually fall into a specific pattern.
The look of fill stitches tends to be a bit flatter than satin stitches. The stitch count of fill stitch elements also
tends to be higher than satin stitch elements because of the extra needle penetrations within the form.

Zig Zag (Multi-Stitch Line Elements)
Zig Zag stitches are often used in embroidery designs for the tacking down of appliqué material. They are
similar to satin stitches in that they go across the form and only sink stitches on the edge. The biggest
differences are the default densities (Zig Zag is pretty light) and the end stitches. Satin stitches usually
generate a full stitch on the ends of elements. Zig Zag stitches do not. They are always stepping forward.

E-Stitch (Multi-Stitch Line Elements)
Also called a blanket stitch, these stitches also are most commonly used as tack-down stitches for appliqué materials or decorative borders.

Edge Fill (Multi-Stitch Line Elements)
Creates a brick-like pattern with multiple needle penetrations just like the fill stitch does. The difference is
that the stitches run perpendicular to the indicated stitch direction lines.
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Tackle Stitch (Multi-Stitch Line Elements)
Tackle stitches are often used in embroidery designs for the tacking down of appliqué material. They are
extremely similar to zig zag stitches in that they go across the form and only sink stitches on the edge.
The biggest difference is that tackle stitches are by default denser. They are always stepping forward and
will not have a full stitch on the end of the element.

Decorative Stitch (Multi-Stitch Line Elements)
When decorative stitches are used within a multi-stitch line element, they repeat lines of repeating motifs
to fill an area. The spacing and scaling of these motifs may be changed.

Sequin Stitch (Multi-Stitch Line Elements)
The sequin stitches in multi-stitch line elements work like the decorative stitches. They just also include
sequin eject commands for machines with sequin capabilities. Sequins or stitches may need to be adjusted to avoid bruising or piercing a sequin with a stitch.
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Walk Element Properties
Walk elements will display different properties based on the stitch type. Stitch type is a
common property to all walk elements and is explained in the previous section. Selecting the
stitch type will display the properties listed below.
Walk Element
Properties Video

Walk Normal
• Stitch length - This property controls the length of each stitch
or the distance between needle penetrations. Longer stitches will stay up out of the fabric more. Short stitches tend to
sink down into the fabric. Make sure that your stitch lengths
are longer than the diameter of your needle to avoid thread
breaks.
Common settings for stitch lengths vary on purpose.
• 15-25 point length - Good for travel, underlay, and detail
stitches
• 40-65 point length - Good for basting stitches to be removed later

• Retrace - This will cause the walk element to sew forward and then backward. Each needle penetration will line up. The element will end sewing exactly where it began. Check the box in the
properties window or on the properties bar to enable this feature.
• Offset - Only available if Retrace is checked, this will alter the needle penetrations on the return to
prevent the needle penetrations from falling into the same hole. Changing this will shift the return
needle penetrations by the specified amount.
• Curve Compensation - This will shorten stitch lengths around
the inside of curves to help maintain the shape. Since longer
stitches give tighter curves a more angular appearance, this option will give the curve a much smoother and even appearance.

Walk Bean
Walk bean stitches have all the properties listed for walk normal
stitches. They also have one more property.

Curve
Compensation

Curve
Compensation

Off

On

• Bean Thickness - This property dictates how many time each
stitch will go over itself before moving forward. This can be set to any odd number between 3 and
13. Usually 3 to 5 stitches works well for most applications.

Walk Jump
Walk jumps use the same properties as a walk normal. The walk jumps just use those properties to move
the machine without stitching.
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Walk Decorative
• Pattern - This drop down menu allows you to select the decorative motif to repeat along the walk element.
• Width - This allows for the adjustment of the width of the
decorative motif.
• Height - This allows for the adjustment of the height of the
decorative motif.
• Auto-Adjust - This automatically adjusts the motif by the
specified dimension to fill the linear walk element. How the
adjustment is made may be changed by selecting a different
dimension from the drop down menu.
• Spacing - This allows you to change the spacing of the motif along the walk element.

Walk Sequin
• Pattern - This drop down menu allows you to select your desired sequin fixing stitches to repeat along the walk element.
• Shape - From this drop down menu, you may select the size
and shape of the sequins to be used in the element.
• Color - A specific color may be selected for the sequin to be
displayed in. If no color is selected, the box will display diagonal lines and the sequins will match the thread color of the
element.
• Width - This allows for the adjustment of the width of the
fixing stitches.
• Height - This allows for the adjustment of the height of the fixing stitches.
• Auto-Adjust - This automatically adjusts the fixing stitches by the specified dimension to fill the
linear walk element. How the adjustment is made may be changed by selecting a different dimension from the drop down menu.
• Spacing - This allows you to change the spacing of the sequins along the walk element.
• Feed Direction - This allows for the compensation for different embroidery machines and sequin
attachment angles. Make sure to select the one appropriate for your device.
• Sequin Compensation - The will add stitches to get out of the way of the sequin as it is ejected
when traveling in a direction that would otherwise damage a sequin.
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Top Stitching (Multi-Stitch Line Element)
Top Stitching properties will display differently depending on the stitch type selected. The stitch type may
be selected from the Stitch Type drop down or determined automatically by using auto.

Auto Stitch Type
Auto stitch type is enabled by checking the Auto box to the right of
the stitch type drop down. Auto stitch type will average the stitch
line lengths of the element to determine by size if the element
should contain a satin or a fill stitch.
The stitch type will be evaluated when the element is scaled, so if the element changes size, it may also
change stitch type to adapt to the new average stitch line length.
Auto Stitch Type Parameters
The parameters for auto stitch type are accessible by clicking on the
[...] box to the right of a checked auto box.
These parameters list out the properties for both size ranges. The
smaller (satin stitch) of the ranges is displayed on the left and the
larger (fill stitch) is displayed on the right. These ranges and properties may be adjusted in these fields. For more information on these
properties, see the following sections on properties for satin stitches
and for fill stitches.
When auto density is enabled, the stitch type drop-down is greyed out, but it will display the stitch type
being used in the selected element.
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Top Stitching Properties for Satin, Zig Zag, E-Stitch, and Tackle
While the stitches for satin, zig zag, tackle, and e-stitch all act slightly
differently, their properties are the same.

Density
The density property represents the space between
stitch lines traveling the same direction. Lowering this
number brings the stitches closer together. Raising the
number moves the stitches farther apart.

Density Video

Density may need to be changed based on the length
of the stitch or the application. Longer stitches may require tighter
densities as they stay farther out of the fabric. Materials with heavy texture may require stitches with
tighter densities to fully cover the material.
Density

Density

Density

Density

Auto Density
Auto density bases the density on the stitch line length. If an element
changes from thick to thin, the density will vary with the stitch line length.
This allows thinner elements to have a more open density while thicker elements have tighter densities.
To enable auto-density, check the auto-density box below the density field.
This will change the number in the density field to a percentage and base
the density on the width/density table found by clicking on the [...] button
to the right of the checked Auto-Density box.
Changing the density percentage will alter the density by multiplying the
density values in the table by that percentage.
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Short Stitches
Short Stitches are used in tight corners and tight curves where stitches have a tendency to
bunch up and can create holes in garments. This feature begins to adjust the needle penetrations on the inside edge of these curved or shapely angled elements to prevent so many
needle penetrations in one place.

Short Stitches
Video

Enabled by default to help avoid thread breaks, this feature can be disabled or enabled via
a check box in the top stitching category or the properties page. It also appears on the property bar as a
small button.

Short Stitches On

•

Short Stitches Off

When researching or discussing short stitches, you may find the recommendation that they
be turned off for small lettering or thinner elements. This is to prevent thread breaks. In your
software, short stitches are automatically disabled by default for stitch lines less than 20 points
long. The button or check box will still show active, but the short stitches will not be generated.
The setting for this is under the advanced sub-category.

Short Stitch Parameters
The parameters for short stitches are under the advanced sub-category. The parameters are as follow:
• Width - This percentage adjust the width of the shorter stitches. It is a percentage of a programmed short stitch. It is not a
percentage of the stitch line length.
• Threshold - When the inside dimension of the curve or angle
becomes less than or equal to this specified percentage of the
outside dimension, short stitches will be generated.
• Disable Short Stitches When... : When stitch line lengths fall
below this specified amount, short stitches will not be generated even when the feature is enabled. This is typically done to prevent thread breaks.
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Use Fill for stitch lines greater than:
To prevent satin stitches from becoming so long that
they are likely to snag and pull out of the material, this
feature will automatically change the stitches to a fill
stitch on any line of stitches that is longer than this
specified amount.

Use Fill
Video

By default, this will generate a random patternless fill for those
stitches. This is more visible on screen than in the sew-out and will
increase the durability of the embroidery.
To disable this feature, enter "0" into the field.

Top Stitching Properties for Fill and Edge Fill
Both fills and edge fills have similar properties.
Density and short stitches function as described in the previous section for satin stitches.

Trapunto
The trapunto function moves the travel stitches from within an shape
to the outside edges of the element. This function is usually only
used on lighter density fills as the stitches on the edges become too
small to sew well on tighter densities.
Trace Border
Trace border is a secondary property that becomes available when
trapunto is enabled. This feature walks around the outside edges of the shape to further hide evidence of
the travel stitches and give a cleaner look to the edge of the shape.

Trapunto Disabled

Trapunto Enabled

Trapunto Enabled + Trace Border
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Use Satin for stitch lines...:
To keep fill elements stitching smoothly and help avoid thread breaks, this feature will essentially remove
internal needle penetrations on stitch lines less than this specified amount.
To disable this feature, enter "0" into the field.

Fill Info
This section contains the information on how the fill is being created and essentially what pattern the
stitches or needle penetrations will work.

Stitch Angle
The stitch angle is set using either the stitch direction editing tool or the stitch angle field in the properties window or on the property bar. If more than one angle is utilized within the element, this field will
not be present.

Fill Pattern (Standard or Random)
Depending on the desired aesthetic, a random or standard fill pattern may
be selected. These pattern choices alter how the successive lines of stitches
and needle penetrations align with one another.
• Standard - Standard fills create a steady and even pattern with the stitches. This can be likened to the pattern a mason may make with bricks.
• Random - Random fills do not have a standard method for placing stitches. At times, a random fill can almost mimic the look of a satin stitch.

Stitch Length
The stitch length field determines the distance between the majority of the needle penetrations or length
of the stitches within the fill. Along the edges, the stitches may fall shorter than this length to preserve
the pattern of the fill.
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Partition Info
In a standard fill, the partition info is what creates the pattern of the stitches. It is what determines how
the stitches are staggered and on what angle the pattern repeats.
• # Partitions - When creating the fill, this number divides the stitch length by the specified amount.
These divisions are then used to determine where the needle penetrations will fall on successive
lines of the fill. This will also indicate how many lines of stitches will be sewn before the pattern
repeats.
• Part Seq - The partition sequence is the order in which the needle penetrations fall on successive
lines of a fill. The divisions of the partitions are numbered zero through the number of partitions
minus one. If you have four partitions, the sequence can contain the numbers 0, 1, 2, and 3.
By default, these numbers fall in order creating a linear look to the fill. These numbers can be
changed to alter the look of a fill.
• Angle - This partition angle is set in relation to the stitch angle. This imaginary line indicates the
line along which the repeat of the pattern falls.
0 1 2 3 0 1 2 3 0 1 2 3 0
0 1 2 3 0 1 2 3 0 1 2 3 0

Density

Stitch length

Stitch length
Fill Examples with 4 partitions, a sequence of 0123.

Angle: 90°

Angle: 45°

Random Fills
When Random is selected as the fill choice, you can choose the random type.
• Patternless - This creates a random and patternless fill that is difficult to distinguish any pattern
but maintains the stitch length.
• Random Offset - This alters the stitch pattern by varying the partitions while maintaining the stitch
length.
• Random Stitch Length - This alters the stitch length
• Random Factor - This percentage dictates the amount that random stitch length can deviate
from the specified stitch length.
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Presets
These preset fills will populate the stitch length and partition info. These are available in the properties
window as well as on the properties bar.
Select one of these fills from the drop-down menu. To see a preview of the fill, click on the [...] button to
the right of the preset drop-down.
Saving Your Fills
To save one of your fills to the presets.
1. Set all of your fill properties.
2. Click the Save button to the right of Presets.
3. Assign it a name and click OK.

Pattern Fill
Pattern fills are created by repeating a split or group of splits or fill islands throughout a shape. Needle
penetrations Line up on those split lines creating an embossed look to the fill.
Select one of these fills from the drop-down menu. To see a preview of the fill, click on the [...] button to
the right of the preset drop-down.

•

Pattern fills are far more noticeable with a satin stitch type and viewed in 3D on screen.

Fill Parameters
Properties in the Advanced sub-category will affect how fills sew out.
These fill parameters follow.
• Minimum Stitch Length on stitch line - This will prevent a fill
from creating a stitch less than the specified amount on any
stitch lines within that fill.
• Fill Overlap Lines - This will allow for a fill to overlap by the
specified number of stitch lines when smaller sections of the
fill need to meet up with themselves.
• Allow Interior Entry/Exit - This allows for a fill to begin or end
within the shape. If disabled, it will move the first and/or last
stitch to the closest edge.
• Travel Length - This will adjust the length of the walk stitches used for generated travel stitches.
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Top Stitching Properties for Decorative Stitches (Multi Stitch-Line Element)
The majority of the properties for multi stitch-line elements containing decorative stitches are the same as
for walk element with decorative stitches.
• Trace Border - This will run a walk stitch around the edges of
the element to hide travel stitches and give a more uniform
appearance to the shape.
• Stitch Angle - This angle indicates the line direction for the
decorative elements to follow. If more than one direction line
is in the element, this field will not be visible.
• Pattern - This drop down menu allows you to select the decorative motif to repeat along the walk element.
• Width - This allows for the adjustment of the width of the
decorative motif.
• Height - This allows for the adjustment of the height of the decorative motif.
• Auto-Adjust - This automatically adjusts the motif by the specified dimension to fill the linear walk
element. How the adjustment is made may be changed by selecting a different dimension from
the drop down menu.
• Spacing - This allows you to change the spacing of the motif along the walk element.
• Vertical Spacing - This adjusts the spacing between the lines of decorative stitches within an
element.
• Both spacing and vertical spacing may be adjusted graphically using the light blue handles extending from the main motif within a selected decorative multi stitch-line element.

Top Stitching Properties for Sequin Stitches (Multi Stitch-Line Element)
The majority of the properties for multi stitch-line elements containing sequin stitches are the same as for
walk element with sequin stitches.
• Stitch Angle - This angle indicates the line direction for the
sequins to follow. If more than one direction line is in the element, this field will not be visible.
• Pattern - This drop down menu allows you to select your desired sequin fixing stitches to repeat along the walk element.
• Shape - From this drop down menu, you may select the size
and shape of the sequins to be used in the element.
• Color - A specific color may be selected for the sequin to be
displayed in. If no color is selected, the box will display diagonal lines and the sequins will match the thread color of the
element.
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• Stitch Mode - Changing this will change whether the lines of sequins mimic the stitch lines in a
standard fill or an edge fill.
• Width - This allows for the adjustment of the width of the fixing stitches.
• Height - This allows for the adjustment of the height of the fixing stitches.
• Auto-Adjust - This automatically adjusts the fixing stitches by the specified dimension to fill the
linear walk element. How the adjustment is made may be changed by selecting a different dimension from the drop down menu.
• Spacing - This allows you to change the spacing of the sequins along the walk element.
• Feed Direction - This allows for the compensation for different embroidery machines and sequin
attachment angles. Make sure to select the one appropriate for your device.
• Sequin Compensation - The will add stitches to get out of the way of the sequin as it is ejected
when traveling in a direction that would otherwise damage a sequin.
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Underlay
Underlay is a sub-category to Top Stitching and
applies to multi stitch-line elements. It can be
accessed from both the property bar and the
properties window.

Underlay Video

Underlay stitches are often used as foundation
stitches for embroidery. Underlay is used to stabilize the material by attaching it to the backing. It can tack down material
nap, and it can add loft by building up your stitches.

Continuous Underlay (Lettering)
Lettering elements have the option to use continuous underly.
This check box only appears for lettering elements. Using this
feature will underlay an entire letterform before starting the
top stitching. If this feature is disabled, each segment of the letter will underlay and sew the top stitching
before moving to the next segment.
Continuous underlay can help keep the joints of smaller letters from gapping.

Auto-Underlay
Auto-underlay is a feature that bases the type of
underlay on the average stitch line length of the element. There are four size ranges and the properties
for those ranges can be accessed via the [...] button.

Primary and Secondary Underlays
The primary and secondary underlays provide the
opportunity to use two underlay types in conjunction. This also allows you to layer one underlay over
another.
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Underlay Types
Different underlay types have varied uses and benefits. The following lists the types from lease aggressive
to most aggressive underlays.

Center Walk
Center walk is a good underlay for smaller lettering and thinner elements. It adds one line of stitching down the middle of an element or
letter.
• Stitch Length - This adjusts the maximum length of the stitches
in the underlay. Stitches may fall short of this amount to better
fit around curves.

Edge Walk
Edge walks are very useful underlays for cleaning up the edges of wider elements on textured materials such as piqué knit, terry, or waffle
knit. Edge walk adds a line of stitching just on the inside of the edges
of an element or letter.
• Border Margin (Absolute) - Only available with the Absolute
radio button is selected, border margin gives the edge walk a
specific inset from the edge.
• Width (Percentage) - Only available with the Percentage radio button select, this adjusts where
within the element the edge walk falls based on a percentage of the width.
• Stitch Length - This functions the same as for center walk.
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Zig Zag
Zig zag underlays begin to tack down the nap of the material and start building up the loft of the stitches. This can be a good underlay for terry cloth, polar fleece, and thick knits. It walks through the middle
of the element and then zig zags back.
• Border Margin (Absolute) - Only available when the Absolute radio button is selected, border margin gives the underlay a specific inset from the edge.
• Width (Percentage) - Only available with the Percentage radio button select, this adjusts how wide
the underlay is under the element based on a percentage of the element width.
• Density - This adjusts how far apart the underlay stitches fall.

Double Zig Zag
Double zig zag underlays zig zags forward and then zig zags back. The stitches cross over each other
• Border Margin (Absolute) - Only available when the Absolute radio button is selected, border margin gives the underlay a specific inset from the edge.
• Width (Percentage) - Only available with the Percentage radio button select, this adjusts how wide
the underlay is under the element based on a percentage of the element width.
• Density - This adjusts how far apart the underlay stitches in each layer fall.
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Fill Underlay
Fill underlay creates a light fill underneath the top stitches. This is a good choice for stabilizing larger
areas. You can adjust the angle of the underlay in relation to the angle of the top stitching. This underlay
couples well with an edge walk or a secondary fill at another angle.
• Border Margin - Border margin gives the underlay a specific inset from the edge.
• Density - This adjusts how far apart the underlay stitches are.
• Angle - This sets the underlay stitch direction in relation to the top stitching stitch direction.
• Stitch Length - This adjusts the maximum length of the stitches in the underlay.
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Pull Comp(ensation)
Using pull compensation is a way to compensate for the pull of stitches on a material. If you
were to digitize a circle and then sew it out, you may notice that your circle looks more like an
oval. As stitches are sewn, they pull in. The distortion of your shape is dependent on the stitch
direction of the element.

Pull Comp Video

Pull compensation can be used to compensate for this. It is best when coupled with underlay, appropriate density settings, and good backing.

If you digitize a circle, you may have an oval on the sew-out.
Depending on the type of material you are sewing, you may need to
add some pull comp.

As you add pull comp to the digitized design, the stitch lines are
extended to compensate for the pull of the stitches. The digitized
circle with the added pull comp will sew out as a circle.

When an element or an input tool is selected, you can add or change the pull compensation using the percentage on the properties bar. You could also use the object properties window to access more options.

The property bar only has access to pull comp. If you want to use pull
offset instead, you’ll need to use the object properties window.
Lock XY
Locking the X and Y will keep the pull compensation equal in all
directions. If you would prefer to adjust in one direction more than
another, uncheck this box.

Pull Comp
Pull compensation multiplies the stitch lines in an element by the
specified percentage, extending them past the wireframe edge.
Due to the use of multiplication, it affects wider areas more quickly and
more drastically than thinner areas. This can make sense as longer stitch lines have more pull than shorter ones.
In the example, the trapezoid is 10 points wide at the narrowest and 100
points wide at the widest in the wireframe. 160% pull comp has been applied to make the narrow section have a stitch line of 16 points (10 × 160%
= 16). This makes the wider stitch lines 160 points wide (100 × 160% =
160). This example is a bit extreme, but it illustrates how much more drastically longer stitch lines are affected by pull comp.
Leaving this setting at 100% will leave the stitch line lengths unadjusted by
this field.
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Pull Offset
Pull offset extends the stitch lines of an element by adding the specified amount to each side. It affects all
stitch lines equally.
In the example, the trapezoid is 10 points wide at the narrowest and 100
points wide at the widest in the wireframe. 3 points of pull offset has been
applied to make the narrow section have a stitch line of 16 points (3 + 10 +
3 = 16). Because it adds to each side of the line, this effectively doubles the
number in the field and adds it to the stitch line length. This also makes the
wider stitch lines 106 points wide (3 + 100 + 3 = 106). This example i illustrates how evenly all stitch lines are affected by pull offset.
Leaving this setting at 0 will leave the stitch line lengths unadjusted by this field.

•

Often times, adding a few points of pull offset can help smaller lettering and thinner elements
sew out a bit more smoothly.

Max Pull Comp
The max pull comp value specifies a maximum amount a stitch line can be extended by using pull comp.
It does not specify the maximum length of a stitch line. It merely specifies the maximum amount that
may be added to it.

Small Column Pull Comp Scale
This property adjusts the smaller areas of elements differently than larger ones. If enabled, you will need
to specify how much additional you would like the smaller elements to be adjusted, and what size elements you consider to be smaller.
• Small Column Scale % - This value is the percentage of pull comp that is added to smaller
elements.
• Small Column Width - Any stitch lines smaller than this specified amount are deemed small columns and adjusted by the above setting.

Column Width
Both a minimum and maximum value for stitch lines can be set using this feature.
• Min Col Width - If a digitized stitch line within a multi stitch-line element falls short of this value, it
will be extended to meet this length.
• Max Col Width - If a stitch line within a multi stitch-line element exceeds this value, it will be
shortened to fit this length.

•

A Min Col Width of 8-10 points can sometimes be used to help prevent thread breaks on troublesome designs with stitches smaller than a needle diameter.
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Effects (Sub-Category)
The properties in the effects sub category are often used for creating
blends, fur effects, and the illusion of space.

Random Edge
The random edge feature will allow the edges of the stitch lines to
end randomly. They will be extended or shortened up to the specified
percentage of the width.
To enable random edge, check the enable box. Random edge will
affect different stitch types differently.
• Width - Using the width field, specify with a percentage the amount the stitch lines should extend
or contract past the wireframe edge.
• Type - Specify which ends of the stitch lines you would prefer to be affected by random edge.

•

Random edge can be used to quickly mimic grass, fur, or feather the edges of a shape.

Custom Density
Custom density allows the density to change throughout a form. This is often
used to blend one color into another by layering fills with custom densities.
To enable custom density, check the Custom Density check box.
• Type - Choose the way you want the density to vary through the form.
• Linear - This creates a linear progression for the density
from the minimum to the maximum.
• Convex - This changes the density along a curve from the minimum to the maximum and back again.
• Exponential - This creates an exponential curvilinear progression for the density from the minimum to the maximum.
• Wave - This creates a curvilinear progression for the density from the minimum to the maximum to the minimum and finally back to the maximum.
• Custom - This allows you to edit the density line/curve in the window as you would a wireframe outline.
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• Reverse - This reverses the density graph. This essential makes convex become concave and instead of progressing from the minimum to the maximum, the linear densities will move from the
maximum to the minimum.
• Min Density - This specifies the minimum density for the density graph.
• Max Density - This specifies the maximum density for the density graph.
• Blend - The layers two colors together. The first layer is the reverse density of the second layer.

•

For more effective blends, try blending colors that are closer together on the color wheel.
Making to large of a jump can ruin an otherwise effective blend.

•

Use stitch lengths to further the effect of blends. Since longer stitches stay out of the fabric and
shorter stitches sink, use a slightly shorter stitch length on the later layers to help the stitches
sink into the earlier layers and better complete the look of the blend.

•

Watch your stitch directions when layering fills for blends. Stitch directions that line up will
make for much more effective blends.

Custom densities were used in the numbers and the background for the "JACKPOT". Random edges were used on the highlights of many of the fruits.
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Distortion Effects
Distortion effects are most commonly used with fills. They can be used along with the previous effects to
further the illusion of space or depth of field.
• Type - from the drop-down menu, select the type of distortion you would like applied to your
element.
• Double Waved - This creates an editable line on the top and another on the bottom of the element. These lines can be edited like any wireframe line and manipulate the stitch lines. The stitch lines will attempt to progress from the first line
shape to the second line shape. It helps if the stitch direction of the element falls
between these two lines.
• Perspective - More easily seen with a decorative fill, the perspective distortion
creates the same types of lines as the double wave fill, but like the perspective
line type in the lettering tool, it makes the stitches within the element appear to
recede in space. Like the double wave lines, the perspective lines may be edited
like any wireframe line. Crossing the distortion line over the wireframe outline can
create some unusual results.
• Radial Out - This creates the illusion of the stitches creating a half sphere protruding from the surface. The size/depth of the sphere effect can be altered by selecting and dragging the handle of the circular effect line. The handle will appear as a
light blue diamond. It works very similarly to the arc line type in lettering. For this
distortion effect, the circle can fall within or outside the wireframe lines.
• Radial In - This creates the illusion of the stitches creating a half sphere receding
into the surface. The size/depth of the sphere effect can be altered by selecting
and dragging the handle of the circular effect line. The handle will appear as a
light blue diamond. It works very similarly to the arc line type in lettering. For this
distortion effect, the circle can fall within or outside the wireframe lines.

•

When using any of the effects, be mindful of the densities and severity of the effects. These
can add up and begin to ripple the surface of the material if taken to extremes.
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Advanced (Sub-Category)
The advanced sub-category contains filters and parameters for many of the multi stitch-line elements.

Fill Parameters
Properties in the Advanced sub-category will affect how fills sew out.
These fill parameters follow.
• Minimum Stitch Length on stitch line - This will prevent a fill
from creating a stitch less than the specified amount on any
stitch lines within that fill.
• Fill Overlap Lines - This will allow for a fill to overlap by the
specified number of stitch lines when smaller sections of the
fill need to meet up with themselves.
• Allow Interior Entry/Exit - This allows for a fill to begin or end
within the shape. If disabled, it will move the first and/or last
stitch to the closest edge.
• Travel Length - This will adjust the length of the walk stitches used for generated travel stitches.

Filter Parameters
The filter parameters will filter the stitches within a design. Setting
the value to 0 will disable that filter.
• Min Stitch Length - If a stitch length falls below this amount,
the software will begin filtering out alternate stitches until
stitch lengths fall above this amount.
• Max Stitch Length - If stitch lengths within a form fall above
this amount, the software will sink stitches along that stitch
line at intervals equal to this amount until the stitch lines fall
below this amount.
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Short Stitch Parameters
The parameters for short stitches are under the advanced sub-category. The parameters are as follow:
• Width - This percentage adjust the width of the shorter stitches. It is a percentage of a programmed short stitch. It is not a
percentage of the stitch line length.
• Threshold - When the inside dimension of the curve or angle
becomes less than or equal to this specified percentage of the
outside dimension, short stitches will be generated.
• Disable Short Stitches When... : When stitch line lengths fall
below this specified amount, short stitches will not be generated even when the feature is enabled. This is typically done to prevent thread breaks.

Auto-Processing
Auto-processing deals with the splice lines within a complex fill.
These lines allow for sub-divisions within an element. Because of this,
there is a need for those stitch regions to have overlap.
• Splice Overlap - This setting controls the amount of overlap
used by the sub-regions of a fill created by a splice line.
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Single Line (Object Properties)
Single line elements are a unique column element that uses one
input line and generates stitches off that line. The width of the
line is consistent throughout the element and is determined by the
properties.

Width
The width of the line can be set in the properties window, on the
properties bar, or graphically using the width handles (light blue diamonds). This width will be consistent throughout the line.

Line Position
The stitches for a single line element are generated in relation to the input line. This relation is selected
first by selecting which digitizing tool is used, but it can be changed in object properties.
• Center - This causes the stitches to be split evenly on each side of the line. The input line runs the
center of the stitches.
• Right - This causes the stitches to fall on the right side of the input line.
• Left - This causes the stitches to fall on the left side of the input line.
• Custom - This option produces a percentage and a slider. These can be used to adjust the stitches
to fall a percent on the left and the remaining on the right side of the line.

•

Like when driving, the side of the line is determined by the digitizing direction. If a circle was
digitized clockwise, selecting single line right would cause the stitches to fall to the inside of the
circle. If it was digitized counter-clockwise, the stitches would fall to the outside of the circle.

Single Line Center

Single Line Right
(Digitized Clockwise)
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Single Line Left
(Digitized Clockwise)

Single Line Custom
(80%/20%)

Corners
Corners can be troublesome areas for embroidery. The problem arises as
stitches navigate around corners. It can be common for them to bunch up
and cause puckering, thread breaks, and even holes in the garment. Notice
the dark area of stitches in the example. Such tight stitching is problematic.

Corners Video

Changing how the stitches handle the tighter angled corners can smooth
these problems out.
Single line column elements have a "Corners" property. This object properties sub-category will allow you to choose how that element handles corners.

Cap
Capping the corners is a way to keep the stitches in a consistent direction and maintain an even stitch spacing. The drawback of capping
comes from the limited range of use. Larger corners should not be
capped as longer satin stitches are prone to snagging and becoming
loose. Try to avoid creating satin stitches longer than 60 points in length.
To cap a single line column corner, check the cap option check box
in the "Corners" sub-category. If the angle of the corner falls within
range, the corner will cap.
• Angle - This sets the threshold for when a corner is capped.
• Overlap - This sets the number of lines that the cap stitches
will overlap the main leg of the column.
• Max St. Length - This determines the maximum stitch length
allowed in the cap. Typically this limit will not be reached unless the "Use Fill for Stitches Greater
Than..." feature has been disabled.

•

If an input point other than the exact corner or a stitch direction line other than bisecting the
corner exists within the area to be capped, the capping feature will not cap the corner.

Example of how a capped corner sews
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Miter
Mitering corners is another way to keep the stitches in a more consistent direction and maintain an even stitch spacing. Mitering works
well for less extreme angles and wider satin stitches. It splits the corner in two pieces and overlaps at the bisection of the angle.
To miter a single line column corner, check the miter enable check
box in the "Corners" sub-category. If the angle of the corner falls
within range, the corner will miter.
• Type - This allows you to select the type of miter.
• Type 1 - This is what many people think of when they think of
a mitered corner. It gives the appearance like the corner of a
picture frame.
• Type 2 - This type of miter can mimic the more traditional corner from a traditional sewing machine. It does not taper the stitches. It gives a more squared-off
appearance to the corner.
• Angle - This sets the threshold for when a corner is mitered.
• Overlap - This sets the amount the stitch lines are extended underneath the second half of the
mitered corner.

•

If an input point other than the exact corner or a stitch direction line other than bisecting the
corner exists within the area to be mitered, the mitering feature will not affect the corner.

Example of how a miter type 1
corner sews
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Example of a miter
type 2

Tie In & Tie Off
Tie stitches are small groupings of stitches a the beginning and/or end of embroidery elements. Their purpose is to lock the thread in place and prevent it from
pulling out when the machine starts sewing or trims.
Tie Stitches Video
Setting tie stitches appropriately for the design will
help keep the design running smoothly as well as stay in the garment
after laundering.

Manually Digitized Tie Stitches
In wireframe files, you may find tie stitches in the form of manually
digitized small walk normal or manual stitch elements at the beginning and end of an element. This is typical of older designs or designs from digitizers who may have started digitizing in older versions
of software.
If you zoom in on the last element of a color, you may see these few
stitches going back and forth across each other. If you don't see these, check the properties of the project for tie stitches.

In expanded stitch files, these tie stitches are a bit harder to see because you cannot just select the last
element before a trim.

Adding Ties In & Ties Off
The properties window allows you to automatically add tie stitches to a wireframe design. To do this:
1. Select the element(s) or project to which you would like to add ties.
2. Access the Tie In And Tie Off properties category.
3. Place a check in the check box beside the tie stitches you would like to add.
4. Adjust the properties as needed.
Ties in happen at the beginning of the element (or after a trim) whereas ties off happen at the end of the
elements (or before a trim).
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Tie Stitch Properties
• When To Tie - This drop down allows you to select when you would prefer to add tie stitches.
• Always - This option will add tie stitches to every wireframe element within a design.
• Only When Necessary - This option will add tie stitches at the beginning and end of a design
as well as before and after any trim command. This option is more efficient and can create a
smoother sew-out.
• Type - Select the style of tie stitch you wish to use from this drop-down.
• Style 1 - The most common and useful of the tie stitches, this tie
style uses full and half stitches back and forth over one another to
lock into place. It keeps the stitches in a linear pattern which is a
little easier to hide within the top stitches. If the number of stitches is left to "Default", this style will adjust the number of stitches
used based on the length of the stitch lines executed prior to the tie
stitch. This will allow longer stitches to have a more aggressive tie
and shorter stitches to have a more easily hidden tie stitch.
• Style 2 - This tie style keeps the needle penetrations in line with the
needle penetrations prior to the tie stitch. This is the least aggressive
tie style.
• Style 3 - This style also keeps the needle penetrations with the needle penetrations prior to the tie stitch. This style will work well only
for walk-type elements.

Style 1

Style 2

Style 3

Style 4

Style 5

• Style 4 - This extends the tie stitches beyond the wireframe outline.
• Style 5 - The most aggressive and most difficult to hide style of tie. It crosses in multiple directions and creates small cross.
• Width - This sets the width of the tie stitches. With most stitches, it is best to stay above a 10
point stitch, but ties can usually handle being a touch smaller. Try to keep your tie stitches between 6-8 points. Smaller stitches will sink down into the material and hold better, but if the
stitches are too short, it can cause thread breaks.
• Num(ber of) Stitches - This sets the number of stitches in the tie. The higher the number is, the
more aggressive and harder to hide the tie is. For style 1, leaving this setting at default will allow
the number of stitches to adjust based on the length of the previous stitches.

Auto Trim
When enabled by checking the box, auto trim will add trims wherever the distance between the exit
point of one element and the entry point of the next element exceed the specified amount.

Auto Tie
When enabled by checking the box, auto tie will add ties to elements wherever the distance between the
exit point of one element and the entry point of the next element exceed the specified amount.
126 of 218
Table of Contents

View
The View category lists check boxes for visual components. Check the ones that you would like to see.
Unchecked ones will be left hidden.
• Show Wireframe Points - This option displays the wireframe points even when the element is not
selected. Selected elements typically display these points as slightly enlarged.
• Show Wireframe Lines - This option displays the wireframe outlines of elements even when the
element is not selected.
• Show Stitches - This element shows the stitches of the element. This is the same function as the
show/hide stitches button on the view toolbar.

• Show Expanded Points - This displays the expanded points of an element. It displays the needle
penetrations as small plus signs. This is the same function as the toggle expanded points button
on the view toolbar.
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(Fabric) Styles
The Styles category allows you to apply a set of properties to a project, a selection, or the defaults of the software. This can be a quick
way to alter a design for a given fabric or application.

Creating A Style
To create a style,
1. Access the Styles category in Object Properties.
2. Click the Create Style... button.
3. Name the style to be created and click OK.
4. Populate the object properties window that pops up with your desired properties.
5. Click OK.
6. The new style is now available in the drop-down menu.

Editing an Existing Style
To edit a style,
1. Access the Styles category in Object Properties.
2. Select the style to be edited from the style drop-down menu.
3. Click the Edit button.
4. Make the desire changes to the properties pop-up.
5. Click OK.

Deleting an Existing Style
To delete a style,
1. Access the Styles category in Object Properties.
2. Select the style to be edited from the style drop-down menu.
3. Click the Delete button.

Applying A Style
To apply a style,
1. Access the Styles category in Object Properties.
2. Select the style to be edited from the style drop-down menu.
3. Select to apply the style to the project, defaults, or selection from the drop-down.
4. Click Apply.
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Vector (Object Properties)
The properties for vector objects deal mostly with the appearance
of vector artwork elements. This properties category is only available
when a vector element is selected.
• Pen Color - The pen color affects the color of the vector line.
• Clicking on "More Colors" will allow you to mix your own
custom color with sliders or numbers.
• No color or multiple selected colors will display as diagonal lines. (As shown)
• Pen Width - This setting affects the width of the vector line.
• Brush Color - This affects the fill color or the interior color of a closed vector shape.
• Curve Smoothing - This slider will add or remove input points and Bezier handles along the vector
element. For complex or rough shapes, this can simplify the form.
• Winding - The winding alters how a vector fill with holes is rendered. This can drastically alter how
a vector fill is transformed into a single line or appliqué element. This is initially determined by the
illustration program that created the vector fill.
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Appliqué (Object Properties)
The properties for an appliqué element affect the different portions
of a traditional appliqué design. The outline or locater stitch, appliqué color preview, tack-down, and cover stitch are all controlled by
this properties category.

General
The General section of the appliqué properties controls the fabric
preview and the color change between the outline (placement/locater) stitch and the tack-down.
• Background Type - The background type allows you to select
the style of the fabric preview. This will be displayed inside the
shape of the element but will not generate stitches.
• Solid color - Select a color from the drop-down or go to "More Colors" to mix your own. This
shows the interior of the element as a solid color.
• Cross Hatch - Select a color as you would for solid color (above) and the interior of the element will be display with a tiny cross hatch pattern utilizing the specified color.
• Graphic - an image of fabric may be used to represent the appliqué fabric in the interior of the
element. After selecting "Graphic", click on the [...] by the File Name to navigate to the fabric
image to be used.
• Color Change Enabled - This will enable a color change command between the outline and the
tackdown stitches. This allows an embroiderer to add a command into the color sequence of the
machine to stop the machine and place the appliqué material.

Tackdown Stitch
The purpose of a tack-down stitch is to attach the appliqué material to the garment/product as quickly as
possible without shifting the material.
• Enable - This check box enables the tack-down stitch. If the box is unchecked, a tack-down will
not be generated.
• Object type - The tack-down stitch for an appliqué may change depending on your application or
desired aesthetic. This drop-down will allow the switch from a column type (suitable for tackle, zig
zag, and e-stitches) to a walk type (suitable for walk normals and walk beans).
• Walk Stitch Offset (Walk Object Type) - This sets the distance from the outline stitch. Ideally, the
tack-down stitch will be inset from the outline stitch to ensure that the fabric is caught. It also will
ideally be covered by the cover stitch if present.
• Column Width (Column Object Type) - This sets the width of the column used for the tack-down.
It functions like a single line column element in that it is even all the way around the form.
• Inside/Outside Slider & Percent - Like the single line column elements, the tack-down stitches can
be shifted across the outline. It is often beneficial to have the majority of the stitch to the inside of
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the shape with just enough stitching on the outside of the shape to cover any slight fabric edge or
placement imperfections.
• Enable Color Change After Tackdown - This enables a color change between the tack-down stitch
and the cover stitch. Some embroiderers may choose to stop the machine between these to stitches to ensure that the appliqué material is completely caught by the tack-down and trim by hand
anything that is sticking too far out from under the tack-down.

Cover Stitch
The purpose of a cover stitch is to cover the tack-down stitch and the edge of the material with typically
a satin stitch.
• Enable - This check box enables the cover stitch. If the box is unchecked, a cover will not be generated. This may be left unchecked if a traditional tackle-twill look is desired.
• Column Width - This sets the width of the column used for the cover stitch. It functions like a single line column element in that it is even all the way around the form. You may prefer to set this
with a slightly larger value than the tack-down width as it will help to cover all the edges.
• Inside/Outside Slider & Percent - Like the single line column elements, the cover stitches can be
shifted across the outline. It is often beneficial to have the majority of the stitch to the inside of
the shape with just enough stitching on the outside of the shape to cover any slight fabric edge or
placement imperfections.

Appliqué Sub-Categories
On the left side of the object properties window, the properties for
the outline, tack down, and cover stitches can be set like any other
element. Their property types are displayed in parentheses.

•

Note that the corners property is available for appliqué elements like for single line and may be set separately for the
tack-down and cover.
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The Digitizing Process
The individual details and choices of digitizing are often specific to the digitizer, but most
digitizers go through vary similar digitizing processes. The following is a general overview of
the process many digitizers follow when turning artwork into embroidery.
1. Get the Graphic on the Screen

Digitizing Process
Video

• You can either open a graphic file or you can insert a graphic file into an open project. With some graphics, you can also copy out of one program and paste into DesignShop.
• If you have a scanner attached to your computer, you can also scan directly into DesignShop by
going to File>Scan Image...
2. Size the Graphic
• Scale the graphic to the intended size of the final sewout. Select it in the project view to scale.
• Many decisions for stitch types are based on the size of the elements. Digitizing at one size
and then scaling up or down before sewing out can lead to thread breaks, snagged stitches,
and registration loss.
3. Plan It Out
• Layers - Consider how you will layer your design. Embroidery can be very dimensional. Think
about moving from the background to the foreground.
• Thread Colors - Will the thread colors on top conceal the ones underneath?
• Path - How will you get from one area to the next? Do you have to trim? Is there a way to
avoid a trim?
• Push - Think about the direction you’re sewing. Try to sew away from elements you’ve already
sewn. If you sew toward existing stitching without stabilizing the area first, a ripple of material
can sometimes be created.
4. Stitch Types & Stitch Directions
• Different stitch types can create a variety of textures and the illusion of depth in a design.
• Size range - Many times, the size of an element will dictate the appropriate stitch type.
• Cross Contour - If you can create stitches that appear to go across a form, you can create a
more realistic and three dimensional appearance.
• Stitch Direction - by changing stitch directions, you alter the way light plays off of a thread. In
this way, you use one color of thread to create what appears to be many shades.
5. Set Up Your Properties
• Go to View > Properties to set up the default properties for the project. Then click on “Save
Current Settings to Defaults” and save them for the Project. You may find applying a style to
be a quick way of setting your properties.
• Setting properties can be done before or after digitizing. It is up to the digitizer what workflow works best.
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6. Input the Elements
• Create your elements using the DesignShop Input tools. You may find that digitizing in a contrasting color is a convenient way to better see what you are creating.
7. Finish Up
• Make adjustments to the properties.
• Add Tie Stitches.
• Center the design.
• Adjust for Push & Pull.
8. Sew It Out
• Sew out the design on a swatch of material that is similar to the final product.
9. Final Edits
• Using the sew-out as a guide, make any needed adjustments to your design.
• Sometimes another round of sew-outs and revisions is required.

Example Digitizing Plan
Below is an example digitizing plan for the earthday artwork in the graphics folder loaded
with the software. It is just one of many ways this artwork could become stitches.
1. Sky - Fill
Digitizing Process
Video

2. Top Mountain - Fill
3. Middle Mountain - Fill

Stitch Direction

4. Bottom Mountain - Fill
5. Water - Fill (Create depth with different stitch
directions for each wave)

8

1

6. Tree Top - Fill (avoid trim by traveling under
the trunks and black outline)
7. Tree Trunks - Satin (create rounded effect
with satin. Avoid trim by traveling under
black outline)
8. Sun - Satin for rays, fill for middle (sew rays
first and travel underneath middle of sun.
Cover up the travel stitches with the fill by
sewing the middle last.)
9. Outline - Satin (Outline waves and mountains
first. Cover the travel stitches with the horizon
line, then clean everything up with the outermost border.)

9
2

6
7

3

4
5
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Manipulating a Graphic Before Digitizing
Graphic elements should be scaled and appropriately positioned before the stitches are digitized on top
of the artwork. With the graphic file selected in the project view, resize handles appear in the view window and may be used like scaling embroidery elements.
Vector elements may be manipulated like embroidery elements. They may be scaled, rotate, and even
edit the same way.

Raster Image Properties
Raster images have a few properties that can make digitizing and preparing the artwork a bit easier.
To access these properties:
1. Select the graphic file in the graphics list of the project view.
2. Right-click on the selected graphic and select Properties.
General Graphics Properties (Tab)
• Name - This will change the label of the graphics file in the
project view.
• Hide - This will hide the graphics file. This is the same as the
Hide Graphic button on the view toolbar or the show/hide graphic eye in the project view.
• Dim - This will light all of the colors significantly and reduce the contrast. It can sometimes help
make the stitches more visible layered over the graphic when viewed this way.
Position Tab
The position tab allows you to manipulate the position and the rotation of the graphic using specific increments.
• X - This will move the image to the left or right.
• Positive numbers will move to the right.
• Negative numbers will move to the left.
• Y - This will move the image to up or down.
• Positive numbers will move up.
• Negative numbers will move down.
• Rotate - This allows rotation by specific degrees.
• Orientation - This will rotate by 90° increments with every click.
• At four clicks, the image will be mirrored, and you may continue with rotations.
Scale Tab
Only the top section of the Scale tab is available for graphics. This allows you to scale design to a specific
size or by percentage.
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Input Tools and Basic Digitizing Functions
While the digitizing tools in the software create different types of elements, they use similar
keyboard assists and shortcuts.

Selecting an Input Tool

Digitizing Tools Video

To select an input tool, click on the desired tool in the input tool bar
• If you don’t see the desired tool, it may be necessary to select the tool from a fly-out.
• To access a fly-out, click and hold on the tool within the same tool family. After
a half second, the other tools within this family will appear at the right. You may
then select your desired tool. This newly selected tool will now be displayed in the input tool bar
for this tool family.
• Tools with fly-outs are indicated by a small black arrow in the lower right corner of the tool.
Selecting Properties
Once a digitizing tool or an element is selected, you can change the properties on the properties bar.

Creating the Elements
After selecting a digitizing tool and setting the properties, you can create the elements in the view window. Many of these key commands will accelerate your digitizing.
• Left Click = Creates a Straight Point
• Right Click = Creates a Curve Point
• Click & Drag = Pulls Bezier Handles from a point as you digitize
• [Backspace] = Deletes the last input point you created
• [Enter] = Completes the element or moves to the next step of an element
• [Ctrl] + [Enter] = Completes a column with the exit point on the opposite side
• [Shift] + [Enter] = Closes an open shape and completes the element
• Holding [Alt] = Constrains line angles to 15° increments
• [Esc] = Removes all points from the element
• [Esc] x 2 = Deselects Input Tool

•

Use as few points as possible to create your shapes when digitizing. The fewer points an element has, the easier that element is to edit and scale. A straight line doesn’t get any straighter
by adding more straight points to it. A straight line is most effectively created by two straight
points. When working with curves, try to stay within 180° in any sequence of three points.
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Digitizing & Editing Preferences
Your digitizing style and preferences are usually fairly personal. To customize the software
to better fit your style, access the Preferences tab.
Toolbars & Preferences
Video

To change your digitizing preferences:
1. Go to the Tools menu and select Options.
2. Click on the Preferences tab.
3. Select your preferences.
• Point Size - This slider changes how large or small the
wireframe points are displayed.
• Constrain Line Angle - When holding ALT to constrain the
line angle while digitizing, this field will specify the degree
of constraint.
• Auto Scroll - While using a input tool, if you nudge the
side of the view window, it will automatically begin to
move with the cursor. This setting enables this feature and
controls the speed.
• Digitizing Cursors - This allows you to select the cursor
seen when using a digitizing input tool.
•

Small Crosshair

•

Large Crosshair

•

Arrow

•

Small Eye Crosshair

•

Large Eye Crosshair

• Full Screen Crosshair
• Digitizing Sound - Check this box if you would prefer to here a beep for every wireframe point
digitized.
• Lower tones indicate straight points.
• Higher tones indicate curve points.
• Icons - Select either to view the software with color or grayscale icons.
4. Click OK to affect the changes.
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Digitizing & Editing Icons & Cursors
As you move the cursor throughout the view window, it will change to indicate a multitude of positions
or states. These are listed below.

Editing Cursors
Edit Mode
• You can select elements
Cursor Over an Element
• You can click and drag to move the element.
• Hold [Alt] to constrain the movement to the X or Y axis.
Cursor Over a Line
• You can add points along the line.
• Click and drag to move the line
Cursor Over a Straight Point
• Click and drag to move the point.
• Hold [Shift] and click on the point to change it to a Curve Point.
• Hold [Shift] and click and drag off of the point to create a bezier handle.
Cursor Over a Curve Point
• Click and drag to move the point.
• Hold [Shift] and click on the point to change it to a Straight Point.
Cursor Over an Entry or Exit Point (or using the Entry/Exit Tool)
• Click and drag to move the entry or exit point to a new location.
Cursor Over a Letter Handle
• Click and drag on the handle to move the letter.
• Hold [Ctrl] and click and drag to move the letter off the line.
Cursor Over a Spacing Handle
• Click and drag on the handle to alter the spacing or arc line.
Cursor Over a Bezier Handle
• Click and drag on the bezier handle to alter a curve.
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Digitizing Cursors
Insert Hole, Split Line, or Fill Island
• Inserts holes, split lines, or fill islands into selected elements.
Insert Entry/Exit Points
• Insert or change the entry and exit points of the selected element.
• This tool can also resequence with multiple elements selected.
Insert Splice Line
• Inserts splice lines within a fill element. This creates sub-regions of an element that can
contain opposing stitch directions.
Insert Stitch Direction Line
• Inserts stitch direction lines within a multi stitch-line element.

Element Points
Straight Point
• Non-Selected points display in blue.
• Selected Points display in black.
• Bezier handles extending from these points may be moved
independently.
Curve Point
• Non-Selected points display in blue.
• Selected Points display in black.
• Bezier handles extending from these points are locked together.
Bezier Handle
• From a Straight Point, handles work independently.
• From a Curve Point, handles work in tandem.
Entry Point
• Indicates the start of an element.
Exit Point
• Indicates the end of an element.
Last Stitch of Previous Element
• Displays the last stitch of the previous element. If you are creating the first element of
the design, it indicates the origin of the design.
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Spacing Handle
• Spacing for decorative stitches, pattern fill elements, single line column width, and arc
line types can be adjusted with these handles.

Element Lines
Stitch Direction Line (Wireframe Editing Mode)
• Indicates the stitch direction of an element

Stitch Direction Line (Stitch Direction Editing Tool Selected)
• Creates a stitch direction line across a form. Multiple stitch direction lines can
be used to create different effects.
• This line is created by clicking and dragging across an element with the stitch
direction tool.
End Line (Stitch Direction Editing)
• Creates an end line before the end of the fill shape. This allows for the compensation of stitch push.
• This line is created by right-click and dragging across a fill element with the
stitch direction tool.
Singleline Width
• This line indicates the width of a single line column.
• The width of the column can be changed by clicking on one of the points of
the width and dragging.
Splice Lines
• These lines break up larger, more complex shapes into smaller regions. Each
region can have its own stitch direction line.
• This line is created by clicking and dragging across an element with the splice
tool. This is usually done at a junction or odd angle in the shape.)
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Digitizing a Walk Element
The process for creating elements with the walk input method is the same for all of the
walk types.

Walk Input Method

Walk Input Video

Select the walk input method by clicking on the tool in the input tool bar. If the walk input
method is unavailable, you may need to click and hold for a half of a second to access the tool
fly-out. If it is available in the input tool bar, simply clicking on the tool will select it for use.

•

Lines.bmp located in the graphics folder that was loaded with the software is a
good graphic to practice creating these linear walk elements.

Digitizing Straight Lines
To create a straight line using a walk input method, select the tool, then:
1. Lift-click to create a straight point at the beginning of the line.
2. Move the mouse to the end of the line and left-click again to create a straight point at the end of the line.
• If you would like to constrain the line angle to 15° increments, hold the ALT key while moving the mouse.
3. Press the ENTER key on the keyboard to complete the element.

1

2

Digitizing Curved Lines
To create a curve line using a walk input method, select the tool, then:
1. Left-click to create a straight point at the beginning of the line.
2. Move to the center of the curve and right-click to create a curve point.
3. Move to the end of the line and left-click to create a straight point.
4. Press the ENTER key on the keyboard to complete the element.
2

1

3
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Digitizing Complex Lines
• When creating curved segments, try to divide the curves into equal portions and use as few points
as possible. However, if a curve exceeds 180°, use multiple curve points.
• To create Sharp angles, use a straight point (left-click). Straight points allow a line to change drastically from a curve to a straight line, or from one angle to another.
2

5

6

1

4

3

Walk Decorative and Walk Sequin Elements
The orientation of the decorative motifs and sequin fixing stitches is determined by the direction the walk
element was digitized.

2

1

3
Digitized from left to right. Notice the direction of the leaves.

2

3

1

Digitized from right to left. The leave flow the opposite direction of the example above.
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Digitizing a Vector Line Element
Vector line elements are digitized the same way as a walk element. All the keyboard and mouse commands are the same. The big difference is the lack of stitch information and that the elements typically
appear in the vector list in the project view. Please see the walk normal section for the steps to digitize a
vector line element.

Vector Line Input Method
Select the vector line input method by clicking on the tool in the input tool bar. If the vector
line input method is unavailable, you may need to click and hold for a half of a second to access the tool fly-out. If it is available in the input tool bar, simply clicking on the tool will select
it for use. Watch for the tool tip to appear if you are unsure of the correct tool.
Since vector lines contain no stitch information, they will also not display an entry or exit point.
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Digitizing a Manual Stitch Element
Manual stitch elements are different from any other embroidery input elements in that every input point
creates a needle penetration and only where input points exist will there be a needle penetration. This
means that only where you click with this tool will there be a needle penetration.

Manual Stitch Input Method
Select the manual stitch input method by clicking on the tool in the input tool bar. If the manual stitch input method is unavailable, you may need to click and hold for a half of a second
to access the tool fly-out. If it is available in the input tool bar, simply clicking on the tool will
select it for use. Watch for the tool tip to appear if you are unsure of the correct tool.

Digitizing with Manual Stitches
Because you are digitizing every needle penetration with the manual stitch input method, you need to do
the following:
1. Select the tool and left-click every place you would like the needle to penetrate.
• Right-clicking will not produce a curve point as it is not possible to have a curved single stitch.
2. Press the Enter key to complete the element.

Uses for Manual Stitches
Manual stitches are a seldom used tool in the digitizer's toolbox, but they can be used to great effect.
Below is a list of possible uses for manual stitches.
• Hair, fur, and grass-like details.
• "Traveling" over a satin stitch of the same color.
• Custom Tie Stitches
• Custom Sequin Fixing Stitches
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Digitizing With Column Elements
The column tools are typically used for creating elements with stitches that change direction frequently
throughout the form. Traditionally, these tools were used for digitizing letterforms and more sculptural
elements within a design.

Column 1 Input Method
The column 1 input method utilizes alternating pairs of points. The line generated between
these points determines the stitch direction. Because of this, the stitch direction of the
column 1 element is determined as you digitize and must be considered as you create the
wireframe input points and outline.

Column 1 Video

Select the column 1 input method by clicking on the tool in the input tool bar. If the column 1
input method is unavailable, you may need to click and hold for a half of a second to access the tool
fly-out. If it is available in the input tool bar, simply clicking on the tool will select it for use. Watch
for the tool tip to appear if you are unsure of the correct tool.

•

Columns.bmp located in the graphics folder that was loaded with the software is a good graphic to practice creating column elements.

Creating Shapes with Column 1
To use a Column 1 Input Method:
1. Move the cursor into the view window and
start with a left-click to create a straight point.

3b

2. Cross over the form to the other side and leftclick again to create the first end and stitch
direction of your element.

3a

3. Continue crossing back and forth over the
form, clicking to create the wireframe points.
2

• Right-Click to create a curve.

1

3c

3e

• Left-click for a straight point which can create a sharp transition or angle.
• Watch the lines that connect the wireframe points. These will determine the stitch direction.
4. Press the Enter key to complete the shape and generate the stitches. Make sure you complete a
pair of points before pressing the Enter key.
• The exit point will be on the last input point.
• Press CTRL + Enter to move complete an element with the exit point on the opposite side of
the last input point.
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Stitch Directions and Curves
Watch your stitch directions on curves. Think of spokes on a wheel. Don’t try to “help” the curve along.
Notice how poorly the stitches fan on the example.

"Pairs" of Points
The points within a pair don’t have to be of the same type. Notice on the middle pair that the top is a
curve point, and the bottom is a straight.

Creating Complex Curves with Columns
When dealing with more complex curves, try to divide the curves into simpler ones. Avoid exceeding
180° in any set of three pairs. Also, try to think about your stitch directions as spokes on a wheel. Each
one should come out from the center of the arc.

Too Few Wireframe Points

Ideal Number of Wireframe Points

Too Many Wireframe Points
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Column 2 Input Method
The Column 2 Input method creates the wireframe outline and stitch directions independently of each other. The stitch directions are not tied to wireframe points and are set
after the outline is created. The tool lends itself to more organic or irregular shape.
Column 2 Video

Select the column 2 input method by clicking on the tool in the input tool bar. If the column 2
input method is unavailable, you may need to click and hold for a half of a second to access the
tool fly-out. If it is available in the input tool bar, simply clicking on the tool will select it for use.
Watch for the tool tip to appear if you are unsure of the correct tool.

Creating Shapes with Column 2
To use a Column 2 Input Method:
1. Start with a left-click to create a straight point.
2. Continue along the first side of the element
until you reach the end.

5a
7

7

3. Press the Enter key to complete the first side.
4. Left-click to start the second side with a straight
point. Notice that you will need to digitize in
the same direction, so start each side at the
4
same end of the shape.

2a

1

2b

5b

5. Continue along the second side. Digitize in the same direction as the first side.
6. Press the Enter key to complete the second side. The column 2 tool will temporarily shift to the
stitch direction tool.
7. Click and drag across the form to add a stitch direction. Continue adding stitch directions until the
desired effect is achieved. The order of the stitch direction lines does not matter.
8. Press the Enter key to complete the shape and generate the stitches.
• The exit point will be on the last input point.
• Press CTRL + Enter to move complete an element with the exit point on the opposite side of
the last input point.

Column 2 Input Method works well for shapes with even sides.
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Single Line Input Method
The single line input method uses a single digitized line and places stitches along that line.
The width of the stitches are constant throughout the line making this an excellent tool for
many borders.
Single Line Video

Select the single Line Input Method by clicking on the tool in the input tool bar. If you would
prefer a different single line method other than the one that is shown, click and hold for a
half of a second to access the tool fly-out. If the desired method is available in the input tool
bar, simply clicking on the tool will select it for use. Watch for the tool tip to appear if you are
unsure of the correct tool. If you select the wrong single line method, don't worry. The settings
for the single line can be changed after the element has been digitized.

Creating Shapes with Single Line Input Method
To use any Single Line Input Method:
1. Start with a left-click to create a straight point.
2. Continue by adding input points along the path. This is
very similar to a walk input method at this point.
3. Press Enter to complete the linear element.
4. Input the first width point with a left click or press enter
to accept the default width.

5

2a
4
1

2b

5. Input the second width point with a left click. This will
determine the width of the element and generate the stitches.

•

For more options for the placement of the stitches along the input line or how the stitches navigate sharp corners, see the Single Line properties section.

147 of 218
Table of Contents

Digitizing with Complex Fills
Complex fills were traditionally used for digitizing larger areas or areas with irregular edges that were
ill-suited for column tools or satin stitches.

•

Fills.bmp located in the graphics folder that was loaded with the software is a good graphic to
practice creating complex fill elements.

Complex Fill Input Method (Traditional Mode)
The traditional mode for complex fill input includes a single stitch direction and no sub-regions. It uses the same steps and the most common and limited information that have
been used for years. Because of this, it is the fastest method for creating a complex fill.
Traditional Video

Select the complex fill input method (traditional input mode) by clicking on the tool in the
input tool bar. If it is unavailable, you may need to click and hold for a half of a second to
access the tool fly-out. If it is available in the input tool bar, simply clicking on the tool will
select it for use. Watch for the tool tip to appear if you are unsure of the correct tool.

Creating Shapes with Traditional Mode
1. Input the wireframe outline of the complex fill by
left-clicking on the mouse to create straight points and
right-clicking on the mouse to create curve points.
• Try to use as few points as possible. Lines are the
straightest when between two straight points, and
curves are smoother when fewer points are used.
While fewer points are ideal, avoid creating curves
that exceed 180° in any set of three points.
2. To complete the shape, press Enter on your keyboard.
This will connect the line between the first and last
point, closing the shape.
3. If the shape has holes or places that you do not wish
to have stitches, you may digitize a wireframe outline
around those areas next, pressing Enter after each one.
When you have finished adding any holes, press Enter
again.

148 of 218
Table of Contents

4. Input your Entry Point by clicking where you would like
the fill to start stitching. Many times, this will be where
the previous element ended. The last stitch of the
previous element is displayed by a white cross-hair. This
can be inside or outside the wireframe shape.
5. Input the exit point. This is where you would like the
fill to end. This can be inside or outside the wireframe
shape.

6. Lastly, a stitch direction must be determined. To do
this, left-click and drag across the form, using the line
created to control the stitch angle. When the mouse
button is released, the stitch direction will be created.
To use the default stitch direction, you could press
Enter on the keyboard instead of clicking and dragging
across the form.
7. Stitches will be generated once the stitch direction has
been determined.

Planning for Push, Pull, and Sewing Direction
As you proceed through your elements, think about the direction of the stitching. Try to complete simple
shapes in one fluid fill. If a fill has to sew back towards with itself, there is the possibility that it will push
a ripple of fabric back with it. This will create a line of fabric where the fill doesn’t meet up. This effect
can be minimized with the use of appropriate underlay, but sewing in one direction can alleviate any potential issues with material push.

In this example, the stitches have pushed a ripple of material and
don’t quite meet in the final sew-out.

By altering the stitch direction and the entry and exit points, a much
smoother final sew-out can be achieved.
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Complex Fill Input Method (Unafill Input Mode)
The unafil mode for complex fill input includes sub-regions and multiple stitch directions. It
expands on the steps from the traditional mode. Because of this, it is more a more flexible
tool and may be used for more applications than the traditional mode.
Unafill Video

Select the complex fill input method (unafill input mode) by clicking on the tool in the input
tool bar. If it is unavailable, you may need to click and hold for a half of a second to access
the tool fly-out. If it is available in the input tool bar, simply clicking on the tool will select it
for use. Watch for the tool tip to appear if you are unsure of the correct tool.

Creating Shapes with Unafill Mode
1. Input the wireframe outline of the complex fill by left-clicking on the
mouse to create straight points and right-clicking on the mouse to create
curve points.
• Try to use as few points as possible. Lines are the straightest when
between two straight points, and curves are smoother when fewer
points are used. While fewer points are ideal, avoid creating curves
that exceed 180° in any set of three points.
2. To complete the shape, press Enter on your keyboard. This will connect
the line between the first and last point, closing the shape.
3. If the shape has holes or places that you do not wish to have stitches,
you may digitize a wireframe outline around those areas next, pressing
Enter after each one. When you have finished adding any holes, press
Enter again.

4. Now, you can input any splice lines that are needed. To input a splice
line, click from one edge of the fill and drag to the other. The splice line
will show in green. Splice lines divide a fill into smaller regions. Each
region can contain its own stitch direction. Press Enter on the keyboard
when all desired splice lines have been placed.
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5. Input your Entry Point by clicking where you would like the fill to start
stitching. Many times, this will be where the previous element ended.
The last stitch of the previous element is displayed by a white cross-hair.
This can be inside or outside the wireframe shape.
6. Input the exit point. This is where you would like the fill to end. This can
be inside or outside the wireframe shape.

7. Lastly, stitch directions must be determined. To do this, left-click and
drag across the form or region, using the line created to control the
stitch angle. When the mouse button is released, the stitch direction will
be created. Continue adding stitch directions for all spliced regions. If
desired, multiple stitch directions can be added to one region to create a
fan effect. Stitch direction lines will be displayed as a blue line with black
squares on each end.
8. Optional – While determining stitch directions, you may also define end
lines. End lines are used to both determine a stitch direction and stop
the stitching before the wireframe edge of a shape. Most commonly,
this feature is used to compensate for the push of stitches or to ensure
a full stitch at the end of a shape. To create an end line, right-click and drag from one edge of the
element to the other. An end line will be created and displayed as a red line. The stitches will also
stop at that line.
9. Press Enter to complete the shape and generate the stitches.

•

With the Unafil Input Mode, many different stitch directions can be input for one wireframe
outline. This can be used to create a sense of movement or depth in a design.
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Complex Fill Input Method (Manual Input Mode)
The Complex Fill Input Method (Manual Input Mode) will create shapes without stitches. The entry
points, exit points, splices, and stitch directions can be determined later using their respective editing
tools.
Select the complex fill input method (manual input mode) by clicking on the tool in the
input tool bar. If it is unavailable, you may need to click and hold for a half of a second to
access the tool fly-out. If it is available in the input tool bar, simply clicking on the tool will
select it for use. Watch for the tool tip to appear if you are unsure of the correct tool.

Creating Shapes with Unafill Mode
1. Input the wireframe outline of the complex fill by left-clicking
on the mouse to create straight points and right-clicking on
the mouse to create curve points.
• Try to use as few points as possible. Lines are the straightest when between two straight points, and curves are
smoother when fewer points are used. While fewer points
are ideal, avoid creating curves that exceed 180° in any set
of three points.
2. To complete the shape, press Enter on your keyboard. This will
connect the line between the first and last point, closing the
shape.
• There are no stitches in the shape at this point and it is displayed as a Vector Fill in the Design
section of the Project View.
3. Holes, entry points, exit points, splice lines and stitch directions lines can be added to the element later.
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Digitizing Vector Fills
The Vector Fill Input Method will create shapes without stitches. The entry points, exit points, splices, and
stitch directions can be determined later using their respective editing tools to convert the vector shape
into embroidery.
Select the vector fill input method by clicking on the tool in the input tool bar. If it is unavailable, you may need to click and hold for a half of a second to access the tool fly-out. If it is
available in the input tool bar, simply clicking on the tool will select it for use. Watch for the
tool tip to appear if you are unsure of the correct tool.

Creating Shapes with Vector Fill Input Method
1. Input the wireframe outline of the vector fill by left-clicking on
the mouse to create straight points and right-clicking on the
mouse to create curve points.
• Try to use as few points as possible. Lines are the straightest when between two straight points, and curves are
smoother when fewer points are used. While fewer points
are ideal, avoid creating curves that exceed 180° in any set
of three points.
2. To complete the shape, press Enter on your keyboard. This will
connect the line between the first and last point, closing the
shape.
• There are no stitches in the shape at this point and it is displayed as a Vector Fill in the Vector
List section of the Project View.
3. Holes, entry points, exit points, splice lines and stitch directions lines can be added to the element later
to convert the vector shape into embroidery.
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Digitizing An Appliqué Element
Appliqué and tackle twill designs are designs that are specifically digitized for using fabric
instead of stitches to fill in an area of a design. To create an effective appliqué element, it is
important to understand the sewing process for an appliqué design.
There are entire magazine and book articles devoted to different ways of doing appliqué
with different types of fabric. The variety is endless, but the core process remains mostly
the same.

Appliqué Video

Anatomy Of An Appliqué Design
1. Placement Stitch - To start, the embroiderer needs to know where to place the material and in
what shape to cut it. This is accomplished through a walk or run stitch that traces the outside
edge of the appliqué shape. This stitch line is referred to as a placement stitch, a locater stitch, an
outline stitch, or sometimes even the cut line. No matter what the line is called, it has the same
purpose. It shows the embroiderer where to place the appliqué material.

2. Place the Material - Typically after the placement stitch is sewn, the machine will be stopped so
that the material can be placed. Usually a light adhesive is used to keep the material in place while
it is being tacked into place. Some twill manufacturers will apply a pressure sensitive (peel-andstick) adhesive to the back of the twill.

•

If using spray adhesive, please spray outside or at least far from your machine.
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3. Tack-down Stitch - After the material has been placed, the edges are tacked down with a tackdown stitch. This stitch is usually an inset walk or run stitch, a zig-zag or tackle stitch, or an
e-stitch or blanket stitch. The purpose of this stitch is to attach the material to the product as
quickly as possible without shifting the material and losing the registration. Attempting to tack
down with a standard density satin stitch usually leads to pucking, bunching, and shifting of the
material.

4. Cover Stitch (Optional) - Many designs will stop after the tack-down, but many others will finish
the edge by following up with a satin stitch cover over the top of the tack-down.

Precut Appliqué
If you would prefer to cut your appliqué material ahead of time, you can use the placement stitch as a
template. Some embroiderers sew just that stitch onto the appliqué material while others sew it on a
manila folder and use that as a stencil for cutting the appliqué pieces.
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Appliqué Input Method
The Appliqué Input Method will create elements that can contain the locater stitch, the
tack-down stitch, and the cover stitch all within a single element. This means that while the
properties of each part may be edited independently, the wireframe shape will adjust all
three.
Select the appliqué input method by clicking on the tool in the input tool bar. If it is unavailable, you may need to click and hold for a half of a second to access the tool fly-out. If it is
available in the input tool bar, simply clicking on the tool will select it for use. Watch for the
tool tip to appear if you are unsure of the correct tool.

Creating Shapes with Appliqué Input Method
1. Input the wireframe outline of the appliqué element by left-clicking on the mouse to create straight points and right-clicking on
the mouse to create curve points.
• Try to use as few points as possible. Lines are the straightest
when between two straight points, and curves are smoother
when fewer points are used. While fewer points are ideal, avoid
creating curves that exceed 180° in any set of three points.
2. To complete the shape, press Enter on your keyboard. This will connect the line between the first and last point, closing the shape.
3. If the shape has holes or places that you do not wish to have
stitches, you may digitize a wireframe outline around those areas
next, pressing Enter after each one.

4. When you have finished adding any holes, press Enter again to
complete the element and generate the stitches.
5. The appliqué properties can then be altered in the object properties window. From there, outline stitches, tack-down stitches, and
cover stitches can all be changed or disabled independently.
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Appliqué Input
Method Video

Insert Trim
Machine trim commands are inserted between elements. Trim commands automatically occur between
colors, but if a trim is required within a color, the command must be inserted.
To insert a trim,
1. Select the element after which a trim is desired.
2. Insert the trim by using one of the following
• Click on the Insert Trim button on the input toolbar.
• Go to the Insert menu and select Trim.

Auto Trim
Trims can be set to automatically occur if connectors (the length
between elements) is longer than a specified amount. This setting is
controlled in the Tie In and Tie Off category of properties.
These trims will show differently in the project view. They will display
as "Auto Trim" and will be updated upon saving or pressing the
Update Auto Ties/Trims button on the object bar.

Return to Origin
The return to origin command traditionally was inserted at the end of a design.
Under the project properties (accessed by right-clicking on the project name in the project view and selecting "Project") there is a check box for return to origin. With this enabled, there will automatically be a
return to origin command inserted at the end of the project upon saving.
Should you need to insert the command manually, it is still available beneath the fly-out from the insert
trim command.
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Editing Modes
There are two main forms of editing that can be done in an embroidery design. These editing modes are
largely dependent on the type of file or embroidery element that needs to be edited.
The default mode for most of the work done in the software is wireframe editing mode. This mode can
be changed to expanded editing mode (editing the individual needle penetrations). It can also be used for
extending the wireframe editing capabilities for a wireframe element.

Wireframe Editing Mode
The edges of elements within a wireframe design can be manipulated using the mouse combined with
keyboard commands.
As you move the cursor throughout the view window, it will change to indicate a multitude of positions or
states. For information on these icons and cursors, see the Digitizing and Editing Icons & Cursors section.
Located on the view toolbar, this button will allow the editing of wireframe forms. It will also affect the
following elements a little differently.
• Individually selected letters - It will display with wireframe information and allow editing of the
letterform while maintaining the integrity of the lettering element. This can prevent needing to
convert the lettering to wireframe.
• Sequin Elements - Using this button will display handles for each sequin and they can be moved
like letters along a line.
Wireframe editing mode is also available through the right-click context menu under "Mode".

Expanded Editing Mode
Expanded Editing Mode is used for editing the individual needle penetrations of an embroidery element.
To access expanded editing mode, follow these steps:
1. Select the element to be edited.
2. Click on the expanded editing mode button on the view bar.
The individual needle penetrations will appear in the element.
3. With the cursor, you can do the following:
•

This indicates that you've over a needle penetration. To move it, click and drag.

•

This indicates that you've over a needle penetration. To delete it, select and press the delete
key on the keyboard.

•

This indicates that you've over stitch between needle penetrations. To add needle penetrations along a stitch, along the stitch line.

Expanded editing mode is also available through the right-click context menu under "Mode".

158 of 218
Table of Contents

Wireframe Editing Commands
The following commands are used to manipulate the wireframe outlines.
• Drag a point - Clicking and dragging on a selected point drags the point and the
bezier handles connected to that point.
• Alt + Drag a point - Holding the ALT key while dragging a selected point will constrain the movement of that point to 15° increments.

Wireframe Editing
Video

• CTRL + Drag a point - Holding the CTRL key while dragging on a selected point drags the point
and adjusts the bezier handles connected to that point to generate a perfect arc between the next
and previous points on that line.

• Ctrl + Drag a Bezier Handle - Holding the Ctrl key while dragging on a Bezier handle fixes the angle of the handle. This means that even if your move the mouse off of that line, the Bezier handle
will remain on the same angle.

• Shift + Clicking on a point - Holding the Shift key while clicking on a point will change it between
a straight and a curve. If you change from a curve point to a straight point, the handles will stay,
but they can be moved independently of each other. Handles on curve points are locked.

• Double-Clicking on a selected point - Double-clicking on a selected point will bring up the digitize
point properties box. This will allow you to choose which type of point you want by clicking one
of the radio buttons.
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• Shift + Dragging on a point - Holding the Shift key while dragging on a point will pull a Bezier
handle from a point that doesn’t have one. This is an easy way to curve a line coming off of a
straight point.

• Clicking on a line - Left-clicking on a line will add a straight point on the line.

• Right-Clicking on a line - Right-clicking on a line will add a curve point on the line.

• Clicking + dragging on a line OR CTRL + Clicking + dragging on a line - Clicking and dragging on
a line will drag that segment. It will adjust curves as well. This allows you to edit shapes without
adding points. Holding the CTRL key while doing this prevents accidentally adding a point.

• CTRL + Right-Clicking on a line - Holding the CTRL key while right-clicking on a line will change it
from a curve segment to a straight segment.
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Wireframe Element Editing Tools
Just below the input toolbar, you’ll find the editing tools. These tools are used for
changing existing complex fills, or converting manual and vector fills into stitches.
They can also be used on many column elements.
To use these tools, you must first have the element that you wish to modify selected.

Editing Tools
Video

Insert Hole, Split Line, or Fill Island
These tools insert shapes into existing multi stitch-line elements or vector fills. These tools
can be used to create holes or embossed effects in the stitches. If the desired tool is unavailable, you may need to click and hold for a half of a second to access the tool fly-out. If it is available in the input tool bar, simply clicking on the tool will select it for use. The tools are as follow.
• Insert Hole - This tool is used to insert a hole into an element. There will be no stitches inside the
shape of the hole.
• Insert Split - This tool creates a line inside an element. The needle penetrations of the stitches are
forced to fall along this line creating a visible,almost debossed line in the stitching.
• Insert Fill Island - Like insert hole, this tool creates a closed shape within an element. Instead of
removing stitches from this shape, the stitches are given a different fill pattern. The fill pattern can
be changed by accessing the object properties page while the island is selected.
To use one of these tools:
1. To insert a hole into a complex, manual, or vector fill, or any column, select the element.
2. Select the desired insert tool.
3. Input the wireframe outline of the hole, split, or fill island by left-clicking on the mouse to create
straight points and right-clicking on the mouse to create curve points.
• Holes and fill islands should be contained within the wireframe outline. They will also close
themselves when completed.
• Splits may extend beyond the wireframe outline to ensure the line extends to the edge of the shape.
Splits will not automatically close themselves upon completion. They can stay as a line segment.
4. To complete the shape, press Enter on your keyboard. Press Esc to deselect the tool.
• For holes and fill islands, this will connect the line between the first and last point, closing the
shape and completing the hole or island.

Hole

Split

Fill Island
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Properties of the Outline (Hole, Split, or Island)
The properties of the internal outlines created by the insert hole, split, or fill island can be
changed. To do this, the outline itself must first be selected.
1. Select the element with the internal outline.
2. With the element selected, click within the fill island or hole.
• For splits, the element will need to be expanded in the project view and the
"split" will need selected. This must be done within the project view for splits.
• Toggle Point List must be enabled to expand the project view enough to access
the wireframe points and the split outline.
3. The resize/edit box will now surround the internal outline.
4. Right-click within the box and select "properties" to access the properties of the
outline.

The properties are also available on the property bar when the internal outline is selected.
• Outline Type - From here, you may select the following:
• Hole - This contains no stitches
• Split - This contains the same stitches as the main element,
but the needle penetrations will fall along the outline.
• Fill - This is a fill island. The stitches on the inside of this
outline may contain a different fill pattern than those of
the main element.
• Satin - This too is a fill island, but the stitches on the inside
of the outline are satin stitches.
• Tiled - Checking this box will repeat the outline throughout the element. Spacer handles will appear and with these handles, the spacing of the repeat may be adjusted. This is how patterned fills
are created.
• Alternate Split - This will alternate so that only every other stitch line will sink along the outline.
• Blur outline - This option will essentially create two outlines space as far apart as the amount specifies. Even stitch lines will fall on one outline. Odd stitch lines will fall on the other.
The rest of the properties are consistent with the fill and satin stitch properties. These will only show for
the satin for fill outline type.

Deleting a Hole, Split, or Fill Island
To delete an interior outline, select that outline and press the delete key on the keyboard.
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Insert Splice
Splices are used to divide complex fills into smaller sub-regions. These regions can have
different and even opposing stitch directions.
There are three splice tools under the splice tool icon.
• Insert Splice - This splice tool creates a straight line as the edge between sub-regions.
1. Left-click and drag across the form where a splice line is desired.
2. Press Enter to finish editing splices.
3. Stitch direction lines will most likely need to be added to achieve the desired effect in the newly create sub-regions.
• Insert Curved Splice - This splice tool allows for curved edges of the sub regions.
1. With the element and the tool selected, begin to digitize the splice as you would a walk element. Start with a left-click. This can begin outside of the element outline.
2. Continue digitizing across the form where a splice line is desired. Right-click for curves. Leftclick for straight points and sharp angles.
3. Press Enter to finish the splice line.
4. More splice lines can now be added or press Esc to deselect the tool.
5. Stitch direction lines will most likely need to be added to achieve the desired effect in the newly create sub-regions.
• Auto Compute Splice Lines - Select this tool to automatically generate splice lines for the selected
element.
1. Splice lines are generated as soon as the tool is selected.
2. Stitch direction lines will most likely need to be added to achieve the desired effect in the newly create sub-regions.

Deleting a Splice Line
To delete a splice line, use the following steps.
1. In wireframe editing, select the element.
2. Select one of the end points of the splice line to be removed.
3. Press the Delete key on the keyboard to delete the entire splice line.
4. Stitch directions will need to be addressed after deleting a splice line.

•

With the splice tool selecting, right-clicking in the resize/edit box will bring up the option to
clear all splice lines.
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Insert Stitch Direction
Stitch direction lines are used to give direction to the embroidery stitches in an element.
There are three stitch direction tools under the stitch direction tool icon.
• Insert Stitch Direction - This tool creates a straight line for the stitch direction.
1. Left-click and drag across the form where a stitch direction line is desired.
2. Press Esc to finish editing stitch directions and deselect the tool.
• Insert Curved Stitch Direction - This stitch direction tool allows for curved stitch direction lines. These
usually work better with a more gentle curve. Tight curves can cause density and puckering issues.
1. With the element and the tool selected, begin to digitize the splice as you would a walk element. Start with a left-click. This can begin outside of the element outline.
2. Continue digitizing across the form where a splice line is desired. Right-click for curves. Leftclick for straight points and sharp angles.
3. Press Enter to finish the stitch direction line.
4. More stitch direction lines can now be added or press Esc to deselect the tool.
• Auto Compute Stitch Direction - Select this tool to automatically generate stitch direction lines for
the selected element.
1. Stitch direction lines are generated as soon as the tool is selected.

Editing Stitch Directions
To edit stitch directions using the tool, use the following.
1. In wireframe editing, select the element.
2. Select the insert stitch direction tool. This will change the view of the element. The input points
will vanish and stitch directions will change from a dotted black line to an editible blue line with
black squares on each end.
3. These lines may now be edited like a regular wireframe line.

Deleting a Stitch Direction Line
To delete a stitch direction line, use the following steps.
1. In wireframe editing, select the element.
2. Select the insert stitch direction tool. This will change the view of the element. The input points
will vanish and stitch directions will change from a dotted black line to an editible blue line with
black squares on each end.
3. These lines may now be edited line a regular wireframe line. Select the end of the line to be
removed.
4. Press the Delete key on the keyboard to remove the line.
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Insert Entry/Exit Points
This tool is used change the entry and exit points of an element. The entry and exit points of an
element can also be changed by selecting the element and then clicking on the entry or exit point
and dragging it to the desired location.
1. To insert an entry point and an exit point into a an element, select the element.
2. Then, select the Insert Entry/Exit Points tool.
3. Click where you want the element to start stitching. An entry point will be inserted.
4. Click where you want the element to finish stitching. An exit point will be inserted.

•

If multiple elements are selected, this tool can be used to resequence those elements, starting
where the entry point is placed and ending where the exit point is placed. Travel stitches will be
regenerated to accommodate the new order.

Automatic
Sequence Video
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Element Operations
Many operations can be performed on elements to speed editing and design creation.

Split Element
Elements may be split into two pieces along a designated line or point. This is handy for
removing unwanted parts of elements or inserting another element in between the two
halves for a more efficient sew sequence.
To split an element:

Split Element
Video

1. Select the element to be split.
2. Determine where the split should take place by selecting the wireframe point(s). If multiple points
are required, click on one first, hold CTRL, and click on the second to select them both.
• For walk, single line, and column 1 elements, only a single wireframe point needs to be
selected.
• For column 2 and fill elements, two points must be selected. The split will occur along the line
between the two selected points.
3. Once the wireframe point(s) is selected, split the element. This can be done a few ways.
• Right-click on one of the selected points, go to Operations>Split Element in the context menu.
• Click and hold for a half a second on the change element type tool to access split element
from the fly-out.
• Go to the menu Object, and select Split Element.

Break Object
Fills with splice lines may be broken apart at those splices. The sub regions of the fill become individual
fills when this occurs. This can be helpful in altering sew sequence and the layering of elements.
To break a fill with splice lines:
1. Select the element to be broken.
2. Break the element using one of the following methods.
• Right-click on the selected element, go to Operations>Break Object in the context menu.
• Go to the menu Object, and select Break Object.
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Combine Elements

Two or more overlapping fills may be combined into a single fill if desired.
To combine overlapping fills:
1. Select the overlapping fills to be combined.
2. Combine the fills using one of the following methods.
• Click on the combine elements button on the property bar. This will only be available if multiple fills are selected.
• Right-click on the selected fills, go to Operations>Combine Elements in the context menu.
• Go to the menu Object, and select Combine Elements.

Subtract Elements

Overlapping fills may also be subtracted from one another. The operation will remove the overlapped
portion of one of the layered fills.
To subtract an overlap from an element:
1. Select the fill to have the overlap removed first. The layering of the elements does not matter. The
first selected fill will be the one to have a portion removed.
2. Hold CTRL and select the second fill that overlaps the first.
3. With both fills selected, subtract the overlapping area by using one of the following.
• Click on the subtract elements button on the property bar. This will only be available if multiple
fills are selected.
• Right-click on the selected fills, go to Operations>Subtract Elements in the context menu.
• Go to the menu Object, and select Subtract Elements.

Overlap
When elements are next to each other on screen, they will most likely sew with a slight gap between
them on fabric. To avoid this, most embroidery elements overlap slightly.
When using subtract element, you can specify and overlap to be left when the portion of the fill is removed. This must be specified before the operation is executed.
To specify and overlap,
1. Right-click on the subtract elements button on the property bar.
2. Specify and overlap and click okay.
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Offset Outline
A fill may be modified by offsetting the outline. This will push the
edges of the wireframe outline out evenly all the way around the
form.
In the example, the fill was duplicated first to show the change. The
red is the original, the blue was offset by 20 points.
To offset an outline,
1. Select the fill to be altered.
2. Offset the outline using one of the following methods.
• Right-click on the selected fills, go to Operations>Offset Outline in the context menu.
• Go to the menu Object, and select Offset Outline.
3. Specify the amount that you would like the outline offset.
• Positive numbers push the outline out.
• Negative numbers inset the outline.
4. Click OK

Transform Outline
Like the perspective line type manipulates lettering, transform outline can manipulate elements and
groups of elements.
To transform an element or group of elements,
1. Select the element(s) to be transformed.
2. Access the transform outline lines using one of the following methods.
• Right-click on the selected elements, go to Transform Outline in the context menu.
• Go to the menu Object, and select Transform Outline.
3. A blue line will appear at the top and bottom of the elements. These may be edited like any wireframe line and the elements will distort to match the newly defined boundaries.
4. To complete the transformation, deselect the elements.
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(Drop) Shadow
A drop shadow can be generated for a wireframe element using the shadow function.
To create a shadow element,
1. Select the element(s) to be shadowed.
2. Access the shadow by going to the Object menu and selecting
Shadow.
3. Select your desired settings from the Create Shadow window.
• Stitch type - Select either a satin or a fill
• Angle - This sets the angle of the shadow.
• Offset - This indicates how far from the original element
the shadow will be generated.
• Overlap - This determines how far under the top stitching
the shadow element will extend.
• Stitch Top - This determines if the original element will be stitched or not.
• Alternate Stitching - If used in conjunction with Add Color Change and a lettering element, it
will generate a shadow for each letter so that the sew sequence sews a shadow and then the
corresponding letter. Each letter will first sew the shadow and then the letter as opposed to
sewing all the shadows and then all the letters. This will help with registration.
• Add Color Change - This will create a separate color block for the shadow element.
4. Click OK to generate the shadow element.
5. The shadow element or top element may be selected and moved and the removed areas of the
shadow element will continue to be removed and regenerated as the elements are repositioned.
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Change Element Type
The change element type feature allows you to select and element or elements and change them from
one type to another. The original elements can be replaced or added to. This feature will work on most
types of elements, but you cannot change from a manual stitch or expanded data.
To use change element type:
1. Select the element(s) to be changed.
2. Access the change element type feature using one of the following methods.
• Click on the change element type button on the on the input bar.
• Right-click on the selected element(s), go to Operations>Change Element Type in the context
menu.
• Go to the Object menu, and select Change Element Type.
3. From the Change Element Type window, select the type of element that you wish the selected elements to be changed to.
• If a single line column is selected, you have the option of
using the edge or the input line as the reference for the
new element.
4. Click on either Add or Replace to change the element type.
• Add will add an element with the same shape but a new
element type.
• Replace will replace the old element with the new one.
5. The new elements will immediately follow the original elements in the project view.

Using Keyboard Shortcuts
If desired, keyboard shortcuts can be used to access this feature more quickly. To do this:
1. Select the element(s) to be changed.
2. Hold the Shift key for the add function or CTRL for the replace function.
3. Click on the input tool of the type of element that you would like to change to.

•

Using the keyboard shortcut uses the input lines of single line columns as the reference line.

A single line column can be quickly added to a fill to create a border.

•

Some elements may require editing after an element change. Pay close attention to tighter corners or those with many wireframe points when converting to a single line column.
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Convert Object to Wireframe
The operation of converting objects to wireframe is a way to produce more easily editable
elements from an embroidery object. It will affect different element types in different ways.
• Lettering - Converting lettering to wireframe will break the lettering apart into the elements that make up the letterforms. This will populate the project view with column,
walk, and fill elements that mimic how the digitizer created the letters originally.

Convert to
Wireframe Video

• Appliqué - Using Convert Object to Wireframe on an appliqué element will create a separate element for the placement, tack-down, and cover stitches. Typically, this will be in the form of walk
and single line column elements.
• Expanded - Converting expanded data to wireframe will get the embroidery back to a wireframe
element. The software will process the expanded data and the majority of the information will be
translated, but not all data will be retained. Specific fill patterns or decorative elements may be
lost in the translation.
To use Convert Object to Wireframe:
1. Select the element(s) to be converted.
2. Access the convert object to wireframe feature using one of the following methods.
• Right-click on the selected element(s), go to Operations>Convert Object to Wireframe in the context menu.
• Go to the Object menu, and select Convert Object to Wireframe.
3. The newly converted elements will replace the original in the project view.

Auto Sequence
Auto Sequence is a feature that will alter the sew sequence of a set of elements based on parameters set
in the auto-sequence window.
To use Auto Sequence:
1. Select the elements or design to be sequenced.
2. Access auto sequence using one of the following methods.
• Click on the auto sequence button on the on the input bar (found in the entry/exit fly-out).
• Right-click on the selected element(s), go to Operations>Auto Sequence in the context menu.
• Go to the Object menu, and select Auto Sequence.
3. Select the parameters by with the elements will be sequenced.
• Minimize Jumps - this will minimize the jumps within the elements/design.
• Auto-Entry Exit - This will shift the entry and exit points with the elements.
• Generate Travel - This will generate travel stitches if the travel threshold is exceeded.
• Minimize Color Changes - This will minimize the color blocks within the design.
4. Click OK to see the changes.
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Step & Repeat
The step and repeat function is useful for sewing many smaller designs within a larger hoop. This might
be done for patches or emblems and it places the designs in columns and rows.
To use step and repeat:
1. Access the step and repeat function by going to the Object
menu and selecting Step and Repeat.
2. This will bring up the Step and Repeat Placement Window.
Enter your preferred settings.

•

These settings will be populated with the optimal numbers to
fit any hoop currently displayed in the view window.
• Spacing or Center - This choice determines what the spacing is based on. The designs will
either be spaced by the distance between the edges of the design (spacing) or the distance
between the centers of the designs (center).
• Number of Columns - Specify the number of columns you would prefer.
• Space Between Columns - Enter the amount of horizontal space you would like between the
design columns (dependent on the spacing or center choice above).
• Number of Rows - Specify the number of rows you would prefer.
• Space Between Rows - Enter the amount of vertical space you would like between the design
rows (dependent on the spacing or center choice above).
• Total Designs on last row - If the desired number of designs is less than the number of columns
multiplied by the number of rows, the number of designs on the last row may be specified so
that extra designs are not created. "0" disables this feature.

3. Preview the layout by pressing the Preview button.
4. Click OK to generate the repeated designs.

•

Step and Repeat may be used with Group Names to generate designs using different names
from the group names list.
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Converting Artwork to Embroidery
Artwork may be converted into embroidery a few different ways in the software. These methods vary by
artwork type.

Automatic Conversion (Raster Graphic)
If a nearly automatic conversion of a raster graphic is desired, you can achieve this using the following
method:
1. Open a raster graphic file.
2. Select the graphic file in the graphic list of the project view.
3. Use one of the following methods to access the conversion
tool.
• Click on the Convert Objects to/From Embroidery on the
Object Bar
• Click on the Graphic to Embroidery Assistant and then
click on the Convert to Vector button
4. In the Image Processing Options window that appears, select
your settings.
• Convert to - This drop-down is level-dependent and will
allow for the conversion to vector or embroidery. At lower levels, the drop-down is unavailable and the tool only
converts to embroidery.
• Number of Colors - This can be specified using the check
box or filtered using the slider.
• Image Filtering - This slider indicates how much the image will be filtered in the conversion.
• Overlap - Specify how much overlap elements will have when they touch each other.
• Include Background - The background color is usually ignored. Check this box to include it.
• Color order - Click and drag the color boxes into your desired sew order.

173 of 218
Table of Contents

Automatic Conversion (Vector Graphic)
If a completely automatic conversion is desired, you can achieve this using the following method:
1. Open a vector file.
2. Select the vector list in the project view.
3. Select any desired options for the conversion from the property bar. This is optional.
• Convert to Embroidery - This allows you to specify what type of embroidery elements to create. Leaving it as "Default" will automatically choose the type.
• Fabric Styles - This will adjust the properties of the embroidery elements based on the fabric
style selected.
• Use Vector Color - If enabled, the converted embroidery elements will maintain the color of
the original vector elements. If disabled, they will use the current color in the palette.
• Flatten - If enabled, this will function similarly to the subtract elements feature. It will remove
portions of the vector elements that are overlapped by later elements.
• Flatten overlap - If flatten is enabled, this will determine how much of the original element is left to be overlapped by later elements. With embroidery, if elements are to look as
though they touch in the final sew-out, it is best that they overlap a bit in the file.
• Options - Clicking on this will bring up options on how vector elements should be handled in
the conversion.
• Stitching - Specify the threshold to be a satin or fill.
• Sequencing - Determine how and when to generate travel stitches.
• Single Line - When converting vector line elements, this will
determine when to use single line elements instead of walk
elements. It also determines the width.
• Outlines - This sets guidelines on removing elements and
holes in elements too small for embroidery.
4. Convert the vector objects to embroidery using one of the following:
• Click on the convert button on the property bar.
• Click on the Convert Objects To/From Embroidery button on the object bar.
5. The embroidery elements will be listed in the design list in the project view.
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Stitch Graphic Region (Vector or Raster)
This tool works for both vector and raster artwork. It fills in with stitches any area that is
clicked. To use the tool:
1. Select the Stitch Graphic Region tool from the Object bar.
2. With the tool selected, click on the region of the graphic that you would like to be converted to
stitches.
3. The new created embroidery element(s) will be displayed in the design list in the project view.

Graphic to Embroidery Assistant (Vector or Raster)
The Graphic to Embroidery Assistant steps through the conversion of the artwork step by step. It provides
more opportunities for decision making and interpretation.
To use the assistant:
1. Open the graphics file.
2. Select the artwork to be converted.
• If selecting vector artwork, select the vector elements or the entire Vector List.
• If selecting raster artwork, select the artwork file in the Graphics List.
3. Click on the Graphic to Embroidery Assistant on the Object bar. This will launch the assistant and
a grid will appear in the background to indicate that launch. The property bar will also change to
begin prompting through the steps of conversion.
4. Select the desired conversion fabric style from the drop-down on the left of the bar.
5. (Step 1) - Specify the number of colors you'd like in the design.

• Specify the total number of colors to be in the design. This is the number of
thread colors to be used. It is not the number of color changes. The same colors may be repeated.
• Modify the artwork colors using the eyedropper to select colors and the paint bucket to
fill areas or holes with that color.
• If converting a raster graphic, you have the option to convert it to vector here.
6. Click Next to continue to the next step or Cancel to cancel the conversion.
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7. (Step 2) Select the color to convert.
• Click on the color to be converted. You can change how much of the color to convert in the next step.
• Flatten may be used to remove areas of color that are being overlapped by other elements.
This layering of elements would only exist in a vector list.
• Adjust the flatten overlap to extend the layers underneath the later overlapping layers.
• Click Exit to quit the assistant.
• Click Previous to return to the previous step.
8. Once a color as been selected, the assistant will move to the next step. (Step 3) Editing the elements in the color.
In this step, you need to specify what portions of the color you want to convert. You can also fill
in holes in elements during this step.
• Add Elements - Using the arrow with the plus, you can click on elements not included in
this color to add them.
• Remove Elements - Using the arrow with the minus, you can click on elements in the color
to remove them from this round of conversion.
• Fill Region - Using the paint bucket, you can fill in a single region (hole).
• Fill All Holes - Using the second paint bucket, you can click within a hole to fill all holes
within that element or shape. This can be useful when creating a fill that will later have
lettering on top of it. You can fill all the holes from the lettering at once.
• Click Next to continue to the next step.
• Click Exit to quit the assistant.
• Click Previous to return to the previous step.
9. (Step 4) Determine the sew sequence.
In this step, you need to decide in what order the elements will sew.
• Manual Sequencing - Using this tool, click on the elements in the order you want them to
sew. The numbers of the elements will change to reflect this process.
• Insert Entry/Exit Points - Using this tool, select where you want the elements to start sewing and where you want them to end. The software will sequence them according to this.
• Left to Right, Right to Left, or Center Out - Select any of these to sew in that order.
• Click Next to continue to the next step.
• Click Exit to quit the assistant.
• Click Previous to return to the previous step.
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10. (Step 5) Edit Splice Lines and Stitch Directions

In this step, splice lines and stitch directions can be added to the elements to complete their conversion to embroidery.
• Insert Splice - This splice tool creates a straight line as the edge between sub-regions.
• Insert Curved Splice - This splice tool allows for curved edges of the sub regions.
• Auto Compute Splice Lines - Select this tool and click on the element to automatically generate splice lines for the element.
• Insert Stitch Direction - This tool creates a straight line for the stitch direction.
• Insert Curved Stitch Direction - This stitch direction tool allows for curved stitch direction lines.
These usually work better with a more gentle curve. Tight curves can cause density and puckering issues.
• Auto Compute Stitch Direction - Select this tool and click on the element to automatically generate stitch direction lines for the element.
• Options - This accesses the vector options window as described above in the automatic
conversion.
• Click Next to continue to the next color. This will begin a repeat cycle starting with (Step 1).
• Click Exit to quit the assistant.
• Click Previous to return to the previous step.

Manual Conversion (Vector Graphic)
Vector elements can be quickly converted to stitches using the editing tools to indicate entry points, exit
points, splice lines, and stitch directions. See the editing tools section for more information on those
tools.
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Automatic Shapes & Designs
DesignShop has tools for automatic shapes. Some of these tools are used with digitizing input tools.
Other tools provide quick access to an editable library of custom designs.

Automatic Circle Input
The automatic circle input tool may be coupled with walk, vector line, single line, complex fill, vector fill,
and appliqué input methods. It can also be used with insert hold, split, and fill island. It assists with creating perfect ellipses and circles.
To use the tool;
1. Select the input method or insert tool (element must first be selected if insert tool is used).
2. With the tools selected, select the Automatic Circle Input.
3. Create the shape using the tool. If an input tool is used, you will create an element. If an insert tool is selected, you will need to create the shape within the
element you wish to insert a hole/split/fill island.
a. Click on one side of the desired ellipse.
b. Move the mouse to the other side of the ellipse. A dotted line will show. This
is creating one of the axis of the ellipse.
c. Click on the other side of the ellipse. This will complete the first axis.
d. Move the mouse in a perpendicular direction. This will create the second axis
of the ellipse and show the outline of the ellipse.
e. Click to finish the ellipse and generate the stitches or wireframe outline.

•

To create a perfect circle, hold ALT between the first to clicks.

Automatic Ellipse Tool
The automatic ellipse input tool works with the same tools as the automatic circle input tool.
To use the tool;
1. Select the input method or insert tool (element must first be selected if insert tool is used).
2. With the tools selected, select the Automatic Ellipse Input. You may need to access it
from the fly-out beneath the automatic circle input tool.
3. Create the shape using the tool
a. Click on one "corner" of the ellipse.
b. Move the mouse and click on the opposite "corner" of the ellipse to complete the shape.
• Holding ALT will generate a perfect circle from the center.
• Holding Shift will generate a perfect circle from a "corner".
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Automatic Rectangle Tool
The automatic rectangle input tool works with the same tools as the automatic circle input tool.
To use the tool;
1. Select the input method or insert tool (element must first be selected if insert tool is used).
2. With the tools selected, select the Automatic Rectangle Input. You may need to access it
from the fly-out beneath the automatic circle input tool.
3. Create the shape using the tool
a. Click on one corner of the ellipse.
b. Move the mouse and click on the opposite corner of the ellipse to complete the shape.
• Holding ALT will generate a perfect square from the center.
• Holding Shift will generate a perfect square from a corner.

Automatic Custom Shape Input & Designs
The custom shape input tool provides a catalog of shapes and designs that can be dragged and dropped
in to projects. The custom shapes can also be used with the same input tools as the automatic circle,
ellipse, and rectangle tools.
The custom shape input tool is located below the editing tools on the input toolbar.
To access the tool:
1. Click on the custom shape input tool.
2. The scrollable library will appear on screen.

Categories
The custom shapes library has five categories and a few sub-categories. These are navigated via the dropdowns on the left side of the customer shapes window.
• Custom Designs - This is a library of designs. These designs maintain their stitch information and
are ideal for dropping into projects as needed.
• There are custom design sub-categories, and you can add more.
• Custom Shapes - Stored as shapes with little stitch information, these are excellent for both drag
and drop as well as use with input tools.
• There are custom shape sub-categories, and you can add more.
• Decorative Stitches - These are used with the decorative walks and decorative fills, but the scrollable
library provides a nice preview of them. It also provides easy access for editing the decorative motifs.
• Custom Ties - A library for tie stitches that you create to be used with the Tie In and Tie Off property.
• Custom Sequin Stitches - This is a library of sequin fixing stitches to be used with sequin fill and
sequin walk types.
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Drag & Drop Use
Automatic shapes and designs are easily used with a drag and drop method. To use this method:
1. Access the custom shape input tool/libraries.
2. Using the drop-down menus on the left of the window, navigate to the shape/design that you
wish to use.
3. Left click and drag the shape/design from the library into the view window where you would like
to place it. It can be moved later.
4. Release the mouse button to place the shape/design into the view window and into your project.

Independent Use
Automatic shapes and designs can also be inserted and scaled or rotated. To use this method:
1. Access the custom shape input tool/libraries.
2. Using the drop-down menus on the left of the window, navigate to the shape that you wish to use.
3. Double-click on the shape/design in the automatic custom shapes window. It will highlight.
4. Insert the shape in one of the following ways:
• Double-click to insert the shape into the view window and project at the stored size and orientation.
• Click on one "corner" of the ellipse, then move the mouse and click on the opposite "corner"
of the ellipse to complete the shape.
• Holding ALT will generate a proportional shape from the center.
• Holding Shift will generate a proportional shape from a "corner" and allow for rotation.

Use With Input Tools
Automatic shapes can also be used with the same tools as the automatic circle, ellipse, or rectangle. This
works best with the Custom Shapes category. To do this:
1. Access the custom shape input tool/libraries.
2. Using the drop-down menus on the left of the window, navigate to the shape that you wish to use.
3. Select the input or insert tool that you wish to use with the shape.
4. Double-click on the shape/design in the automatic custom shapes window. It will highlight.
5. Insert the shape using the input tool in one of the following ways:
• Double-click to insert the shape into the view window and project at the stored size and orientation.
• Click on one "corner" of the ellipse, then move the mouse and click on the opposite "corner"
of the ellipse to complete the shape.
• Holding ALT will generate a proportional shape from the center.
• Holding Shift will generate a proportional shape from a "corner" and allow for rotation.
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Creating New Custom Shapes & Designs
New custom shapes and designs may be added to the library. To do this, use the following method:
1. Select the element or group of elements to be added to the custom shapes or designs library.
2. Copy them and paste them into a new project.
3. Center the design.
4. With the elements selected, do one of the following:
• Right-click and select "Save Custom Shape" from the context menu.
• Click on the "Add Current" button on the left side of the custom shapes window.
5. This will bring up the Save Custom Shape Dialog.
6. Name the shape.
7. Select either Custom Shape or Custom Design depending on the
intended use and the amount of stitch information to be stored.
8. Select the category for the new shape.
9. If a new category is desired, click in the category name dropdown/field and type the new name.
• Avoid the category "Patterns" as that is used for pattern fills.
10. Click OK.
11. The new design/shape and possibly sub-category will now be
available using the custom shape input tool.

Rename A Custom Shape/Design
1. Using the drop-down menus on the left of the window, navigate to and select the shape/design that
you wish to rename.
2. Click within the name of the design.
3. The name will swap to an edit field (like changing the name of a folder or file in your file browser).
4. Type the new name and press Enter on the keyboard.

Editing A Custom Shape/Design
1. Using the drop-down menus on the left of the window, navigate to and select the shape/design that
you wish to edit.
2. Right-click on the shape/design and choose "Edit" from the context menu.
3. This will open the stored design/shape file.
4. Make your edits in the view window and save the file.
5. Close the shape/design file.
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Deleting A Custom Shape/Design
1. Using the drop-down menus on the left, navigate to and select the shape/design to be deleted.
2. Right-click on the shape/design and choose "Delete" from the context menu.
3. A confirmation window will appear. Confirm the deletion to remove it from the library.

•

Empty sub-categories will automatically be removed from the drop-down menus.

Clipboard Shapes
The clipboard shapes tool allows you to utilize shape or design data as you would a custom shape or design.
This can be used independently (almost like a rubber stamp) or it may be coupled with walk, vector line, single
line, complex fill, vector fill, and appliqué input methods. It can also be used with insert hole, split, and fill island.

Independent Use
To use this tool without coupling it with an input tool:
1. Select the element(s) to be used as reference.
2. Copy the element(s) to the clipboard using any of the copy methods listed in the Basic Functions section.
3. Select the Clipboard Shapes tool. This may be found in the fly-out beneath the custom shapes input tool.
4. Insert the shape using the input tool in one of the following ways:
• Double-click to insert the shape into the view window and project at the stored size and orientation.
• Click on one "corner" of the ellipse, then move the mouse and click on the opposite "corner"
of the ellipse to complete the shape.
• Holding ALT will generate a proportional shape from the center.
• Holding Shift will generate a proportional shape from a "corner" and allow for rotation.

Use With Input Tools
To use this tool without coupling it with an input tool:
1. Select the element(s) to be used as reference.
2. Copy the element(s) to the clipboard using any of the copy methods listed in the Basic Functions section.
3. Select the input or insert tool that you wish to use with the shape.
4. Select the Clipboard Shapes tool. This may be found in the fly-out beneath the custom shapes input tool.
5. Insert the shape using the input tool in one of the following ways:
• Double-click to insert the shape into the view window and project at the stored size and orientation.
• Click on one "corner" of the ellipse, then move the mouse and click on the opposite "corner"
of the ellipse to complete the shape.
• Holding ALT will generate a proportional shape from the center.
• Holding Shift will generate a proportional shape from a "corner" and allow for rotation.
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Pattern Fills
Pattern fills are fills with repeating splits or fill islands. To see them on screen, it is necessary to view the
stitches in 3D.
Pattern fills work best with satin, fill, and edge fill stitch types.

Using Stored Patterned Fills
Several pattern fill motifs are loaded and stored with your software. To use one of these patterns:
1. Select the element(s) to which you'd like to add a pattern.
2. Access the stored patterns from object properties or the property bar.

3. Select one of the stored pattern fills from the drop-down menu.
4. The pattern outline will be placed in the selected element(s) as a split and the tiled option will be
enabled.

Modifying the Pattern
• The pattern spacing can be adjusted by moving the spacing handles protruding from the pattern
outline.
• The pattern size can be changed by selecting the split outline(s) and using the resize handles
around the split element in the view window to scale the split.
• Once selected, the split outline can be edited like any wireframe shape.
• The pattern can be changed to a different stored pattern by selecting a new pattern from the
stored pattern fills drop-down menu.
• The pattern can be removed by selecting "None" from the stored pattern fills drop-down or deleting all the internal split outlines from the element.
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Creating a New Pattern Fill
New pattern fills are created by inserting a split or fill island into a multi stitch-line element and tiling that
split outline. To create a new pattern fill:
1. Select the element to which you'd like to add a pattern.
2. Insert a fill island or split using the respective editing tools. See the insert hole, split, and fill island
section for more information.
• Any of the automatic shape tools or clipboard shapes work well for this task.
3. Once inserted, select the internal outline. This may need to be done from the project view for an
open outline.
4. Tile the selected internal outline using either the property bar or the object properties window.
5. Adjust the spacing using the spacing handles around the split in the view window.

•

Remember that pattern fills are only visible on screen if the stitches are viewed in 3D or the
expanded points are visible.

Saving a Pattern Fill
To store a pattern fill motif that you've created for later use, follow the steps below:
1. Create a pattern fill using the process above.
2. Select the split or fill island outline(s) in the pattern fill.
3. Right-click within the resize/edit box and select "Save Custom
Shape".
4. Name the shape.
5. Select the Custom Shape shape and the Patterns category.
6. Click OK
7. The pattern will now appear in the pattern fills drop-down menu.
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Editing a Stored Pattern Outline & Spacing
A stored pattern outline may be modified like any custom shape in the library.
1. Click on the custom shape input tool to access the custom shapes library.
2. The scrollable library will appear on screen.
3. Using the drop-down menus on the left of the window, navigate to Custom Shapes and the
Patterns category. Select the shape/design that you wish to edit.
4. Right-click on the shape/design and choose "Edit" from the context menu.
5. This will open the stored design/shape file.
6. Make your edits in the view window and save the file.
7. Close the shape/design file.

Rename A Stored Pattern
1. Click on the custom shape input tool to access the custom shapes library.
2. The scrollable library will appear on screen.
3. Using the drop-down menus on the left of the window, navigate to Custom Shapes and the
Patterns category. Select the shape/design that you wish to rename.
4. Click within the name of the motif.
5. The name will swap to an edit field (like changing the name of a folder or file in your file browser).
6. Type the new name and press Enter on the keyboard.

Deleting A Stored Pattern
1. Click on the custom shape input tool to access the custom shapes library.
2. The scrollable library will appear on screen.
3. Using the drop-down menus on the left, navigate to and select the shape/design to be
deleted.
4. Right-click on the shape/design and choose "Delete" from the context menu.
5. A confirmation window will appear. Confirm the deletion to remove it from the library.
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Decorative Stitches
Decorative stitches are repeating motifs typically composed of smaller elements. This differs from a pattern
fill in that the decorative stitches usually appear more open and the motifs can contain multiple types of elements as opposed to the debossed look of pattern fills.
Decorative stitches may be used with walk elements or multi-stitch line elements.

Using a Stored Decorative Stitch
To use a stored decorative stitch:
1. Change the stitch type of a selected element or input tool to "Decorative"
2. Select a pattern from the drop-down menu on the property bar or in the object properties window. Click Apply if using the object properties window.
3. The selected decorative element will repeat along a walk element or throughout a multi stitch-line
element.

Modifying the Decorative Element
• The decorative spacing can be adjusted by moving the spacing handles shown on a decorative
multi stitch-line element.
• The decorative motif size and spacing can be changed via the object properties window on all
decorative elements.
• The decorative motif can be changed to a different stored decorative stitch by selecting a new motif from the pattern drop-down menu.
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Creating a New Decorative Stitch
Decorative stitches are created by digitizing a smaller element or group of elements using a single color
and saving that as a decorative stitch much in the same way custom shapes and designs are saved.
To create a new decorative stitch:
1. Using input tools, create a small motif that you would like to use as a decorative
stitch.
2. Make sure that the beginning needle penetration and the end needle penetration
fall on the same Y coordinate. You may need to look in the project view or use
snap to grid for this. This is to allow the decorative motif to follow along a path
without connector stitches.
3. Center the design.
4. Select the elements.
5. Right-click within the resize/edit box and select "Save Custom
Shape".
6. Name the shape.
7. Select "Decorative" as the shape.
8. Click OK.
9. The new motif will now be available in the Decorative Patterns
drop-down.

A Walk Decorative and a Decorative Fill using the New Decorative Stitch
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Editing a Stored Decorative Stitch
A stored decorative stitch may be modified like any custom shape in the library.
1. Click on the custom shape input tool to access the custom shapes library.
2. The scrollable library will appear on screen.
3. Using the drop-down menus on the left of the window, navigate to Decorative Stitches. Select
the decorative stitch that you wish to edit.
4. Right-click on the decorative stitch and choose "Edit" from the context menu.
5. This will open the stored decorative stitch file.
6. Make your edits in the view window and save the file.
7. Close the decorative stitch file.

Rename A Stored Decorative Stitch
1. Click on the custom shape input tool to access the custom shapes library.
2. The scrollable library will appear on screen.
3. Using the drop-down menus on the left of the window, navigate to Decorative Stitches. Select
the decorative stitch that you wish to rename.
4. Click within the name of the decorative stitch.
5. The name will swap to an edit field (like changing the name of a folder or file in your file browser).
6. Type the new name and press Enter on the keyboard.

Deleting A Stored Decorative Stitch
1. Click on the custom shape input tool to access the custom shapes library.
2. The scrollable library will appear on screen.
3. Using the drop-down menus on the left of the window, navigate to Decorative Stitches. Select
the decorative stitch that you wish to delete.
4. Right-click on the decorative stitch and choose "Delete" from the context menu.
5. A confirmation window will appear. Confirm the deletion to remove it from the library.
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Sequin Stitches
Sequin as a stitch type can be used with walk elements and multi stitch-line elements.

Using a Stored Sequin Stitch
To use a stored sequin stitch:
1. Change the stitch type of a selected element or input tool to "Sequin"
2. Select a fixing stitch from the pattern drop-down menu on the property bar or in the object properties window. Click Apply if using the object properties window.
3. Select a sequin shape from the shape drop-down menu on the property bar or in the object properties window. Click Apply if using the object properties window.
4. The selected sequin fixing stitch will repeat along a walk element or throughout a multi stitch-line
element.
5. Sequin fixing stitches include a sequin eject command that is represented by a small shape with a
hole in it. The shape varies based on the selected sequin shape.

Modifying the Sequin Element
• The sequin spacing can be adjusted by moving the spacing handles shown on a decorative multi
stitch-line element.
• The sequin fixing stitch size and spacing can be changed via the object properties window on all
sequin elements.
• The sequin fixing stitch can be changed to a different stored fixing stitch by selecting a new pattern from the pattern drop-down menu.
• Individual sequins may be moved by selecting the element and clicking on wireframe editing
mode. This will add small handles (X) to each sequin. Moving this handle will move the sequin and
the fixing stitch like a letter on a line in a lettering segment.
• Dragging the handle will move the sequin along the stitch line.
• Holding CTRL while dragging the handle will move the sequin off of the stitch line. This will
create a connector stitch.
• Occasionally when working with sequins, expanded stitch editing is the easiest way to avoid
puncturing a sequin. To expanded stitch edit the sequin element, select the element and click on
expanded editing mode.

•

Sequins will display in yellow with a black halftone pattern if they are going to be punctured by a subsequent stitch. This is only visible when NOT
viewed in 3D. These punctured sequins can be avoided using the modification techniques above. The offending needle penetration is highlighted
and enlarged. This is most easily seen at higher zoom levels.
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Creating a New Sequin Fixing Stitch
Sequin fixing stitches are created by digitizing a smaller element or group of elements using a single color
and saving that as a sequin fixing stitch. This is nearly identical to the process of creating a new decorative stitch.
To create a new sequin fixing stitch:
1. Using input tools, create a small motif that you would like to use as a fixing stitch.
• Make sure that the beginning needle penetration and the end needle penetration fall on the
same Y coordinate. You may need to look in the project view or use snap to grid for this. This
is to allow the fixing stitches to follow along a path without connector stitches.
• Make sure that the start and end points are on the far edges of the design. This too is to allow
the fixing stitches to follow along a path without connector stitches.
• It is best to use manual stitches for the portion of the decorative stitch that affixes the sequin.
This will prevent the fixing stitch from puncturing the sequin.
2. Prepare for the sequin.
a. Create any design elements to occur before the sequin eject command.
b. Digitize to the outside of where the sequin will fall. If no design elements are desired, input at
least a single manual stitch input point.
3. Insert a sequin eject command. This is located in the fly-out beneath the trim
command.
4. Using a manual stitch, click in the middle of where you wan the sequin to fall, then
continue to click at points on the edge of the sequin and returning to the center
as needed. The sequin will appear when you press Enter and the manual stitch is
completed.
5. Continue creating any more manual stitches or decorative portions of the fixing stitch.
6. Center the design.
7. Select the elements.
8. Right-click within the resize/edit box and select "Save Custom
Shape".
9. Name the shape.
10. Check the "Sequin" box in the lower half. This will limit your category choices to sequin shape and sequin stitch.
11. Select the Sequin Stitch as the shape.
12. Click OK.
13. The new fixing stitches will now be available in the sequin Patterns
drop-down.
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Editing a Sequin Fixing Stitch
A stored sequin fixing stitch may be modified like any custom shape in the library.
1. Click on the custom shape input tool to access the custom shapes library.
2. The scrollable library will appear on screen.
3. Using the drop-down menus on the left of the window, navigate to Custom Sequin Stitches.
Select the sequin fixing stitch that you wish to edit.
4. Right-click on the sequin fixing stitch and choose "Edit" from the context menu.
5. This will open the stored sequin fixing stitch file.
6. Make your edits in the view window and save the file.
7. Close the sequin fixing stitch file.

Rename A Sequin Fixing Stitch
1. Click on the custom shape input tool to access the custom shapes library.
2. The scrollable library will appear on screen.
3. Using the drop-down menus on the left of the window, navigate to Custom Sequin Stitches.
Select the sequin fixing stitch that you wish to rename.
4. Click within the name of the sequin fixing stitch.
5. The name will swap to an edit field (like changing the name of a folder or file in your file browser).
6. Type the new name and press Enter on the keyboard.

Deleting A Sequin Fixing Stitch
1. Click on the custom shape input tool to access the custom shapes library.
2. The scrollable library will appear on screen.
3. Using the drop-down menus on the left of the window, navigate to Custom Sequin Stitches.
Select the sequin fixing stitch that you wish to delete.
4. Right-click on the sequin fixing stitch and choose "Delete" from the context menu.
5. A confirmation window will appear. Confirm the deletion to remove it from the library.

Saving Sequin Files
Sequin eject commands are saved in OFM and DST file formats only. Saving as any other file type will remove any sequin eject commands.
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Creating a New Custom Tie Stitch
Custom tie stitches are creating by digitizing a smaller element or group of elements using a single color
and saving that as a custom tie stitch much in the same way custom shapes and designs are saved.
To create a new custom tie stitch:
1. Using input tools (usually a manual stitch), create a tie shape that you would like to
use as a custom tie stitch.
2. Center the design.
3. Select the element(s).
4. Right-click within the resize/edit box and select "Save Custom
Shape".
5. Name the shape.
6. Select "Custom Tie" as the shape.
7. Select Both, Tie In, or Tie Off
8. Select the rotation for the tie.
9. Click OK.
10. The new tie stitch will now be available in object properties tie ins
and tie offs category.

Editing a Stored Custom Tie Stitch
A stored decorative stitch may be modified like any custom shape in the library.
1. Click on the custom shape input tool to access the custom shapes library.
2. The scrollable library will appear on screen.
3. Using the drop-down menus on the left of the window, navigate to Custom Ties. Select the
tie stitch that you wish to edit.
4. Right-click on the decorative stitch and choose "Edit" from the context menu.
5. This will open the stored tie stitch file.
6. Make your edits in the view window and save the file.
7. Close the tie stitch file.
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Rename A Stored Custom Tie Stitch
1. Click on the custom shape input tool to access the custom shapes library.
2. The scrollable library will appear on screen.
3. Using the drop-down menus on the left of the window, navigate to Custom Ties. Select the
tie stitch that you wish to rename.
4. Click within the name of the tie stitch.
5. The name will swap to an edit field (like changing the name of a folder or file in your file browser).
6. Type the new name and press Enter on the keyboard.

Deleting A Stored Custom Tie Stitch
1. Click on the custom shape input tool to access the custom shapes library.
2. The scrollable library will appear on screen.
3. Using the drop-down menus on the left of the window, navigate to Custom Ties. Select the
tie stitch that you wish to delete.
4. Right-click on the tie stitch and choose "Delete" from the context menu.
5. A confirmation window will appear. Confirm the deletion to remove it from the library.
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Photo Fill
The Photo Fill feature allows you to process an image into a black and white or three color process image. The Photo Fill feature generates expanded elements and is not meant to be edited.
Photo Fill processes an image into a grid of stitch elements. These elements range in value from dark
to light. This is achieve by varying the number, length, and density of the stitches within the elements.
When put together and viewed from a distance, the rendered image becomes clearly visible.

To Use Photo Fill
1. Open a raster graphic that you would like to convert.
2. Select the graphic file in the graphics list in the project view.
3. Right-click on the selected file and select "Photo Fill"
4. Choose your settings in the dialog that comes up.
• Graphic Size - This is the pixel dimensions of the original graphic as
opened by the software.
• Output Design Size - This is the size of the embroidery element to be created.
• Design Element Count - This specifies the number of stitch elements to be
used in rows and columns.
• Element Size - This determines the size of the stitch elements to be placed
in the grid. The smaller elements will give better detail, but they also will
increase the stitch count substantially.
• Design Type - Here you can decide if the final embroidery design is a single
color or three color process.
• Linear distribution - This will alter the values within the image for more
even distribution of the lights and darks.
• Equalize Contrast - This will adjust the values within the image to equalize
the contrast.
• Brightness Adjustment - This will slide the whole value scale of the image
up or down. It will make the entire image lighter or darker.
• Automatic Column Outline - This will generate a single line center element
around the image to create a border.
• Hide Graphic on Completion - If this is checked, the graphic will be hidden
when the stitches are generated.
5. Click OK to generate the stitches.

•

Color images should be sewn with the color sequence of Yellow, Magenta, Cyan and should be
sewn on white material. These threads should match the printers' process colors as closely as
possible for the best results.
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Cross Stitch
The Cross Stitch feature allows you to mimic the hand-sewn art of cross stitch. These cross stitch elements may be digitized or converted from images.

Manually Digitizing Cross Stitch
To manually digitize a cross stitch element:
1. Select the Cross Stitch Input Method.
2. Click and drag a box within the view window. This will create the grid within which the little crosses will be placed.
• The size of the grid can be changed by dragging any of the resize handles on the selected grid.
3. Input your cross stitch design on the grid using the following tools on the cross stitch toolbar:

• Color Drop-Down Menu - The cross stitch feature has a set number of colors in which to sew.
It will sew all of one color before moving on to the next color. This drop-down allows you to
choose the color (number) you wish to digitize in.
• The first time you use a color number, you will need to select a color from the palette for it.
• Cross Drop Down - This menu allows you to fill in the grid areas with a variety of shapes from
crosses to stars and half shapes.
• Cross Stitch Pencil - This tool allows you to draw your design on the grid. Left-click and drag to
do this. A single click will input a single cross.
• Hold the ALT key and click with the tool to flood an enclosed area with the selected color.
• Cross Stitch Line - This works like the walk input methods, but generates cross stitches within
the grid.
• Cross Stitch Fill - This tool works like the manual fill or vector fill, but it generates cross stitches
within the grid.
• Touch Up - This tool allows you to erase individual segments of the crosses.

195 of 218
Table of Contents

Converting An Image Into Cross Stitch
Any raster graphic file can be converted into cross stitch. To do this:
1. Open a raster graphic file.
2. Select the graphic file in the graphics list in the project view.
3. Right-click on the selected file and select "cross "
4. Choose your settings in the dialog that comes up.
• Thickness - Similar to bean thickness, this sets the number
of times the thread will pass over itself for each item.
• Shape - Sets the shape of the stitch element (cross)
• X Size - Sets the width of the stitch element.
• Y Size - Sets the height of the stitch element.
• Lock - Locks X and Y Size to always be the same.
• Number of Colors - Specify the number of colors to use for
the design.
• Use Palette Colors - This allows you to specify the colors
via the palette. If unchecked, the tool will select RGB values for the colors.
• Filter - Select the amount of filtering for the image.
• Include Background - Enable only if you desire the background color to be included in the
cross stitch element.
• Click and drag the color order - From here you can alter the sew order by dragging the color
blocks within this field.
5. Click OK to generate the cross stitch element.

Cross Stitch Properties
Properties of an existing cross stitch element are available in the object properties window.
They are as follows:
• Type - This selects the shape of the stitch element (cross)
to use.
• Overlap - The sets the overlap for the crosses.
• Thickness - Similar to bean thickness, this sets the number
of times the thread will pass over itself for each item.
• Grid Size - This sets the size of the grid squares.
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Alphabet Editor
The alphabet editor allows you to make changes to existing alphabets as
well as create new ones.
To access the alphabet editor, go to the Tools menu and select Alphabet
Editor.
Newer style embroidery alphabets as indicated by (
ed with the alphabet editor.

) are able to be edit-

Legacy embroidery alphabets ( ) and TrueType fonts (
cated and converted before they are editable.

) will be dupli-

To Create a New Alphabet
1. In the alphabet editor, under the alphabet drop-down, click on New
2. The New Alphabet dialog will appear. Name your new alphabet.
3. Click OK
4. The New Letter dialog will appear. Enter the Key stroke that you
wish to create.
5. Click OK
6. Create or paste your digitized letterform in the view window.
7. Adjust the position of the letterform in relation to the baseline and
cap height lines.
8. Adjust the marker for the start of the next glyph.
9. Click on New under the Letter window on the left side to create
another letter/keystroke and save the first.

To Edit an Alphabet
1. In the alphabet editor, select the alphabet or font that you would like to edit.
2. A list of glyphs contained in the alphabet is displayed below the name. Click on the glyph that you
would like to edit.
• If the alphabet is a newer style alphabet, the letterform will be displayed in the view window.
• It the alphabet is an older style or a TrueType font, the Convert Alphabet dialog will appear.
This must be completed in order to edit the letterforms.
• Name the new version of the legacy alphabet and click OK to initiate the conversion.
• The newly converted alphabet will appear and glyphs are now able to be selected and
edited.
3. After editing a letterform, click on a new glyph to save the changes.
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Creating Letterforms for an Alphabet
When planning for an alphabet, keep in mind the size that the letterforms will be scaled to. The minimum size should be considered to prevent thread breaks, and the maximum size should also be considered for gaps and push issues.
By default, glyphs are entered into the alphabet editor with one inch between the baseline and the cap
height line. This can be altered by dragging the cap height line, but it is often easiest and yields the best
results to plan for a one inch cap height.
Cap Height
Ascender
Letter
Height
Baseline
Descender

Element
Height

Example shown in Shell Script

As digitizing each letterform inside the alphabet editor may be inconvenient, digitizers often choose to
digitize all the glyphs in an alphabet in a single project. They then can copy out of that project and paste
into the editor to create the individual key strokes. This also tends to make test sew-outs a bit easier.

Editing Glyphs in the Alphabet Editor
The majority of the editing of a glyph in the alphabet editor is the same as any wireframe editing. The
biggest differences deal with the specification of spacing.
Cap Height

Glyph Origin
Next Glyph Origin

Baseline

• The position of the glyph to the origin and the cap height is easily altered by selecting and dragging
the embroidery elements in the view window. The relationship of the letterform to the origin and the
next glyph origin will determine the relationship of the letterforms when typed next to each other.
• The Next Origin point can be moved by clicking and dragging the point.
• The Cap Height can also be changed in the same way, but it is not recommended.
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Hoop Manager (Hoop Setup)
Selecting Tools>Hoop Setup will access the Hoop Manager. The Hoop Manager allows you to view information on the predefined hoops commonly used with your machine and other embroidery machines.
The Hoop Manager also allows you to create user-defined, custom hoops.

•

NOTE: With your machine type set to a specific machine, some hoops are turned off. To see all
hoops, go to the Customize Hoop List button and turn the hoops on.

•

Tip: You have the option of changing the measurement units displayed by the Hoop Manager.
To do this, select Tools->Options, then click the Measurements Units tab. Here you can select
inches or cm for Hoops.

Predefined Hoops
The Hoop Manager stores and displays the following information about predefined hoops. This information cannot be changed.
Machine Manufacturer: The Machine Manufacturer list displays several embroidery machine manufacturers. (Click the pull-down arrow to display the list, then left-click a manufacturer to select). The selected
manufacturer will determine which machines are shown in the Machine Name list.
Machine Name List: The Machine Name list displays the machines produced by the selected manufacturer. For example, your machine name will only appear in the Machine Name list when ARC - Melco
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is selected as the manufacturer. (Click the pull-down arrow to display the list, then left-click a machine
name to select). The selected machine will determine which hoops are available in the Hoop Name list.
Hoop Name: The Hoop Name list displays which hoops are associated with the selected machine. To
change which hoops are displayed in this list, click the Customize Hoop List button (located directly under
the Hoop Name pull-down menu). This will display the following dialog:

When the check box next to a hoop name is checked, the hoop will be displayed in the list. To hide a
hoop name in the list, uncheck the hoop’s corresponding check box. When you click OK to close the
dialog and display your changes, the hoop will not be visible in the list. To display a hoop that has been
hidden, simply check its corresponding check box in this dialog.

•

NOTE: The 15cm / 5.9 inch hoop will not be available in this dialog because it is the default
displayed hoop.

Part Number: This shows you the part number of the hoop you have selected.

Hoop Attributes
When a hoop is selected (click the pull-down arrow to display the list, then left-click a hoop name to
select), that hoop’s attributes will be displayed. These programmed dimensions will be grayed out; this
information cannot be changed.
• Hoop Type: the type of the selected hoop (rectangular, circular, square, etc)
• X Dimension: the width of the hoop from left to right (measured from the outside edge of one
side of the inner hoop to the outside edge of the other side of the inner hoop)
• Y Dimension: the height of the hoop from top to bottom (measured from the outside edge of
one side of the inner hoop to the outside edge of the other side of the inner hoop)
• X and Y Offset: the distance from the machine origin to the hoop center
• Hoop Thickness: the width of the outside edge of the hoop wall to the inside edge of the hoop
wall
Click OK to close the Hoop Manager dialog.
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User-Defined Hoops
Complete the following steps to create a custom hoop in the software.
1. Make sure your machine is selected in the Machine Name pull-down menu (Arc - Melco must be
selected as the Machine Manufacturer).
2. Click the Add Hoop button in the Hoop Manager window. Type in a name for the new hoop and
click OK.
3. Select a hoop shape from the Hoop Type pull-down menu.
4. Enter the attributes of the new hoop in the Hoop Attributes area.
• Hoop Type: the type of the selected hoop (rectangular, circular, square, etc.)
• X Dimension: the width of the hoop from left to right. This measurement should be from the
outside edge of one side of the inner hoop to the outside edge of the other side of the inner
hoop (see image below).
• Y Dimension: the height of the hoop from top to bottom. This measurement should be from
the outside edge of one side of the inner hoop to the outside edge of the other side of the
inner hoop (see image below).
• Hoop Thickness: the width from the outside edge of the inner hoop to the inside edge of the
inner hoop (see image below). If you do not enter a hoop thickness, the Hoop Manager will
use a default thickness of 65 points.

•

NOTE: Some hoops (such as Fast Frames) consist of a single frame rather than an inner and
outer hoop. To measure the hoop thickness of this type of hoop, measure the thickness of the
frame as shown in the example hoop below. To obtain the X dimension, measure the outer
edge of the frame horizontally (left to right). To obtain the Y dimension, measure vertically (top
to bottom) as shown in the following image. Notice that the Y dimension is not measured to
the edge of the bracket.
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• X and Y Offset: the distance from the machine origin to the hoop center. It is necessary to
enter offsets when the hoop center is not aligned with the machine origin (the needle plate
hole). Offsets will align the hoop center to the machine origin. Please note that you will not
always need an X and Y offset; for example, in many cases, only a Y offset is needed.
To measure for offsets, you must first select a predefined hoop (e.g., 15cm) from the Hoop
Selection menu, then click the Hoop Center button. Then attach the hoop you are defining to
your machine.
To measure for the X offset, measure the horizontal distance (in inches) from the hoop center
to the needle plate hole. If you need to move the hoop center to the left (your left as you face
the machine), enter a negative number for this value.
To measure for the Y offset, measure the vertical distance (in inches) from the hoop center to
the needle plate hole. If you need to move the hoop center toward the machine, enter a negative number for this value.
5. After you enter the hoop attributes, the Hoop Manager will have the information needed to create the new hoop. Click OK to save your changes and close the Hoop Manager dialog. The new
hoop will now be available from the Hoop Selection menu.
When the hoop is displayed in the View Window (the hoop will be displayed when selected in the
Hoop Selection menu), you will see two solid lines and a dashed line.

The outer solid line represents the outer edge of the inner hoop (drawn based on entered X and Y
dimensions). The inner solid line represents the inner edge of the inner hoop (the Hoop Manager
determines this by doubling the hoop thickness, then subtracting this from the X and Y dimensions). The dotted line represents the sew field for the defined hoop. The Hoop Manager determines the sew field from the value in the Default Sew Field Margin box. If you have not changed
this value, the sew field will be 126 embroidery points (approximately 0.50 inches) from the inner
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edge of the inner hoop (the inner solid line). You can change this to any desired value, and this
value will be saved with the hoop.

Additional Settings
Associated Machines - To change the machine(s) associated with the new hoop, click the Change
Associated Machines button in the Hoop Manager Properties dialog. To select a machine, left-click the
machine name, then click (>). [To select all machines click (<<)]. Click OK when you are finished selecting
machines.

You can enter an image file name (in the Bitmap File box) if you have an image of the new hoop. This
image will be displayed in the main Hoop Manager window. (The ideal size for this image is 1.3 inches
wide x 0.82 inches tall). After you type the name of the image in the Bitmap File box, copy the image file
into the following directory (Install Directory\System\Bitmaps).
Click OK or Apply when you have completed your changes.
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Custom Hoop Shape
When creating a custom hoop, the shape of your hoop may not be available from the Hoop Type menu.
If it is not, you will need to create a custom hoop shape. In our example, we will create a rectangular
hoop with round edges that is 11 x 8.5 inches (28 x 22 cm). To create a custom hoop shape:
1. Creating a custom hoop shape involves entering a
list of points that will define the shape in the Hoop
Manager. Before you open the Hoop Manager, you can
determine these points.
The easiest way to obtain these points is to trace your
hoop on a piece of paper. When tracing, trace around
the outer edge of the inner hoop. After tracing, draw
a vertical line to split the hoop exactly in half vertically
(this will be the Y axis). Next, draw a horizontal line to
split the hoop exactly in half horizontally (this will be
the X axis). The point where the two lines cross will be
the hoop center (0,0). (See the following image, which
displays the traced outline of our example hoop).
2. Now you need to determine the points you are going
to enter in the Hoop Manager . On the traced hoop,
draw up to 32 points all the way around the hoop.
You must place a point at any location where the X/Y
axes intersect with the hoop outline (see the following
image).
The more points you choose to enter, the smoother the
drawing of the hoop will be on screen. Try to place as
many points as you can on any curved areas of your
hoop. (The following image displays 28 points selected
to enter for our example hoop. Notice how most of the
points are clustered at the curves of the hoop).
3. Now you need to measure the distance from each point to the hoop center. You can take these
measurements in inches or centimeters. For each point you will need to take two measurements:
the horizontal distance from the hoop center (0,0) and the vertical distance from the hoop center.
Note that the closer the points are together, the more exact your measurements should be.
Once you have these measurements, you will need to determine the coordinates of each point in
embroidery points. For the X coordinate, multiply the horizontal distance by 254 if measured in
inches or by 100 if measured in centimeters. If the point is to the left of the hoop center, the coordinate will be a negative number. Repeat this for the Y coordinate (vertical distance). If the point
is below the hoop center, this coordinate will be a negative number. After calculating the embroidery points, round them to whole numbers. You will now have the coordinates needed to enter in
Hoop Manager.
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See the following image for examples of these measurements (note that distances were measured
in inches).

4. Click the Add Hoop button in the Hoop Manager Properties dialog. Enter a name for the new
hoop and click OK.
5. Click the Edit Hoop Shape button. You will see the Hoop Shape Definition dialog.
6. In this dialog you will enter points to plot the shape of your hoop. After you have calculated all of
your points, you can enter them in the Hoop Manager. In the Hoop Shape Definition dialog, select
Custom Shape from the Hoop Type pull-down menu.
7. In the Number of Points text box, type the number of points you will be entering. Once you type
this number, the coordinate text boxes will no longer be grayed out.
8. You can now type in the coordinates of your points, beginning with the lowest point (type this
point in the X1 and Y1 boxes). If you have more than one lowest point, enter the point that is
farthest to the left. The first point of our example hoop is indicated in the above image. After
entering the first point, proceed in a counter-clockwise direction around the hoop and enter the
remaining points.
9. The following image displays all of the points of our example hoop typed in the Hoop Shape
Definition dialog.
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After you enter all points, click the Apply button.
The Hoop Manager will notify you if the shape is invalid. For example, you will receive an error message
if your shape does not form a convex polygon (the hoop must be a convex polygon, that is, none of the
sides can be dented inward). If you received an error message, check your points to make sure you entered them correctly.
Click OK to close the Hoop Shape Definition dialog.
Your custom hoop with custom hoop shape will now be available in the Hoop Manager.

Custom Sew Field Shape
As mentioned above, the Hoop Manager will determines the sew field from the value in the Default Sew
Field Margin box (the sew field takes the shape of the defined hoop). If you wish to change the sew
field, click the Sew Field Shape button in the Hoop Manager Properties dialog. You will see the following
window:

In this window, you can either select a predefined sew field shape or create a custom sew field shape.
To select a predefined sew field shape (based on hoop types), select the type from the Hoop Type menu
(e.g., circular in the above image). To specify the sew field size, enter the X Dimension (sew field width),
Y Dimension (sew field height) and X and Y Offsets (the vertical and horizontal distances from the sew
field center to the hoop center).
You can also enter points to create a custom sew field shape. To do this, use the same procedure used to
create a custom hoop shape. (See Custom Hoop Shape for the procedure).
Clicking the Reset to Default Sew Field Value will reset the sew field to the value on the Hoop Manager
Properties dialog. (See Default Sew Field Value).
When finished, click Apply. You will receive a message if your sew field is not valid.
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DesignShop Tools & Preferences
Several tools and settings exist in the software that affect the software or projects in a more encompassing way. These tools, filters, preferences and settings follow.

Accelerator Editor
To speed your digitizing and editing as well as lessen any learning curve, you can customize the keyboard
shortcuts for your software. In this way, you can make DesignShop more closely mimic software that you
are already familiar with.
To Add A Keyboard Shortcut:
1. Go to the Tools menu and select "Accelerator Editor".
2. In the Accelerator Editor, select from the commands list the
command to which you would like to assign a keyboard shortcut. If you are attempting to assign a shortcut to a command
for which you lack the name, you can often find the name of
a tool by hovering the mouse over it and reading the tool tip
that pops up.
• Current Keys - This list will display any keyboard shortcuts that are currently assigned to the
selected command.
• Any commands shown in light grey are coded in and cannot be altered or used for another
command. You can, however, add another shortcut.
• Black commands are user commands that can be removed.
3. In the Select New Shortcut Key field, enter the keyboard shortcut as you intend to use it.
• If the shortcut is currently assigned to a alternate command, it will display in the "Currently
Affected to:" area to the left.
4. Click the Assign button to assign the shortcut to the command.
5. Continue selecting commands and assigning shortcuts.
6. Click OK to close the window and use the new keyboard shortcuts.
To Remove A Keyboard Shortcut:
1. Access the accelerator editor.
2. Select the command.
3. Select the shortcut to be removed.
4. Click Remove, then click OK.
• Reset All will remove all user defined keyboard shortcuts.

•

The accelerator keys are stored at C:\Users\{username}\AppData\Roaming\Melco\Settings\
Accelerators.xml and may be transfered to another computer to automatically use your saved
keyboard shortcuts on the new computer.
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File Options
The file options tab provides access to settings pertaining to how the
software handles files at open, save, import, and export.
To use the File Options tab:
1. Go to the Tools menu and select "Options".
2. Click on the File Options Tab.
3. Select your desired settings.
• Auto Save - when enabled, this saves a temporary file at
the specified interval. Should something happen to the
software, this auto-saved version will be available.
• The auto-saved file is stored in a temporary location. If
used as a recovery file, SAVE AS a new name in a permanent location or the file will be deleted after a time.
• Open File At - You can select to open files zoomed to actual size or to fill the screen.
• Open Graphics At - This allows you to open graphics at
the specified resolution.
• Zoom Level Actual Size - If your screen resolution is set so that 100% zoom level does not
equate to actual size on your screen, you can change the zoom level here.
• Open tiff/jpegs at resolution settings stored in file - If checked, this will open the graphic at the
resolution settings stored in the file.
• Preserve condensed connectors on open - When this is checked a jump stitch object will be
created for each portion of a condensed design that was in the needle up mode. If the box is
not checked the needle up sections of the condensed design are discarded and connectors are
created instead.
• Write icon files at save - If this box is checked before you save a file, then an icon file will be
created when you save. This means that when you go to open a file, you can click on the file
name and you will see a picture of the file to the right of your open dialog box.
• Expanded Open: Jump Stitches for Trim (0=disable) - When opening a stitch file, this feature
will translate groups of consecutive jump stitches into trim commands. If the number of jumps
in the file meets or exceeds the specified number, a trim will be created and replace the jumps.
Entering "0" in this field disables the feature.
• Vector Options - This accesses the vector options as described in the Graphics File Support
section of this document.
4. Click OK to affect the changes and close the window.
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Icon Update
Icon Update is found under Tools->Icon Update.
DesignShop includes a Windows shell extension that displays icons
for embroidery files in Explorer, Find Files, and File Open, Save, and
Save As dialogs within DesignShop. The icon files with extensions
such as .cpf and .epf (shadow files) that were produced by earlier
versions of Melco digitizing software will continue to be used by
DesignShop when available. For designs that were not produced
by Melco software, for example those purchased as a library, these
shadow files must be generated.
Icon Update scans your drives searching for embroidery files. It keeps
counts of expanded, condensed, and project (OFM) files that need to have their icons and design properties generated or updated. This only needs to be done when you first install DesignShop and whenever
you copy new embroidery designs to your drives.
To Use Icon Update
1. Specify where you want Icon generator to look for files by using the Browse... button in the
dialog.
2. Click Begin to start scanning.
3. Icon Update tells you what kind of files and how many need to be updated.
Icon Update Failures
Two things can cause Icon Update to fail. First, if it encounters non-embroidery files with extensions of
EXP, CND, or OFM, a variety of failures can occur. The offending file can be read from the line that initially contained the Target root path so you can readily identify the source of the failure. In addition, a very
small number of embroidery design errors cannot be correctly diagnosed in condensed files. This occurs
fewer than three times in a thousand files among the more than fifteen thousand files used to test Icon
Update and DesignShop. Should you experience such a failure, note the name of the offending file and
either remove it or rename it with a different file extension and restart Icon Update.
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Filters
Under Tools>Filters, you will find a few filters to ease troublesome designs and speed expanded editing.

Design Filter
Located under Tools>Filters>Design Filter, this window allows for the
following adjustments to designs.
• Accumulate Short Stitches - Accumulate Short Stitches: This
function will delete all short stitches that are equal to, or
less than, the length that you set in Short Stitch Length. This
function will filter out a series of short stitches; therefore, if
you desire to protect your lock stitches, you must enter the
number of consecutive short stitches that you want to protect
in the After Short stitch count box.
• After Short - The box below Accumulate Short Stitches, labeled After Short, is the short stitch
count. This function is used in conjunction with Accumulate Short Stitches and allows you to
determine the number of consecutive short stitches that will not be deleted when you use the
Accumulate Short Stitches function. You may enter any number up to and including 20 stitches.
• Short Stitch Length - This function allows you to enter a length, from 0 to 10 points, that defines
what is considered a short stitch by the filter. For example, if you enter a length of 3 points; then
any stitch that has a length of 3 points or less will be considered a short stitch, and will be acted
upon by the other short stitch functions.
• Accumulate Jump Stitches - When you digitize a jump stitch between two points, the computer
makes the move in increments of the stitch length you are using. For example, if the total distance
you are moving is 360 points, and your stitch length is 40 points, then the computer will generate
9 stitches (in the jump stitch mode) to cover that distance.
By turning this function ON, you will force the computer to cover the 360-point distance in increments of the maximum stitch length for the format you are using. Most multi-head machines have
a maximum stitch length of 127 points.
• Maximum Stitch Length - Any stitches greater than this value will be broken down with intervening jump stitches by the computer. For most multi-head formats this value should not exceed 127
points.
• Optimize Locks - Checking this box replaces the locks on an expanded design with a default tie
stitch. If there are no locks in an expanded design, this feature will add default tie stitches.
• Filter and Adjust Now - Use this button to apply the filters to the current design.
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Stitch Proximity Plot
The stitch proximity plot tool creates a density map for needle penetrations. In essence, it shows where
needle penetrations fall on top of each other.
To use the stitch proximity plot:
1. Go to Tools>Filters>Stitch Proximity Plot.
2. The proximity map will appear behind the stitches in the view window. It can be seen by zooming
in with the stitches not being shown in 3D, or by hiding the stitches.
3. The stitches may then be adjusted manually or by using the Stitch Proximity Filter.
4. To turn the plot off, go to Tools>Filters>Stitch Proximity Plot again.

Stitch Proximity Filter
The stitch proximity filter can be used to move expanded points away from one another in an attempt to
create a design that will sew more smoothly with fewer thread breaks.
To use the stitch proximity filter:
1. Go to Tools>Filters>Stitch Proximity Filter
2. Select your desired settings from the Stitch Proximity Filter
window.
• Max Offset dist - This setting determines how far the expanded points will be allowed to move from one another.
• Sensitivity - This adjusts the sensitivity of the filter.
• Low - This will affect only the darkest areas of a stitch proximity plot.
• Medium - This will affect more areas of the stitch proximity plot.
• High - This will affect the most areas of the project.
3. Click OK
4. The design will be filtered and turned to expanded data in the project view.

•

The Stitch Proximity Filter moves expanded points and changes all wireframe elements to expanded data.

211 of 218
Table of Contents

Batch Conversion
Under the tools menu is a batch converter. This tool is used to convert a group of embroidery files to any
supported embroidery file format.
To use the batch converter:
1. Go to Tools>Batch Converter.
2. Select your desired settings from the Batch File Converter
window.
• Source Folder - Browse to the location of the folder containing the embroidery files to be converted.
• Destination Folder - Browse to the location of the folder to
contain the newly converted files.
• Select Files - If only a few files are desired as opposed to
an entire folder, they can be browsed to and selected using this button.
• Input File Type - Select the type of embroidery file to be
converted from.
• Output File Type - Select the type of embroidery file to be
converted to.
• Convert Expanded to Wireframe - Within the process,
expanded data will be converted to wireframe elements. This is similar to the convert to wireframe operation.
• Convert Color Data - With files that store color data, this will convert the color data from what
is stored in the file (if any) to the selected color data thread chart.
3. Click the Convert button to start the conversion.
4. Results will be listed below.
5. Click Done to close the window.
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Scale Features (Global Scaling and Properties Adjustments)
The scale tab allows for the scaling and adjusting of entire wireframe and expanded designs. The adjustments made are relative to and will be subsequently applied to the individual element properties in a
wireframe design.
Any elements that the software does not detect will be greyed out as they are not applicable to the selection.
To use the scale tab:
1. Select the element(s) to be adjusted.
2. Do one of the following:
• Right-click on the selected element(s) and select "Scale"
from the context menu.
• Right-click on the selected element(s) and select
"Properties", then select the Scale category in the properties window.
• Go to Tools>Scale Factors
3. Select your desired settings from the scale options.
• Proportional Check Box - If checked, whatever change
is may to the horizontal will be reflected in the vertical
as well. If a change is made in the vertical, it too will be
reflected in the horizontal. This is to maintain the aspect
ratio while changing the size of the selected element(s).
• Horizontal - This will alter the width of the selected element(s). It can either be changed by a percent or by entering in the desired size.
• Vertical - This will alter the height of the selected element(s). It can either be changed by a
percent or by entering in the desired size.
• Column Width Adjustment / Pull Comp - This section will allow you to adjust the pull compensation, pull offset, and minimum column width for elements that the software sees as column elements. This adjustment will then be applied to the pull comp properties category of the element(s).
• Complex Fill Pull Compensation - This section will allow you to adjust the pull compensation, pull
offset, and minimum column width for elements that the software sees as complex fill elements.
This adjustment will then be applied to the pull comp properties category of the element(s).
• Scale Factors - This section will adjust the density and stitch length properties of the selected
element(s). The percentage entered will be applied to the properties of the individual elements.
• Column Density - This will adjust the density of elements the software sees as columns with
satin stitches.
• Column Fill Density - This will adjust the density of elements the software sees as columns
with fill stitches.
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• Column Fill Stitch Length - This will adjust the stitch length of elements the software sees
as columns with fill stitches.
• Walk/Underlay Stitch Length - This will adjust the stitch length of elements the software
sees as a walk element, underlay, or travel stitch.
• Fill Density - This will adjust the density of elements the software sees as complex fills.
• Fill Stitch Length - This will adjust the stitch length of elements the software sees as complex fills.

•

Scale Factors adjusts density based on stitch count, not stitch spacing. Applying 400% to a
density setting would give you more stitches as opposed to making the stitches farther apart.

Cost Factors
Cost factors allows you to calculate costs and stitch count for a design. You can choose to input the maximum
dollar value you want the design to cost and it will give you the necessary stitch count. Conversely, you can
input the stitch count you want to use and calculate the cost of sewing the design. In addition, scale factors
on this tab allow you to globally (throughout an entire design) scale some properties of wireframe elements.
The cost factors feature is available under the tools menu.
To use cost factors:
1. Go to Tools>Cost Factors.
2. Input the cost per 1,000 stitches for your company.
3. Input any additional charges that your company has, such as base
fees. cost of garment, thread, supplies, etc...
4. Change the number of stitches or the monetary amount.
5. Click Apply.
6. Cost Factors automatically adjusts all the scale factors according to
what your input was.

Business Assistant
The Business Assistant is a utility to help you calculate the cost on a per item
basis. Access the tool under the Tools menu.
You may select the machine and hoop type. Values may be entered for a
charge for each 1000 stitches and the maximum speed the design will be
sewn at. You may also enter a price for any additional charges (for example
a setup fee price).
Click the Calculate button to see the total sewing time (hours:minutes:seconds) and total price. The Business Assistant supports all monetary values
supported by the Windows regional settings.
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Convert & Restore Alphabets
A portion of the older style embroidery alphabets contain tie stitches manually digitized into the letterforms. The newer style of embroidery alphabets do not contain ties and instead rely on the use of object
properties to add the tie stitches.
Adding tie stitches to older alphabets that already contain ties will double up on the tie stitches. This can
potentially cause a visible thread bump in the letter as well a possible trim failures.

Remove Ties From Alphabets
To treat all alphabets the same and utilize object properties to add tie
stitches, the digitized ties can be removed from older style alphabets.
To remove the digitized tie stitches from any alphabets that contain
them:
1. Go to Tools>Convert Alphabets.
2. Click on the Remove Ties button.

Restore Ties To Alphabets
If, after removing the tie stitches from the older alphabets, you decide you want them back, they may be
restored. To do this:
1. Go to Tools>Restore Alphabets.
2. Click on the Restore Now button.
This will only restore tie stitches to alphabets that originally had them. It will not add ties stitches to alphabets that did not originally contain them.

Convert Alphabets
Older style alphabets may be converted to newer style alphabets for ease of editing in the Alphabet
Editor. TrueType fonts may also be converted to an alphabet that may be edited. This can be done in the
alphabet editor, or it may be done using the Convert Alphabets window.
To convert alphabets:
1. Go to Tools>Convert Alphabets.
2. Select the alphabet from the alphabet dropdown.
3. The Convert To drop-down will automatically populate with the appropriate type of alphabet.
• OFA - This is the newer style of alphabet.
• TTM - This is a TrueType that has been modified for use with the Alphabet Editor.
4. Name the alphabet.
5. Click the Convert button.
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Check for Updates
The software comes with the ability to check the Internet for updates. If found, the newer software will
be downloaded and installed. This feature only works within the same version number.
To check for updates:
1. Go to Tools>Check For Updates
2. Follow the on screen prompts.

System Info
For troubleshooting and helping Technical Support help you, the software can generate a text document
listing all the relevant system information. This document can be e-mailed to support staff to speed their
assistance.
To generate the system information document:
1. Go to Tools>System Information
2. McSysInfo.txt will appear in the root of your hard drive. This document can then be attached to an
e-mail and sent to support staff.

Restore Factory Defaults
If you have change the defaults of the software, you can selectively
restore the defaults. To do this:
1. Go to Tools>Factory Defaults
2. Place checks by the items to be restored or excluded from the
restoration.
3. Check the "Don't change selected items" if you would prefer
them to be excluded.
4. Click OK.

Logo Express
Logo Express is a web service for digitizing artwork and converting raster artwork into vector artwork.
To access this service:
1. Go to Help>Web Links>Logo Express
2. Register for the online service via their web page.

216 of 218
Table of Contents

Melco OS Settings
Some of the settings for the embroidery machine may be set in DesignShop. This feature is completely
dependent on the machine and operating software being able to retrieve these settings. Not all machines
or operating softwares can access these settings.
To set up the machine settings:
1. Go to Tools>Melco OS Settings.
2. Populate the machine settings as you would in the operating software.
3. Click OK.
4. The next time the file is saved, the machine settings will be saved with it.

Security
The security window displays Melco security keys currently attached
to your computer. This will allow you to see the product levels, serial
numbers, and device IDs. It will also allow you to deactivate some
products and free the license for use on another device.
To access the security window, go to Tools>Security.
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Software Activation & Deactivation
DesignShop uses a virtual security key as opposed to a physical one. This means that when you initially
launch your software, you will be prompted to activate the product using the product serial number.
DesignShop may be installed on multiple computers, but only one activated software is allowed at one time.
One activation is allowed per product serial number at any given time.

Sizer
If the product is not activated, it can run in Sizer.
Sizer is a limited version of the software that allows for the opening, saving, colorizing, and limited scaling of design files.
To run in Sizer, click on the Sizer button on the first Product Activation page.

•

If an alternate security key is present that allows for the running of DesignShop Lite, the Sizer
button will be a Lite button and DesignShop Lite may be launched from this page.

Product Activation
To activate the product:
1. In the initial activation page that comes up when you launch the software, enter the following
information:
• Product Serial Number - This number is most likely found on the
software package. Do not lose this number.
• Device Identification Number - This number will be generated by
the software and entered for you.
• Activation Code - If you are connected to the Internet, you may attempt to automatically obtain this number by clicking the Activate button. This is the fastest and easiest way to activate
your software.
• If you are not connected to the Internet, follow the on screen instructions to obtain an activation code through an alternative Internet-enabled device.

Product Deactivation
To deactivate the software and free the license for use on another device, follow the steps below:
1. Access the product deactivation page using one of the following methods.
• Go to Tools>Deactivate Product.
• Go to Tools>Security, and click on the Deactivate button in the General tab.
2. Follow the on-screen instructions and retain the deactivation code.
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